summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoranlorsp2023-12-31 14:11:57 +0800
committeranlorsp2023-12-31 14:11:57 +0800
commit4e17e8b207a21a52c7f80e404bde827815b1a462 (patch)
tree984f1e31200caa746d8ed402232c4d32bc0edebc
downloadaur-4e17e8b207a21a52c7f80e404bde827815b1a462.tar.gz
first commit
-rw-r--r--.SRCINFO21
-rw-r--r--LICENSE21
-rw-r--r--PKGBUILD29
-rw-r--r--bilibili_manga_downloader-bin.install19
-rwxr-xr-xbilibili_manga_downloader.desktop9
-rw-r--r--bilibili_manga_downloader.pngbin0 -> 100179 bytes
6 files changed, 99 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..872d5c728746
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = bilibili_manga_downloader-bin
+ pkgdesc = 基于现代GUI的跨平台哔哩哔哩漫画下载器(支持特典下载)
+ pkgver = 3.2.2
+ pkgrel = 1
+ url = https://github.com/MOMOYATW/bilibili_manga_downloader
+ install = bilibili_manga_downloader-bin.install
+ arch = x86_64
+ license = MIT
+ depends = gtk3
+ depends = alsa-lib
+ depends = nss
+ source = https://github.com/MOMOYATW/bilibili_manga_downloader/releases/download/v3.2.2/bilibili-manga-downloader_3.2.2_linux_amd64.tar.gz
+ source = bilibili_manga_downloader.png
+ source = LICENSE
+ source = bilibili_manga_downloader.desktop
+ sha256sums = 841cc1c8310d8d83d73ddab34864869e4b74c69f5a35bbbc8fb9a5d668ebd815
+ sha256sums = ef0ef9c1c65b0aa8c3db6c5dde705336ee7725abd97372eba40cfe71be1816be
+ sha256sums = 9d60cfeddb5c57bfa82b7ece15cc0b270badb5d00cbfbf4d66945a77ee28e662
+ sha256sums = 5221e18d15de713a946a57d43c89f0456ce7e95509ae3d65aa60591b8552baae
+
+pkgname = bilibili_manga_downloader-bin
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..2509a788fcd2
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,21 @@
+MIT License
+
+Copyright (c) 2023 Ye Tao
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e7e1dceda79b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: anlorsp <anlor[at]anlor[dot]top>
+pkgname=bilibili_manga_downloader-bin
+_pkgname=bilibili_manga_downloader
+pkgver=3.2.2
+pkgrel=1
+pkgdesc="基于现代GUI的跨平台哔哩哔哩漫画下载器(支持特典下载)"
+arch=('x86_64')
+url="https://github.com/MOMOYATW/bilibili_manga_downloader"
+license=('MIT')
+depends=('gtk3' 'alsa-lib' 'nss')
+install="${pkgname}.install"
+source=("https://github.com/MOMOYATW/bilibili_manga_downloader/releases/download/v${pkgver}/bilibili-manga-downloader_${pkgver}_linux_amd64.tar.gz"
+ "${_pkgname}.png"
+ "LICENSE"
+ "${_pkgname}.desktop")
+sha256sums=('841cc1c8310d8d83d73ddab34864869e4b74c69f5a35bbbc8fb9a5d668ebd815'
+ 'ef0ef9c1c65b0aa8c3db6c5dde705336ee7725abd97372eba40cfe71be1816be'
+ '9d60cfeddb5c57bfa82b7ece15cc0b270badb5d00cbfbf4d66945a77ee28e662'
+ '5221e18d15de713a946a57d43c89f0456ce7e95509ae3d65aa60591b8552baae')
+
+package() {
+ install -d "${pkgdir}/opt/${_pkgname}"
+
+ install -Dm644 "${_pkgname}.png" "${pkgdir}/usr/share/icons/${_pkgname}.png"
+ install -Dm644 "${_pkgname}.desktop" "${pkgdir}/usr/share/applications/${_pkgname}.desktop"
+ install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+ cp -r "${srcdir}/linux-unpacked/"* "${pkgdir}/opt/${_pkgname}"
+}
diff --git a/bilibili_manga_downloader-bin.install b/bilibili_manga_downloader-bin.install
new file mode 100644
index 000000000000..faa3e39850fc
--- /dev/null
+++ b/bilibili_manga_downloader-bin.install
@@ -0,0 +1,19 @@
+msg_blue() {
+ printf "${blue}==>${bold} $1${all_off}\n"
+}
+
+note() {
+ printf "${blue}==>${yellow} 注意:${bold} $1${all_off}\n"
+}
+
+all_off="$(tput sgr0)"
+bold="${all_off}$(tput bold)"
+blue="${bold}$(tput setaf 4)"
+yellow="${bold}$(tput setaf 3)"
+post_install() {
+ note ""
+}
+post_upgrade() {
+ post_install
+}
+
diff --git a/bilibili_manga_downloader.desktop b/bilibili_manga_downloader.desktop
new file mode 100755
index 000000000000..b2eaaa04e217
--- /dev/null
+++ b/bilibili_manga_downloader.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=Bilibili Manga Downloader
+Exec=/opt/bilibili_manga_downloader/bilibili-manga-downloader %u
+Terminal=false
+Type=Application
+Icon=bilibili_manga_downloader
+StartupWMClass=Bilibili Manga Downloader
+Comment=Bilibili Manga Downloader
+Categories=Utility;
diff --git a/bilibili_manga_downloader.png b/bilibili_manga_downloader.png
new file mode 100644
index 000000000000..2f04d265170c
--- /dev/null
+++ b/bilibili_manga_downloader.png
Binary files differ