summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGitHub Action2023-10-03 14:27:42 +0000
committerGitHub Action2023-10-03 14:27:42 +0000
commitd2a4b0135cbbfb6892eae2fab06ef370201b2252 (patch)
treed6f50899bbe2be204397820076665bda146ebac6
parentf08c9f69896aa47131b7bbd805cdb482e121b456 (diff)
downloadaur-d2a4b0135cbbfb6892eae2fab06ef370201b2252.tar.gz
Update from GitHub Actions: bilili: update to 1.4.14-1
https://github.com/ouuan/AUR-packages/actions/runs/6394386097
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD13
2 files changed, 13 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5eb5f14c5fa4..5f821c251d17 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,18 @@
pkgbase = bilili
pkgdesc = bilibili video and danmaku downloader | B站视频、弹幕下载器
- pkgver = 1.4.13
+ pkgver = 1.4.14
pkgrel = 1
- url = https://github.com/SigureMo/bilili
+ url = https://github.com/yutto-dev/bilili
arch = any
license = GPL3
- makedepends = python-setuptools
+ makedepends = python-build
+ makedepends = python-installer
makedepends = python-wheel
+ makedepends = python-setuptools
depends = python-requests
depends = python-biliass
depends = ffmpeg
- source = https://pypi.io/packages/source/b/bilili/bilili-1.4.13.tar.gz
- sha256sums = 78aae85dbf82c9e35db13e8ca1b02b419f0e426126ad6b8c0307f2d290032752
+ source = https://pypi.io/packages/source/b/bilili/bilili-1.4.14.tar.gz
+ sha256sums = 58c58e12f838fd355c016c0d9b2255c423c388d4ce7b2407928e6a0320ceff59
pkgname = bilili
diff --git a/PKGBUILD b/PKGBUILD
index 584e77d6ee37..1885dd1f22a1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,23 @@
# Maintainer: Yufan You <ouuansteve at gmail>
pkgname=bilili
-pkgver=1.4.13
+pkgver=1.4.14
pkgrel=1
pkgdesc='bilibili video and danmaku downloader | B站视频、弹幕下载器'
arch=('any')
-url='https://github.com/SigureMo/bilili'
+url='https://github.com/yutto-dev/bilili'
license=('GPL3')
depends=('python-requests' 'python-biliass' 'ffmpeg')
-makedepends=('python-setuptools' 'python-wheel')
+makedepends=(python-build python-installer python-wheel python-setuptools)
source=("https://pypi.io/packages/source/${pkgname:0:1}/$pkgname/$pkgname-$pkgver.tar.gz")
-sha256sums=('78aae85dbf82c9e35db13e8ca1b02b419f0e426126ad6b8c0307f2d290032752')
+sha256sums=('58c58e12f838fd355c016c0d9b2255c423c388d4ce7b2407928e6a0320ceff59')
build() {
cd "$pkgname-$pkgver"
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
cd "$pkgname-$pkgver"
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
- rm -rf "$pkgdir/usr/lib/"*"/site-packages/tests" || true
+ python -m installer --destdir="$pkgdir" dist/*.whl
}