summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAthaudia2016-02-11 18:53:42 +0100
committerAthaudia2016-02-11 18:53:42 +0100
commit32008aeefca94db464c2df0c82430bc2e3a78a5c (patch)
tree4b736e3b366fe20739b6600e0f37e3c8632b075d
downloadaur-32008aeefca94db464c2df0c82430bc2e3a78a5c.tar.gz
initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD36
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e264c8c73dd1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+# Generated by makepkg 5.0.0
+# Thu Feb 11 17:52:34 UTC 2016
+pkgbase = bin2tap
+ pkgdesc = ZX Spectrum .bin to .tap converter
+ pkgver = 1.3
+ pkgrel = 1
+ url = http://zeroteam.sk/bin2tap.html
+ arch = i686
+ arch = x86_64
+ license = unknown
+ source = http://zeroteam.sk/files/bin2tap13.zip
+ md5sums = 08124a53e1452d978e1d3baca0eeba51
+
+pkgname = bin2tap
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0a3fea0f2944
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Athaudia <athaudia at gmail dot com>
+pkgname=bin2tap
+pkgver=1.3
+pkgrel=1
+epoch=
+pkgdesc="ZX Spectrum .bin to .tap converter"
+arch=('i686' 'x86_64')
+url="http://zeroteam.sk/bin2tap.html"
+license=('unknown')
+groups=()
+depends=()
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("http://zeroteam.sk/files/bin2tap13.zip")
+noextract=()
+md5sums=('08124a53e1452d978e1d3baca0eeba51')
+validpgpkeys=()
+
+build() {
+ cd "$pkgname"
+ gcc -O2 bin2tap.c -o "$pkgname"
+}
+
+package() {
+ cd "$pkgname"
+ mkdir -p $pkgdir/usr/bin/
+ install "$pkgname" $pkgdir/usr/bin/
+}