summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjose17112016-11-21 07:07:39 +0100
committerjose17112016-11-21 07:07:39 +0100
commit7481884298d276bc638c88c2628d79c09874360e (patch)
treef791803a47005c8edcc83642afcdf17c4093eca0
parentb5ea7dff310ca7c69c5361c26b98608ab06d84c7 (diff)
downloadaur-7481884298d276bc638c88c2628d79c09874360e.tar.gz
Fixed makedeps + missing libstdc++ lib
-rw-r--r--.SRCINFO10
-rwxr-xr-x4L-cli2
-rw-r--r--PKGBUILD18
-rw-r--r--lightscribe.desktop2
4 files changed, 20 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 55241fb8a274..ce71698af577 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Fri Dec 11 13:22:24 UTC 2015
+# Mon Nov 21 06:03:41 UTC 2016
pkgbase = bin32-4l
pkgdesc = 4L: LaCie LightScribe Labeler for Linux
pkgver = 1.0r6
- pkgrel = 8
+ pkgrel = 9
url = http://www.lacie.com/products/product.htm?pid=10803
install = 4l.install
arch = x86_64
@@ -20,9 +20,13 @@ pkgbase = bin32-4l
source = 4L-1.0-r6.i586.rpm::http://www.lacie.com/files/lacie-content/download/drivers/LaCie%20LightScribe%20Labeler%201.0%20Linux.rpm
source = lightscribe.png
source = lightscribe.desktop
+ source = 4L-cli
+ source = libstdc++.so.5::https://dl.dropboxusercontent.com/u/29095940/oss/libstdc%2B%2B.so.5
md5sums = 11fc8b2daeaed2b61a567056413bdefd
md5sums = 582b6cce827c8909115a31c7bc10d6ce
- md5sums = 48d1af9e30a21f6ec1f8c85151b3a652
+ md5sums = c6e2b9fb763819213e48c7861ae23431
+ md5sums = 3c33a7b89acf9abfc5266b6a4e98e75f
+ md5sums = ca9f92eb5fcb3598fabc2cc6c7125054
pkgname = bin32-4l
diff --git a/4L-cli b/4L-cli
new file mode 100755
index 000000000000..98aa01582578
--- /dev/null
+++ b/4L-cli
@@ -0,0 +1,2 @@
+#!/usr/bin/bash
+/usr/bin/gksudo -k -- LD_LIBRARY_PATH=/opt/4L/lib /opt/4L/4L-cli.bin "$@"
diff --git a/PKGBUILD b/PKGBUILD
index f783d50fa191..6329f75b1291 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,31 +6,33 @@
pkgname=bin32-4l
pkgver=1.0r6
_realname=4L-1.0-r6
-pkgrel=8
+pkgrel=9
pkgdesc="4L: LaCie LightScribe Labeler for Linux"
arch=('x86_64')
url="http://www.lacie.com/products/product.htm?pid=10803"
license=('unknown')
install=4l.install
depends=('lib32-fontconfig' 'lib32-gcc-libs' 'lib32-libxcursor' 'lib32-libxi' 'lib32-libxinerama' 'lib32-libxrandr' 'bin32-lightscribe')
-makedepends=('rpmextract')
conflicts=('4l_x86_64')
-source=($_realname.i586.rpm::http://www.lacie.com/files/lacie-content/download/drivers/LaCie%20LightScribe%20Labeler%201.0%20Linux.rpm lightscribe.png lightscribe.desktop)
+source=($_realname.i586.rpm::http://www.lacie.com/files/lacie-content/download/drivers/LaCie%20LightScribe%20Labeler%201.0%20Linux.rpm lightscribe.png lightscribe.desktop 4L-cli libstdc++.so.5::https://dl.dropboxusercontent.com/u/29095940/oss/libstdc%2B%2B.so.5)
md5sums=('11fc8b2daeaed2b61a567056413bdefd'
- '582b6cce827c8909115a31c7bc10d6ce'
- '48d1af9e30a21f6ec1f8c85151b3a652')
+ '582b6cce827c8909115a31c7bc10d6ce'
+ 'c6e2b9fb763819213e48c7861ae23431'
+ '3c33a7b89acf9abfc5266b6a4e98e75f'
+ 'ca9f92eb5fcb3598fabc2cc6c7125054')
package() {
cd $srcdir
- rpmextract.sh 4L-1.0-r6.i586.rpm 2> /dev/null
- mkdir -p $pkgdir/{opt,usr/bin}
+ mkdir -p $pkgdir/{opt/4L/lib,usr/bin}
+ install -D -m644 $srcdir/libstdc++.so.5 $pkgdir/opt/4L/lib/libstdc++.so.5
cp -R usr/4L $pkgdir/opt
+ mv $pkgdir/opt/4L/4L-cli $pkgdir/opt/4L/4L-cli.bin
+ install -m755 $srcdir/4L-cli $pkgdir/opt/4L
cd $pkgdir/usr/bin
ln -s ../../opt/4L/4L-cli 4L-cli
ln -s ../../opt/4L/4L-gui 4L-gui
find $pkgdir/opt -type d -exec chmod 755 {} \;
chmod -x $pkgdir/opt/4L/*/*
- chmod +s $pkgdir/opt/4L/4L-cli
install -D -m644 $srcdir/lightscribe.png ${pkgdir}/usr/share/pixmaps/lightscribe.png
install -D -m644 $srcdir/lightscribe.desktop ${pkgdir}/usr/share/applications/lightscribe.desktop
}
diff --git a/lightscribe.desktop b/lightscribe.desktop
index 595e55000f21..1c400417a13e 100644
--- a/lightscribe.desktop
+++ b/lightscribe.desktop
@@ -3,7 +3,7 @@
Name=Lightscribe
Comment=4L: LaCie LightScribe Labeler for Linux
Encoding=UTF-8
-Exec=4L-gui
+Exec=env LD_LIBRARY_PATH=/opt/4L/lib 4L-gui
Icon=lightscribe
Type=Application
Icon=lightscribe.png