summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoramagura2017-04-21 17:14:08 -0600
committeramagura2017-04-21 17:14:08 -0600
commite5776cb0bdd79808430d7e0c0130de1006d9423e (patch)
tree398b28d3d25e01ee84f0b59098d34a96b1a2527d
parentba63cb45f6762cbe43a78ab63ad9a04018f2227a (diff)
downloadaur-e5776cb0bdd79808430d7e0c0130de1006d9423e.tar.gz
fixes the whole libcurl issue
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD8
-rw-r--r--bin32-epsxe.sh2
3 files changed, 19 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8e1382531e78..2a1da88a41c3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,14 @@
# Generated by mksrcinfo v8
-# Thu Apr 20 23:58:55 UTC 2017
+# Fri Apr 21 23:13:55 UTC 2017
pkgbase = bin32-epsxe
pkgdesc = Enhanced PSX emulator (32-bit)
pkgver = 2.0.5
- pkgrel = 1
+ pkgrel = 2
url = http://epsxe.com
install = bin32-epsxe.install
arch = i686
arch = x86_64
license = unknown
- depends = gtk3
- depends = sdl_ttf
- depends = libtinfo
- depends = libcurl-compat
options = !strip
source = bin32-epsxe.desktop
source = bin32-epsxe.png
@@ -20,8 +16,18 @@ pkgbase = bin32-epsxe
source = http://www.epsxe.com/files/ePSXe205linux.zip
md5sums = aeb34e2ca34f968630ca133ea821c61c
md5sums = eb0c46b8ae1355c589792f6be1835e47
- md5sums = 071c43c1cb8f6b6470b7af60ad69247a
+ md5sums = 317eb969b7a84a810169422d28fb8093
md5sums = 3e1976822eb260722b31c9f24cb1d6e1
+ depends_i686 = gtk3
+ depends_i686 = sdl_ttf
+ depends_i686 = lib32-libtinfo
+ depends_i686 = libcurl-compat
+ depends_x86_64 = lib32-gtk3
+ depends_x86_64 = lib32-libxt
+ depends_x86_64 = lib32-sdl_ttf
+ depends_x86_64 = lib32-libtinfo
+ depends_x86_64 = lib32-libcurl-compat
+ depends_x86_64 = lib32-libcanberra-gtk3
pkgname = bin32-epsxe
diff --git a/PKGBUILD b/PKGBUILD
index 87339cd45fd1..82f45b5eb46c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,18 +4,20 @@
pkgname=bin32-epsxe
_pkgname=ePSXe
pkgver=2.0.5
-pkgrel=1
+pkgrel=2
pkgdesc="Enhanced PSX emulator (32-bit)"
url="http://epsxe.com"
arch=('i686' 'x86_64')
-depends=(gtk3 sdl_ttf libtinfo libcurl-compat)
+depends_i686+=(gtk3 sdl_ttf lib32-libtinfo libcurl-compat)
+#depends=(gtk3 sdl_ttf libtinfo libcurl-compat)
+depends_x86_64=(lib32-gtk3 lib32-libxt lib32-sdl_ttf lib32-libtinfo lib32-libcurl-compat lib32-libcanberra-gtk3)
license=('unknown')
install=${pkgname}.install
options=(!strip)
source=(${pkgname}.desktop ${pkgname}.png ${pkgname}.sh)
md5sums=('aeb34e2ca34f968630ca133ea821c61c'
'eb0c46b8ae1355c589792f6be1835e47'
- '071c43c1cb8f6b6470b7af60ad69247a')
+ '317eb969b7a84a810169422d28fb8093')
source+=("http://www.epsxe.com/files/ePSXe${pkgver//./}linux.zip")
md5sums+=('3e1976822eb260722b31c9f24cb1d6e1')
diff --git a/bin32-epsxe.sh b/bin32-epsxe.sh
index 6205eb9b980e..cdefca8383c9 100644
--- a/bin32-epsxe.sh
+++ b/bin32-epsxe.sh
@@ -1,4 +1,4 @@
#!/usr/bin/env bash
-LD_LIBRARY_PATH+=:/opt/epsxe LD_PRELOAD=/usr/lib32/libcurl.so.3 /opt/epsxe/epsxe "$@"
+LD_LIBRARY_PATH+=:/opt/epsxe LD_PRELOAD=/usr/lib32/libcurl.so.3 /opt/bin32-epsxe/bin32-epsxe "$@"