summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSwift Geek2015-07-09 06:06:28 +0200
committerSwift Geek2015-07-09 06:06:28 +0200
commite23048511305c43a6caac36cc0642c764008dcf1 (patch)
tree29403c5cbe04521526f8e6b5b1293839f6601c35
downloadaur-e23048511305c43a6caac36cc0642c764008dcf1.tar.gz
Initial import to AUR4
-rw-r--r--.SRCINFO32
-rw-r--r--PKGBUILD50
-rw-r--r--firefox32-safe.desktop13
-rw-r--r--firefox32.desktop86
-rw-r--r--mozplugin.patch13
5 files changed, 194 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..909fefc31a42
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,32 @@
+pkgbase = bin32-firefox
+ pkgdesc = Firefox 32bit for Arch 64 bit (en-US)
+ pkgver = 39.0
+ pkgrel = 1
+ url = http://www.mozilla.org/projects/firefox
+ arch = x86_64
+ license = MPL
+ license = GPL
+ license = LGPL
+ depends = lib32-dbus-glib
+ depends = lib32-gtk2
+ depends = lib32-libxt
+ depends = lib32-alsa-lib
+ depends = lib32-nss
+ depends = lib32-xcb-util
+ optdepends = bin32-firefox-i18n: i18n support
+ optdepends = lib32-flashplugin: flash support
+ optdepends = bin32-acroread: adobe reader plugin
+ optdepends = bin32-icedtea-web: java plugin
+ optdepends = lib32-librsvg: svg_loader.so library
+ optdepends = lib32-gtk-engines: libclearlooks.so library
+ source = https://ftp.mozilla.org/pub/mozilla.org/firefox/releases/39.0/linux-i686/en-US/firefox-39.0.tar.bz2
+ source = firefox32.desktop
+ source = firefox32-safe.desktop
+ source = mozplugin.patch
+ md5sums = 5018deec1f7e992deb251a8fc5f0ffd3
+ md5sums = 467b7e46030ee36d7a0e0752d0fa5480
+ md5sums = 9957b560418ad4baf6c6a0d015df2b15
+ md5sums = 8ef4b2a15b9d5e9d5bd5df323dbf012f
+
+pkgname = bin32-firefox
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6088b89f168e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer: Swift Geek
+# Contributor: c0nd0r <gcesarmza@gmail.com>
+# Contributor: Thomas Dziedzic < gostrc at gmail >
+# Contributor: webjdm <web.jdm@gmail.com>
+# Contributor: magedon <magedon.zt@gmail.com>
+
+pkgname=bin32-firefox
+pkgver=39.0
+pkgrel=1
+pkgdesc="Firefox 32bit for Arch 64 bit (en-US)"
+arch=('x86_64')
+_arch=i686
+license=('MPL' 'GPL' 'LGPL')
+url="http://www.mozilla.org/projects/firefox"
+depends=('lib32-dbus-glib' 'lib32-gtk2' 'lib32-libxt' 'lib32-alsa-lib' 'lib32-nss' 'lib32-xcb-util')
+optdepends=('bin32-firefox-i18n: i18n support'
+ 'lib32-flashplugin: flash support'
+ 'bin32-acroread: adobe reader plugin'
+ 'bin32-icedtea-web: java plugin'
+ 'lib32-librsvg: svg_loader.so library'
+ 'lib32-gtk-engines: libclearlooks.so library')
+source=("https://ftp.mozilla.org/pub/mozilla.org/firefox/releases/$pkgver/linux-$_arch/en-US/firefox-$pkgver.tar.bz2"
+ 'firefox32.desktop' 'firefox32-safe.desktop' 'mozplugin.patch')
+md5sums=('5018deec1f7e992deb251a8fc5f0ffd3'
+ '467b7e46030ee36d7a0e0752d0fa5480'
+ '9957b560418ad4baf6c6a0d015df2b15'
+ '8ef4b2a15b9d5e9d5bd5df323dbf012f')
+package() {
+ # directory and files
+ cd ${pkgdir}
+ mkdir -p {usr/bin,usr/lib32}
+ cp -r ${srcdir}/firefox usr/lib32/${pkgname}
+ mv usr/lib32/${pkgname}/firefox usr/lib32/${pkgname}/firefox32
+ mv usr/lib32/${pkgname}/firefox-bin usr/lib32//${pkgname}/firefox32-bin
+ cat <<EOF > usr/bin/${pkgname}
+#!/bin/bash
+/usr/lib32/${pkgname}/run-mozilla.sh /usr/lib32/${pkgname}/firefox32 \$*
+EOF
+ chmod +x usr/bin/${pkgname}
+
+ # desktop icons
+ cd ${srcdir}
+ install -d ${pkgdir}/usr/share/applications
+ install -Dm644 firefox32.desktop firefox32-safe.desktop ${pkgdir}/usr/share/applications
+ install -Dm644 firefox/browser/icons/mozicon128.png ${pkgdir}/usr/share/pixmaps/firefox32.png
+
+ # set MOZ_PLUGIN_PATH variable
+ cd ${pkgdir}/usr/lib32/${pkgname}
+ patch -Np0 -i ${srcdir}/mozplugin.patch
+}
diff --git a/firefox32-safe.desktop b/firefox32-safe.desktop
new file mode 100644
index 000000000000..c1de3b6ef5d7
--- /dev/null
+++ b/firefox32-safe.desktop
@@ -0,0 +1,13 @@
+[Desktop Entry]
+Version=1.0
+Encoding=UTF-8
+Name=Firefox32 - Safe Mode
+Exec=bin32-firefox -safe-mode %u
+Icon=firefox32
+Type=Application
+Terminal=false
+MultipleArgs=false
+GenericName=Web Browser - Safe Mode
+StartupNotify=false
+Categories=Application;Network;
+
diff --git a/firefox32.desktop b/firefox32.desktop
new file mode 100644
index 000000000000..d86443962617
--- /dev/null
+++ b/firefox32.desktop
@@ -0,0 +1,86 @@
+[Desktop Entry]
+Version=1.0
+Encoding=UTF-8
+Name=Firefox32
+Exec=bin32-firefox %u
+Icon=firefox32
+Type=Application
+Terminal=false
+MultipleArgs=false
+Name[bn]=ফায়ারফক্স32
+Name[eo]=Fajrovulpo32
+Name[fi]=Firefox32
+Name[pa]=ਫਾਇਰਫੋਕਸ32
+Name[tg]=Рӯбоҳи оташин32
+GenericName=Web Browser
+GenericName[af]=Web Blaaier
+GenericName[ar]=متصفح ويب
+GenericName[az]=Veb Səyyahı
+GenericName[bg]=Браузър
+GenericName[bn]=ওয়েব ব্রাউজার
+GenericName[br]=Furcher ar Gwiad
+GenericName[bs]=WWW Preglednik
+GenericName[ca]=Fullejador web
+GenericName[cs]=WWW prohlížeč
+GenericName[cy]=Porydd Gwe
+GenericName[da]=Browser
+GenericName[de]=Web-Browser
+GenericName[el]=Περιηγητής Ιστού
+GenericName[eo]=TTT-legilo
+GenericName[es]=Navegador web
+GenericName[et]=Veebilehitseja
+GenericName[eu]=Web arakatzailea
+GenericName[fa]=مرورگر وب
+GenericName[fi]=WWW-selain
+GenericName[fo]=Alnótsfar
+GenericName[fr]=Navigateur web
+GenericName[gl]=Navegador Web
+GenericName[he]=דפדפן אינטרנט
+GenericName[hi]=वेब ब्राउज़र
+GenericName[hr]=Web preglednik
+GenericName[hu]=Webböngésző
+GenericName[is]=Vafri
+GenericName[it]=Browser Web
+GenericName[ja]=ウェブブラウザ
+GenericName[ko]=웹 브라우저
+GenericName[lo]=ເວັບບຣາວເຊີ
+GenericName[lt]=Žiniatinklio naršyklė
+GenericName[lv]=Web Pārlūks
+GenericName[mk]=Прелистувач на Интернет
+GenericName[mn]=Веб-Хөтөч
+GenericName[nb]=Nettleser
+GenericName[nds]=Nettkieker
+GenericName[nl]=Webbrowser
+GenericName[nn]=Nettlesar
+GenericName[nso]=Seinyakisi sa Web
+GenericName[pa]=ਵੈਬ ਝਲਕਾਰਾ
+GenericName[pl]=Przeglądarka WWW
+GenericName[pt]=Navegador Web
+GenericName[pt_BR]=Navegador Web
+GenericName[ro]=Navigator de web
+GenericName[ru]=Веб-браузер
+GenericName[se]=Fierpmádatlogan
+GenericName[sk]=Webový prehliadač
+GenericName[sl]=Spletni brskalnik
+GenericName[sr]=Веб претраживач
+GenericName[sr@Latn]=Veb pretraživač
+GenericName[ss]=Ibrawuza yeWeb
+GenericName[sv]=Webbläsare
+GenericName[ta]=வலை உலாவி
+GenericName[tg]=Тафсиргари вэб
+GenericName[th]=เว็บบราวเซอร์
+GenericName[tr]=Web Tarayıcı
+GenericName[uk]=Навігатор Тенет
+GenericName[uz]=Веб-браузер
+GenericName[ven]=Buronza ya Webu
+GenericName[vi]=Trình duyệt Web
+GenericName[wa]=Betchteu waibe
+GenericName[xh]=Umkhangeli zincwadi we Web
+GenericName[zh_CN]=网页浏览器
+GenericName[zh_TW]=網頁瀏覽器
+GenericName[zu]=Umcingi we-Web
+MimeType=text/html;
+StartupNotify=true
+Categories=Application;Network;
+Name[fr_FR]=Firefox32
+
diff --git a/mozplugin.patch b/mozplugin.patch
new file mode 100644
index 000000000000..b770edb7c335
--- /dev/null
+++ b/mozplugin.patch
@@ -0,0 +1,13 @@
+*** run-mozilla.sh 2011-09-27 19:41:54.215636203 -0300
+--- run-mozilla.sh 2011-09-27 19:47:14.591053402 -0300
+***************
+*** 41,46 ****
+--- 41,48 ----
+ MOZ_APPRUNNER_NAME="./mozilla-bin"
+ MOZ_PROGRAM=""
+
++ MOZ_PLUGIN_PATH="/opt/mozilla/lib/plugins:/usr/lib32/mozilla/plugins"
++
+ exitcode=1
+ #
+ ##