summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjose17112016-08-17 23:17:01 +0200
committerjose17112016-08-17 23:17:01 +0200
commit03202aa5330d0c063e6eaa13b148d36d9f36f8ea (patch)
treeb0fb64a8b64b1d38b7ab0513a999797bfb3eccd2
parentae537b2a62e0affaf23af5dfdf119f5bf6ee6591 (diff)
downloadaur-03202aa5330d0c063e6eaa13b148d36d9f36f8ea.tar.gz
Fix PKGBUILD
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD13
-rw-r--r--SimpleLabeler3
3 files changed, 16 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fd5199c968ac..eb7e989813e1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Fri May 13 20:56:43 UTC 2016
+# Wed Aug 17 21:16:45 UTC 2016
pkgbase = bin32-lightscribe-labeler
pkgdesc = LightScribe Simple Labeler
pkgver = 1.18.15.1
- pkgrel = 4
+ pkgrel = 5
url = http://www.pawtec.com/lightscribe
arch = x86_64
license = custom
@@ -21,8 +21,12 @@ pkgbase = bin32-lightscribe-labeler
options = !strip
source = http://www.pawtec.com/lightscribe_files/Linux/LSL/lightscribeApplications-1.18.15.1-linux-2.6-intel.rpm
source = lightscribe-labeler.desktop
+ source = libstdc++.so.5::https://dl.dropboxusercontent.com/u/29095940/oss/libstdc%2B%2B.so.5
+ source = SimpleLabeler
md5sums = bf5eb9aa41e3b5f4d0c879591464c1db
md5sums = 02f2e57ec1773d906f8b15e6f1f95eae
+ md5sums = ca9f92eb5fcb3598fabc2cc6c7125054
+ md5sums = a130417033d647e2803f5ff9909cbba9
pkgname = bin32-lightscribe-labeler
diff --git a/PKGBUILD b/PKGBUILD
index e7007e07e677..66d8ac631029 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,14 +3,13 @@
# Contributor: James An <james@jamesan.ca>
# Contributor: ugaciaka <ugaciaka@gmail.com>
-
_realname=SimpleLabeler
_pkgpath=opt/lightscribeApplications
_pkgname=lightscribe-labeler
pkgname=bin32-lightscribe-labeler
pkgver=1.18.15.1
-pkgrel=4
+pkgrel=5
pkgdesc="LightScribe Simple Labeler"
arch=('x86_64')
url="http://www.pawtec.com/lightscribe"
@@ -20,13 +19,14 @@ provides=("$_pkgname=$pkgver")
conflicts=($_pkgname)
options=('!strip')
#source=(http://download.lightscribe.com/ls/lightscribeApplications-$pkgver-linux-2.6-intel.rpm lightscribe-labeler.desktop)
-source=(http://www.pawtec.com/lightscribe_files/Linux/LSL/lightscribeApplications-$pkgver-linux-2.6-intel.rpm lightscribe-labeler.desktop)
+source=(http://www.pawtec.com/lightscribe_files/Linux/LSL/lightscribeApplications-$pkgver-linux-2.6-intel.rpm lightscribe-labeler.desktop libstdc++.so.5::https://dl.dropboxusercontent.com/u/29095940/oss/libstdc%2B%2B.so.5 SimpleLabeler)
md5sums=('bf5eb9aa41e3b5f4d0c879591464c1db'
- '02f2e57ec1773d906f8b15e6f1f95eae')
+ '02f2e57ec1773d906f8b15e6f1f95eae'
+ 'ca9f92eb5fcb3598fabc2cc6c7125054'
+ 'a130417033d647e2803f5ff9909cbba9')
build() {
cd $srcdir/$_pkgpath
-
chmod -x $_realname/qt.conf
}
@@ -47,5 +47,6 @@ package() {
msg2 " -> Installing license ..."
install -Dm644 $_pkgpath/lightscribeLicense.rtf $pkgdir/usr/share/licenses/$_pkgname/license.rtf
+ install -Dm644 $srcdir/libstdc++.so.5 $pkgdir/opt/lightscribeApplications/SimpleLabeler/libstdc++.so.5
+ install -Dm755 $srcdir/SimpleLabeler $pkgdir/usr/bin/lightscribe-labeler
}
-
diff --git a/SimpleLabeler b/SimpleLabeler
new file mode 100644
index 000000000000..64154d8a4bfc
--- /dev/null
+++ b/SimpleLabeler
@@ -0,0 +1,3 @@
+#!/usr/bin/sh
+cd /opt/lightscribeApplications/SimpleLabeler
+LD_LIBRARY_PATH=/opt/lightscribeApplications/SimpleLabeler ./SimpleLabeler