summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjose17112016-11-21 07:42:07 +0100
committerjose17112016-11-21 07:42:07 +0100
commitd4487c573b3872d0f034ff01a196b5a9dc682509 (patch)
tree4d06b8e59c714ccfaa66cb10906bb8b57c69b12a
parent03202aa5330d0c063e6eaa13b148d36d9f36f8ea (diff)
downloadaur-d4487c573b3872d0f034ff01a196b5a9dc682509.tar.gz
Cleaned up + use better source for libstdc++
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD11
-rw-r--r--SimpleLabeler2
3 files changed, 8 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index eb7e989813e1..b56a9ba4b403 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,13 @@
# Generated by mksrcinfo v8
-# Wed Aug 17 21:16:45 UTC 2016
+# Mon Nov 21 06:41:52 UTC 2016
pkgbase = bin32-lightscribe-labeler
pkgdesc = LightScribe Simple Labeler
pkgver = 1.18.15.1
- pkgrel = 5
+ pkgrel = 6
url = http://www.pawtec.com/lightscribe
arch = x86_64
license = custom
depends = bin32-lightscribe
- depends = lib32-libstdc++5
depends = lib32-qt4
depends = lib32-libxi
depends = lib32-libxcursor
@@ -21,12 +20,10 @@ pkgbase = bin32-lightscribe-labeler
options = !strip
source = http://www.pawtec.com/lightscribe_files/Linux/LSL/lightscribeApplications-1.18.15.1-linux-2.6-intel.rpm
source = lightscribe-labeler.desktop
- source = libstdc++.so.5::https://dl.dropboxusercontent.com/u/29095940/oss/libstdc%2B%2B.so.5
source = SimpleLabeler
md5sums = bf5eb9aa41e3b5f4d0c879591464c1db
md5sums = 02f2e57ec1773d906f8b15e6f1f95eae
- md5sums = ca9f92eb5fcb3598fabc2cc6c7125054
- md5sums = a130417033d647e2803f5ff9909cbba9
+ md5sums = ea6b5b9c1d18161fe2c6cae21b305016
pkgname = bin32-lightscribe-labeler
diff --git a/PKGBUILD b/PKGBUILD
index 66d8ac631029..09b19a8e7186 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,21 +9,19 @@ _pkgname=lightscribe-labeler
pkgname=bin32-lightscribe-labeler
pkgver=1.18.15.1
-pkgrel=5
+pkgrel=6
pkgdesc="LightScribe Simple Labeler"
arch=('x86_64')
url="http://www.pawtec.com/lightscribe"
license=('custom')
-depends=('bin32-lightscribe' 'lib32-libstdc++5' 'lib32-qt4' 'lib32-libxi' 'lib32-libxcursor' 'lib32-libpng12' 'lib32-fontconfig' 'lib32-libsm' 'lib32-libxrandr')
+depends=('bin32-lightscribe' 'lib32-qt4' 'lib32-libxi' 'lib32-libxcursor' 'lib32-libpng12' 'lib32-fontconfig' 'lib32-libsm' 'lib32-libxrandr')
provides=("$_pkgname=$pkgver")
conflicts=($_pkgname)
options=('!strip')
-#source=(http://download.lightscribe.com/ls/lightscribeApplications-$pkgver-linux-2.6-intel.rpm lightscribe-labeler.desktop)
-source=(http://www.pawtec.com/lightscribe_files/Linux/LSL/lightscribeApplications-$pkgver-linux-2.6-intel.rpm lightscribe-labeler.desktop libstdc++.so.5::https://dl.dropboxusercontent.com/u/29095940/oss/libstdc%2B%2B.so.5 SimpleLabeler)
+source=(http://www.pawtec.com/lightscribe_files/Linux/LSL/lightscribeApplications-$pkgver-linux-2.6-intel.rpm lightscribe-labeler.desktop SimpleLabeler)
md5sums=('bf5eb9aa41e3b5f4d0c879591464c1db'
'02f2e57ec1773d906f8b15e6f1f95eae'
- 'ca9f92eb5fcb3598fabc2cc6c7125054'
- 'a130417033d647e2803f5ff9909cbba9')
+ 'ea6b5b9c1d18161fe2c6cae21b305016')
build() {
cd $srcdir/$_pkgpath
@@ -47,6 +45,5 @@ package() {
msg2 " -> Installing license ..."
install -Dm644 $_pkgpath/lightscribeLicense.rtf $pkgdir/usr/share/licenses/$_pkgname/license.rtf
- install -Dm644 $srcdir/libstdc++.so.5 $pkgdir/opt/lightscribeApplications/SimpleLabeler/libstdc++.so.5
install -Dm755 $srcdir/SimpleLabeler $pkgdir/usr/bin/lightscribe-labeler
}
diff --git a/SimpleLabeler b/SimpleLabeler
index 64154d8a4bfc..22276df60f41 100644
--- a/SimpleLabeler
+++ b/SimpleLabeler
@@ -1,3 +1,3 @@
#!/usr/bin/sh
cd /opt/lightscribeApplications/SimpleLabeler
-LD_LIBRARY_PATH=/opt/lightscribeApplications/SimpleLabeler ./SimpleLabeler
+LD_LIBRARY_PATH=/opt/lightscribeApplications/SimpleLabeler:/usr/lib/lightscribe ./SimpleLabeler