summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoroli2015-12-11 14:04:54 +0100
committeroli2015-12-11 14:05:39 +0100
commitdab0e7194bbe849b4589f81c647ad6e8dce41fc6 (patch)
tree3f631ae3439de5b8c56bc1471f0b0415a5684650
downloadaur-dab0e7194bbe849b4589f81c647ad6e8dce41fc6.tar.gz
adopted from aur3
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD49
-rw-r--r--lightscribe-labeler.desktop11
3 files changed, 88 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c12766ce8191
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+# Generated by mksrcinfo v8
+# Fri Dec 11 13:04:49 UTC 2015
+pkgbase = bin32-lightscribe-labeler
+ pkgdesc = LightScribe Simple Labeler
+ pkgver = 1.18.15.1
+ pkgrel = 3
+ url = http://www.pawtec.com/lightscribe
+ arch = x86_64
+ license = custom
+ depends = bin32-lightscribe
+ depends = lib32-libstdc++5
+ depends = lib32-qt4
+ depends = lib32-libxi
+ depends = lib32-libxcursor
+ depends = lib32-libpng12
+ depends = lib32-fontconfig
+ depends = lib32-libsm
+ depends = lib32-libxrandr
+ provides = lightscribe-labeler=1.18.15.1
+ conflicts = lightscribe-labeler
+ options = !strip
+ source = http://download.lightscribe.com/ls/lightscribeApplications-1.18.15.1-linux-2.6-intel.rpm
+ source = lightscribe-labeler.desktop
+ md5sums = bf5eb9aa41e3b5f4d0c879591464c1db
+ md5sums = 02f2e57ec1773d906f8b15e6f1f95eae
+
+pkgname = bin32-lightscribe-labeler
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..15ebe29943ca
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: Jose Riha <jose1711 gmail com>
+# Contributor: James An <james@jamesan.ca>
+# Contributor: ugaciaka <ugaciaka@gmail.com>
+
+
+_realname=SimpleLabeler
+_pkgpath=opt/lightscribeApplications
+_pkgname=lightscribe-labeler
+
+pkgname=bin32-lightscribe-labeler
+pkgver=1.18.15.1
+pkgrel=3
+pkgdesc="LightScribe Simple Labeler"
+arch=('x86_64')
+url="http://www.pawtec.com/lightscribe"
+license=('custom')
+depends=('bin32-lightscribe' 'lib32-libstdc++5' 'lib32-qt4' 'lib32-libxi' 'lib32-libxcursor' 'lib32-libpng12' 'lib32-fontconfig' 'lib32-libsm' 'lib32-libxrandr')
+provides=("$_pkgname=$pkgver")
+conflicts=($_pkgname)
+options=('!strip')
+source=(http://download.lightscribe.com/ls/lightscribeApplications-$pkgver-linux-2.6-intel.rpm lightscribe-labeler.desktop)
+md5sums=('bf5eb9aa41e3b5f4d0c879591464c1db'
+ '02f2e57ec1773d906f8b15e6f1f95eae')
+
+build() {
+ cd $srcdir/$_pkgpath
+
+ chmod -x $_realname/qt.conf
+}
+
+package() {
+ cd $srcdir
+
+ msg2 " -> Installing program..."
+ install -d $pkgdir/$_pkgpath/$_realname
+ cp -r $_pkgpath/SimpleLabeler $pkgdir/$_pkgpath/
+
+ msg2 " -> Installing icon..."
+ install -Dm644 $_pkgpath/$_realname/content/images/LabelWizardIcon.png ${pkgdir}/usr/share/pixmaps/$_pkgname.png
+
+ msg2 " -> Installing shortcut and symlink..."
+ install -Dm644 $_pkgname.desktop $pkgdir/usr/share/applications/$_pkgname
+ install -d $pkgdir/usr/bin
+ ln -s /$_pkgpath/$_realname/$_realname $pkgdir/usr/bin/$_pkgname
+
+ msg2 " -> Installing license ..."
+ install -Dm644 $_pkgpath/lightscribeLicense.rtf $pkgdir/usr/share/licenses/$_pkgname/license.rtf
+}
+
diff --git a/lightscribe-labeler.desktop b/lightscribe-labeler.desktop
new file mode 100644
index 000000000000..4213c7afda42
--- /dev/null
+++ b/lightscribe-labeler.desktop
@@ -0,0 +1,11 @@
+
+[Desktop Entry]
+Name=Labeler
+Comment=LightScribe Simple Labeler
+Encoding=UTF-8
+Exec=lightscribe-labeler
+Icon=lightscribe-labeler
+Type=Application
+Icon=lightscribe-labeler.png
+Categories=Application;AudioVideo;
+Terminal=false