summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVaporeon2015-10-15 16:10:17 +1300
committerVaporeon2015-10-15 16:10:17 +1300
commit0b42194027a4f46a41b1abf7c5d6003f5f4f5524 (patch)
tree362cc3fea0fdf74456cc71c516c5faf9e09f559c
downloadaur-0b42194027a4f46a41b1abf7c5d6003f5f4f5524.tar.gz
Initial import
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD45
2 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5c9b4dbb5537
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = bin32-pcsxr-svn
+ pkgdesc = A Sony PlayStation emulator based on the PCSX-df Project (32-bit)
+ pkgver = 1.9.93.r97860M
+ pkgrel = 1
+ url = http://pcsxr.codeplex.com/
+ arch = x86_64
+ license = GPL
+ makedepends = gcc-multilib
+ makedepends = intltool
+ makedepends = sdl2
+ makedepends = lib32-mesa
+ makedepends = subversion
+ depends = lib32-gtk3
+ depends = lib32-sdl2
+ depends = lib32-libcdio
+ depends = lib32-libxv
+ optdepends = lib32-libpulse: Pulseaudio support
+ provides = pcsxr
+ conflicts = pcsxr,
+ conflicts = pcsxr
+ conflicts = pcsx-df
+ options = !libtool
+ source = pcsxr::svn+https://pcsxr.svn.codeplex.com/svn/pcsxr
+ sha256sums = SKIP
+
+pkgname = bin32-pcsxr-svn
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..602e284eb6a1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Vaporeon <vaporeon@tfwno.gf>
+# Contributor: shvr <tusklahoma at gmail dot com>
+# Contributor: alucryd <alucryd at gmail dot com>
+# Contributor: Infy <eugene dot yudin at gmail dot com>
+
+_pkgname=pcsxr
+pkgname=bin32-pcsxr-svn
+pkgver=1.9.93.r97860M
+pkgrel=1
+pkgdesc="A Sony PlayStation emulator based on the PCSX-df Project (32-bit)"
+arch=('x86_64')
+url="http://pcsxr.codeplex.com/"
+license=('GPL')
+depends=('lib32-gtk3' 'lib32-sdl2' 'lib32-libcdio' 'lib32-libxv')
+makedepends=('gcc-multilib' 'intltool' 'sdl2' 'lib32-mesa' 'subversion')
+optdepends=('lib32-libpulse: Pulseaudio support')
+provides=("$_pkgname")
+conflicts=("$_pkgname", "${_pkgname%-*}" 'pcsx-df')
+options=('!libtool')
+source=("$_pkgname::svn+https://pcsxr.svn.codeplex.com/svn/pcsxr")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $_pkgname
+
+ printf "1.9.93.r%s" "$(svnversion)"
+}
+
+build() {
+ cd $_pkgname
+
+ CFLAGS="-m32 ${CFLAGS}"
+ CXXFLAGS="-m32 ${CXXFLAGS}"
+ export PKG_CONFIG_PATH="/usr/lib32/pkgconfig"
+
+ ./autogen.sh --prefix='/usr' --libdir=/usr/lib32 \
+ --enable-{libcdio,opengl} --enable-dynarec=x86
+ make
+}
+
+package() {
+ cd $_pkgname
+
+ make DESTDIR="${pkgdir}" install
+}