summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan Keith Darunday2021-08-11 06:59:09 +0800
committerJan Keith Darunday2021-08-11 07:03:40 +0800
commitc0cb86a38d5ca4108579ddb63dd874c07996ba9d (patch)
treeecc5bb6ce56884b4d1a52c6b30661babad8f133b
downloadaur-c0cb86a38d5ca4108579ddb63dd874c07996ba9d.tar.gz
Initial commit of binance-bin package
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD37
3 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..99f27f9555f5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = binance-bin
+ pkgdesc = Buy & sell Crypto in minutes, join the world’s largest crypto exchange
+ pkgver = latest
+ pkgrel = 1
+ url = https://www.binance.com/en/download
+ arch = x86_64
+ license = MIT
+ source = binance-bin-latest.deb::https://ftp.binance.com/electron-desktop/linux/production/binance-amd64-linux.deb
+ source = checksum.txt::https://ftp.binance.com/electron-desktop/linux/production/binance-amd64-linux-deb-sha256.txt
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = binance-bin
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..a39ab9a19e59
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+src/
+pkg/
+*.gz
+*.xz
+*.tar
+*.deb
+*.txt
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cac049fd846f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Jan Keith Darunday <jkcdarunday+aur.archlinux.org@gmail.com>
+
+pkgname=binance-bin
+_pkgname=binance
+pkgver=latest
+pkgrel=1
+pkgdesc="Buy & sell Crypto in minutes, join the world's largest crypto exchange"
+arch=('x86_64')
+url="https://www.binance.com/en/download"
+license=('MIT')
+source=(
+ "${_pkgname}-latest.deb::https://ftp.binance.com/electron-desktop/linux/production/binance-amd64-linux.deb"
+ "checksum.txt::https://ftp.binance.com/electron-desktop/linux/production/binance-amd64-linux-deb-sha256.txt"
+)
+sha256sums=('SKIP' 'SKIP')
+
+pkgver() {
+ tar -zxvf "${srcdir}/control.tar.gz" -C "${srcdir}" > /dev/null
+ egrep '^Version:' control | awk '{print $2}'
+}
+
+check() {
+ cd "$srcdir"
+
+ DEBFILEHASH=$(sha256sum ${_pkgname}-latest.deb | awk '{print $1}')
+ CORRECTHASH=$(cat checksum.txt)
+
+ [[ "$DEBFILEHASH" == "$CORRECTHASH" ]]
+}
+
+package() {
+ cd "$pkgdir"
+
+ tar -xvf "${srcdir}/data.tar.xz"
+ mkdir -p usr/bin
+ ln -s /opt/Binance/binance usr/bin/binance
+}