summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorreck16102016-12-04 12:54:30 +0100
committerreck16102016-12-04 12:54:30 +0100
commit5bf488f16862f391d7ff685235499602819aa086 (patch)
treeae54687415daf5b20bcd2fc139d701dabc1bfc19
parenta2031795a70dc5f931f31a454afc99b0f7c62ffe (diff)
downloadaur-5bf488f16862f391d7ff685235499602819aa086.tar.gz
Bumped version to 0.3
Removed patch
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD5
-rw-r--r--binarix.patch48
3 files changed, 6 insertions, 57 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4382730d8ee3..3774ad8af461 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sun Dec 4 11:45:43 UTC 2016
+# Sun Dec 4 11:52:46 UTC 2016
pkgbase = binarix
pkgdesc = binarix - a matrix styled linux console locker
- pkgver = 0.2a
+ pkgver = 0.3
pkgrel = 1
url = https://gitlab.com/reck1610/binarix
arch = i686
@@ -10,10 +10,8 @@ pkgbase = binarix
license = GPL2
depends = ncurses
depends = glibc
- source = binarix.patch
- md5sums = d6a8fb386a10a2576eff2b32e8ca6df5
- source = binarix-0.2a.tar.gz::https://gitlab.com/reck1610/binarix/repository/archive.tar.gz?ref=release%2F0.2a
- md5sums = 2e1ea4611e5e0824885d919f26a9e9b2
+ source = binarix-0.3.tar.gz::https://gitlab.com/reck1610/binarix/repository/archive.tar.gz?ref=release%2F0.3
+ md5sums = 3690cb489a9502589031cb9e4f63bf7f
pkgname = binarix
diff --git a/PKGBUILD b/PKGBUILD
index 48b0e53f5998..5b4183ec161f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: reck1610 <reck1610@gmail.com>
pkgname=binarix
-pkgver=0.2a
+pkgver=0.3
pkgrel=1
pkgdesc="binarix - a matrix styled linux console locker"
arch=('i686' 'x86_64')
@@ -10,14 +10,13 @@ url="https://gitlab.com/reck1610/binarix"
license=('GPL2')
depends=('ncurses' 'glibc')
source=("$pkgname-$pkgver.tar.gz::https://gitlab.com/reck1610/$pkgname/repository/archive.tar.gz?ref=release%2F$pkgver")
-md5sums=('2e1ea4611e5e0824885d919f26a9e9b2')
+md5sums=('3690cb489a9502589031cb9e4f63bf7f')
build() {
cd "$srcdir"
mv "$pkgname-release/"$(ls "$pkgname-release") "$pkgname-$pkgver"
rm -rf "$pkgname-release"
cd "$srcdir/$pkgname-$pkgver"
- #patch -p1 -i "$srcdir/$pkgname.patch" "$pkgname.c"
make all
}
diff --git a/binarix.patch b/binarix.patch
deleted file mode 100644
index 89b1aa362755..000000000000
--- a/binarix.patch
+++ /dev/null
@@ -1,48 +0,0 @@
---- ../binarix/binarix.c 2003-12-03 21:15:52.000000000 +0100
-+++ ../binarix-patched/binarix.c 2015-12-05 11:22:53.787984664 +0100
-@@ -55,7 +55,7 @@
- void changefield();
- void printhelp(int);
- void getpassword();
--void comparepasswords();
-+void comparepasswords(char);
- void push_snake(int, int);
- char *crypt();
- WINDOW *win;
-@@ -134,7 +134,7 @@
- win = dialog(DIALOG_PASS_HEIGHT, DIALOG_PASS_WIDTH,\
- (y-DIALOG_PASS_HEIGHT)/2, (x-DIALOG_PASS_WIDTH)/2,\
- DIALOG_PASS_TEXT);
-- comparepasswords();
-+ comparepasswords(ch);
- } else {
- refresh();
- }
-@@ -196,9 +196,8 @@
- strcpy(userpass, pw->sp_pwdp);
- }
-
--void comparepasswords()
-+void comparepasswords(char ch)
- {
-- char ch;
- char pass[127];
- int count;
-
-@@ -205,8 +205,15 @@
- count=0;
- nodelay(stdscr, 0);
-
-+ if (ch != '\n') pass[count++] = ch;
-+ if (ch==127 || ch ==8) count--;
-+
- while((ch = getch()) != '\n')
-- pass[count++] = ch;
-+ {
-+ if (count<0) count=0;
-+ if (ch==127 || ch ==8) count--;
-+ else pass[count++] = ch;
-+ }
-
- nodelay(stdscr, 1);
-