diff options
author | Chocobo1 | 2019-06-19 14:33:36 +0800 |
---|---|---|
committer | Chocobo1 | 2019-06-19 14:53:20 +0800 |
commit | 8ad2f9afd6656b1151616708051821bdcaa0f5dc (patch) | |
tree | 27dfebf34ff6ea88fbb9bf40685824044a250e06 | |
parent | 01eca3e9b76235dd95c28614a9fc419d6cd82be4 (diff) | |
download | aur-8ad2f9afd6656b1151616708051821bdcaa0f5dc.tar.gz |
upgpkg: binaryen-git r4335.g06698d7a3-1
-rw-r--r-- | .SRCINFO | 15 | ||||
-rw-r--r-- | PKGBUILD | 65 |
2 files changed, 49 insertions, 31 deletions
@@ -1,19 +1,20 @@ pkgbase = binaryen-git - pkgdesc = Compiler infrastructure and toolchain library for WebAssembly, in C++ - pkgver = 20170508 + pkgdesc = Compiler infrastructure and toolchain library for WebAssembly + pkgver = r4335.g06698d7a3 pkgrel = 1 url = https://github.com/WebAssembly/binaryen arch = i686 arch = x86_64 - license = MIT - makedepends = emscripten + license = apache makedepends = git - makedepends = python2 makedepends = cmake + depends = gcc-libs provides = binaryen conflicts = binaryen - source = git://github.com/WebAssembly/binaryen.git - md5sums = SKIP + source = git+https://github.com/WebAssembly/binaryen.git + source = binaryen.sh::https://git.archlinux.org/svntogit/community.git/plain/trunk/binaryen.sh?h=packages/binaryen + sha256sums = SKIP + sha256sums = SKIP pkgname = binaryen-git @@ -1,36 +1,53 @@ -# Maintainer: Sven-Hendrik Haase <sh@lutzhaase.com> +# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net> +# Former maintainer: Sven-Hendrik Haase <sh@lutzhaase.com> + pkgname=binaryen-git -pkgver=20170508 +pkgver=r4335.g06698d7a3 pkgrel=1 -pkgdesc="Compiler infrastructure and toolchain library for WebAssembly, in C++" -arch=(i686 x86_64) +pkgdesc="Compiler infrastructure and toolchain library for WebAssembly" +arch=('i686' 'x86_64') url="https://github.com/WebAssembly/binaryen" -license=('MIT') -depends=() -makedepends=('emscripten' 'git' 'python2' 'cmake') -provides=(binaryen) -conflicts=(binaryen) -source=('git://github.com/WebAssembly/binaryen.git') -md5sums=(SKIP) +license=('apache') +depends=('gcc-libs') +makedepends=('git' 'cmake') +#checkdepends=('python2') +provides=('binaryen') +conflicts=('binaryen') +source=("git+https://github.com/WebAssembly/binaryen.git" + "binaryen.sh::https://git.archlinux.org/svntogit/community.git/plain/trunk/binaryen.sh?h=packages/binaryen") +sha256sums=('SKIP' + 'SKIP') -build() { - cd binaryen - rm -rf build && mkdir build - cd build +pkgver() { + cd "binaryen" - cmake .. \ - -DCMAKE_INSTALL_PREFIX=/usr \ - -DCMAKE_INSTALL_LIBDIR=/usr/lib - make + _rev=$(git rev-list --count --all) + _hash=$(git rev-parse --short HEAD) + printf "r%s.g%s" "$_rev" "$_hash" } -package() { - cd binaryen/build +build() { + cd "binaryen" - make DESTDIR=${pkgdir} install + mkdir -p "_build" && cd "_build" + cmake \ + -DCMAKE_BUILD_TYPE=Release \ + -DCMAKE_INSTALL_PREFIX="/usr" \ + -DCMAKE_INSTALL_LIBDIR="lib" \ + "../" + make +} + +check() { + cd "binaryen/_build" - install -Dm644 ../LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE + #python2 ../check.py } -# vim:set ts=2 sw=2 et: +package() { + cd "binaryen" + + make -C "_build" DESTDIR="$pkgdir" install + install -Dm755 "$srcdir/binaryen.sh" -t "$pkgdir/etc/profile.d" +} |