summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAllen Zhong2019-04-16 17:50:24 +0800
committerAllen Zhong2019-04-16 18:04:30 +0800
commit0181e2c796bb6254f1966f20fa38c8330f3e6f6d (patch)
tree3041cfad9d00686241c1b83765cb262c076e3807
parent2f856e1ea0f693673a928508a21294bea32a173b (diff)
downloadaur-0181e2c796bb6254f1966f20fa38c8330f3e6f6d.tar.gz
upgpkg: bind-rl 9.14-1
-rw-r--r--.SRCINFO36
-rw-r--r--01-fs60913.patch45
-rw-r--r--PKGBUILD32
3 files changed, 34 insertions, 79 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ae5b981a5af1..c79166cbd2cc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Tue Jan 15 07:28:25 UTC 2019
pkgbase = bind-rl
- pkgver = 9.13.5
- pkgrel = 2
+ pkgver = 9.14.0
+ pkgrel = 1
url = https://www.isc.org/software/bind/
arch = x86_64
license = MPL2
@@ -13,16 +11,19 @@ pkgbase = bind-rl
makedepends = e2fsprogs
makedepends = openssl
makedepends = readline
- makedepends = idnkit
+ makedepends = libidn2
makedepends = geoip
makedepends = dnssec-anchors
makedepends = python
makedepends = json-c
makedepends = python-ply
- makedepends = libseccomp
+ makedepends = lmdb
+ makedepends = zlib
+ makedepends = icu
+ makedepends = xz
options = !emptydirs
- source = https://ftp.isc.org/isc/bind9/9.13.5/bind-9.13.5.tar.gz
- source = https://ftp.isc.org/isc/bind9/9.13.5/bind-9.13.5.tar.gz.asc
+ source = https://ftp.isc.org/isc/bind9/9.14.0/bind-9.14.0.tar.gz
+ source = https://ftp.isc.org/isc/bind9/9.14.0/bind-9.14.0.tar.gz.asc
source = tmpfiles.conf
source = sysusers.conf
source = named.conf
@@ -31,8 +32,8 @@ pkgbase = bind-rl
source = localhost.ip6.zone
source = 127.0.0.zone
source = empty.zone
- source = 01-fs60913.patch
- sha1sums = 8c01018e6928e9117cd8e0cdd464efe3b68894c5
+ validpgpkeys = AE3FAC796711EC59FC007AA474BB6B9A4CBB3D38
+ sha1sums = 8807e4736732300b75193885149807ce3ce99cd4
sha1sums = SKIP
sha1sums = c5a2bcd9b0f009ae71f3a03fbdbe012196962a11
sha1sums = 9537f4835a1f736788d0733c7996a10db2d4eee4
@@ -42,7 +43,6 @@ pkgbase = bind-rl
sha1sums = 52da8f1c0247a11b16daa4e03d920e8f09315cbe
sha1sums = 9c33726088342207ad06d33b2c13408290a0c8ad
sha1sums = 4f4457b310cbbeadca2272eced062a9c2b2b42fe
- sha1sums = a71c39b6073be96589e3c0a8cc7430f0e22ebe9c
pkgname = bind-rl
pkgdesc = The ISC DNS Server, with Response Rate Limit (RRL) enabled
@@ -55,7 +55,7 @@ pkgname = bind-rl
depends = json-c
depends = bind-tools
provides = dns-server
- provides = bind=9.13.5
+ provides = bind=9.14.0
conflicts = bind
replaces = bind
backup = etc/named.conf
@@ -68,20 +68,24 @@ pkgname = bind-rl-tools
pkgdesc = The ISC DNS tools
depends = glibc
depends = libcap
- depends = libseccomp
depends = libxml2
depends = zlib
depends = krb5
depends = e2fsprogs
+ depends = python
+ depends = bash
depends = openssl
depends = readline
depends = geoip
- depends = idnkit
+ depends = libidn2
depends = dnssec-anchors
depends = json-c
+ depends = lmdb
+ depends = xz
+ depends = icu
optdepends = python: for python scripts
- provides = dnsutils=9.13.5
- provides = bind-tools=9.13.5
+ provides = dnsutils=9.14.0
+ provides = bind-tools=9.14.0
conflicts = dnsutils
conflicts = bind-tools
replaces = dnsutils
diff --git a/01-fs60913.patch b/01-fs60913.patch
deleted file mode 100644
index a88439eaec3d..000000000000
--- a/01-fs60913.patch
+++ /dev/null
@@ -1,45 +0,0 @@
-From 0e5dd25fc5c70d656666f6d537e93cf346e7f419 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Witold=20Kr=C4=99cicki?= <wpk@isc.org>
-Date: Thu, 3 Jan 2019 13:06:39 +0100
-Subject: [PATCH] When a forwarder fails and we're not in a forward-only mode
- we go back to regular resolution. When this happens the fetch timer is
- already running, and we might end up in a situation where we we create a
- fetch for qname-minimized query and after that the timer is triggered and the
- query is retried (fctx_try) - which causes relaunching of qname-minimization
- fetch - and since we already have a qmin fetch for this fctx - assertion
- failure.
-
-
-diff --git a/lib/dns/resolver.c b/lib/dns/resolver.c
-index 8beecbcb07..ea122bd30c 100644
---- a/lib/dns/resolver.c
-+++ b/lib/dns/resolver.c
-@@ -4012,6 +4012,7 @@ fctx_try(fetchctx_t *fctx, bool retrying, bool badcache) {
- options &= ~DNS_FETCHOPT_QMINIMIZE;
- fctx_increference(fctx);
- task = res->buckets[bucketnum].task;
-+ fctx_stoptimer(fctx);
- result = dns_resolver_createfetch(fctx->res, &fctx->qminname,
- fctx->qmintype, &fctx->domain,
- &fctx->nameservers, NULL, NULL, 0,
-@@ -4343,13 +4344,12 @@ fctx_timeout(isc_task_t *task, isc_event_t *event) {
- * timer.
- */
- result = fctx_starttimer(fctx);
-- if (result != ISC_R_SUCCESS)
-+ if (result != ISC_R_SUCCESS) {
- fctx_done(fctx, result, __LINE__);
-- else
-- /*
-- * Keep trying.
-- */
-+ } else {
-+ /* Keep trying */
- fctx_try(fctx, true, false);
-+ }
- }
-
- isc_event_free(&event);
---
-2.18.1
-
diff --git a/PKGBUILD b/PKGBUILD
index 9ceb6a05467d..8480c3160b30 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,19 +6,17 @@
pkgbase=bind-rl
pkgname=(bind-rl bind-rl-tools)
-_pkgver=9.13.5
+_pkgver=9.14.0
pkgver=${_pkgver//-/.}
-pkgrel=2
+pkgrel=1
url='https://www.isc.org/software/bind/'
license=('MPL2')
arch=('x86_64')
options=('!emptydirs')
makedepends=('libcap' 'libxml2' 'zlib' 'krb5' 'e2fsprogs' 'openssl' 'readline'
- 'idnkit' 'geoip' 'dnssec-anchors' 'python' 'json-c' 'python-ply' 'libseccomp')
-validpgpkeys=('2B48A38AE1CF9886435F89EE45AC7857189CDBC5'
- 'ADBE9446286C794905F1E0756FA6EBC9911A4C02' #ISC, Inc)
- 'BE0E9748B718253A28BB89FFF1B11BF05CF02E57' #Internet Systems Consortium, Inc.
- )
+ 'libidn2' 'geoip' 'dnssec-anchors' 'python' 'json-c' 'python-ply' 'lmdb'
+ 'zlib' 'icu' 'xz')
+validpgpkeys=('AE3FAC796711EC59FC007AA474BB6B9A4CBB3D38') #ISC Code Signing Key 2019 – 2020 (codesign@isc.org)
source=("https://ftp.isc.org/isc/bind9/${_pkgver}/bind-${_pkgver}.tar.gz"{,.asc}
'tmpfiles.conf'
'sysusers.conf'
@@ -27,9 +25,8 @@ source=("https://ftp.isc.org/isc/bind9/${_pkgver}/bind-${_pkgver}.tar.gz"{,.asc}
'localhost.zone'
'localhost.ip6.zone'
'127.0.0.zone'
- 'empty.zone'
- '01-fs60913.patch')
-sha1sums=('8c01018e6928e9117cd8e0cdd464efe3b68894c5'
+ 'empty.zone')
+sha1sums=('8807e4736732300b75193885149807ce3ce99cd4'
'SKIP'
'c5a2bcd9b0f009ae71f3a03fbdbe012196962a11'
'9537f4835a1f736788d0733c7996a10db2d4eee4'
@@ -38,8 +35,7 @@ sha1sums=('8c01018e6928e9117cd8e0cdd464efe3b68894c5'
'6704303a6ed431a29b1d8fe7b12decd4d1f2f50f'
'52da8f1c0247a11b16daa4e03d920e8f09315cbe'
'9c33726088342207ad06d33b2c13408290a0c8ad'
- '4f4457b310cbbeadca2272eced062a9c2b2b42fe'
- 'a71c39b6073be96589e3c0a8cc7430f0e22ebe9c')
+ '4f4457b310cbbeadca2272eced062a9c2b2b42fe')
prepare() {
msg2 'Getting a fresh version of root DNS'
@@ -66,18 +62,17 @@ build() {
--sbindir=/usr/bin \
--localstatedir=/var \
--disable-static \
- --enable-ipv6 \
- --enable-filter-aaaa \
--enable-fixed-rrset \
- --enable-seccomp \
--enable-full-report \
+ --enable-dnsrps \
--enable-rrl \
--with-python=/usr/bin/python \
--with-geoip \
- --with-idn \
--with-openssl \
+ --with-libidn2 \
--with-libjson \
--with-libxml2 \
+ --with-lmdb \
--with-libtool
sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
make
@@ -120,8 +115,9 @@ package_bind-rl() {
package_bind-rl-tools() {
pkgdesc='The ISC DNS tools'
- depends=('glibc' 'libcap' 'libseccomp' 'libxml2' 'zlib' 'krb5' 'e2fsprogs'
- 'openssl' 'readline' 'geoip' 'idnkit' 'dnssec-anchors' 'json-c')
+ depends=('glibc' 'libcap' 'libxml2' 'zlib' 'krb5' 'e2fsprogs' 'python' 'bash'
+ 'openssl' 'readline' 'geoip' 'libidn2' 'dnssec-anchors' 'json-c'
+ 'lmdb' 'xz' 'icu')
optdepends=('python: for python scripts')
conflicts=('dnsutils' 'bind-tools')
replaces=('dnsutils' 'host' 'bind-tools')