summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAllen Zhong2019-01-15 14:59:37 +0800
committerAllen Zhong2019-01-15 14:59:37 +0800
commitf8a4710a1a1dfcf6d3cc6211e2c3bfc7e9fdb30a (patch)
tree47443a929cfb4be4c4d6bf1f81fcb53d8afe3013
parentd859783f681ad35b28a70818fcdaa34786d3bf30 (diff)
downloadaur-f8a4710a1a1dfcf6d3cc6211e2c3bfc7e9fdb30a.tar.gz
upgpkg: bind-rl 9.13.5-1
-rw-r--r--.SRCINFO14
-rw-r--r--01-fs60913.patch45
-rw-r--r--PKGBUILD10
3 files changed, 59 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4cd3dd34e462..26592746a4fb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
# Generated by mksrcinfo v8
-# Mon Nov 19 03:14:38 UTC 2018
+# Tue Jan 15 06:49:01 UTC 2019
pkgbase = bind-rl
- pkgver = 9.13.3
+ pkgver = 9.13.5
pkgrel = 1
url = https://www.isc.org/software/bind/
arch = x86_64
@@ -21,8 +21,8 @@ pkgbase = bind-rl
makedepends = python-ply
makedepends = libseccomp
options = !emptydirs
- source = https://ftp.isc.org/isc/bind9/9.13.3/bind-9.13.3.tar.gz
- source = https://ftp.isc.org/isc/bind9/9.13.3/bind-9.13.3.tar.gz.asc
+ source = https://ftp.isc.org/isc/bind9/9.13.5/bind-9.13.5.tar.gz
+ source = https://ftp.isc.org/isc/bind9/9.13.5/bind-9.13.5.tar.gz.asc
source = tmpfiles.conf
source = sysusers.conf
source = named.conf
@@ -31,7 +31,8 @@ pkgbase = bind-rl
source = localhost.ip6.zone
source = 127.0.0.zone
source = empty.zone
- sha1sums = eed41fd32887bd163935fe14b94afad4a8b287c2
+ source = 01-fs60913.patch
+ sha1sums = 8c01018e6928e9117cd8e0cdd464efe3b68894c5
sha1sums = SKIP
sha1sums = c5a2bcd9b0f009ae71f3a03fbdbe012196962a11
sha1sums = 9537f4835a1f736788d0733c7996a10db2d4eee4
@@ -41,6 +42,7 @@ pkgbase = bind-rl
sha1sums = 52da8f1c0247a11b16daa4e03d920e8f09315cbe
sha1sums = 9c33726088342207ad06d33b2c13408290a0c8ad
sha1sums = 4f4457b310cbbeadca2272eced062a9c2b2b42fe
+ sha1sums = a71c39b6073be96589e3c0a8cc7430f0e22ebe9c
pkgname = bind-rl
pkgdesc = The ISC DNS Server, with Response Rate Limit (RRL) enabled
@@ -77,7 +79,7 @@ pkgname = bind-rl-tools
depends = dnssec-anchors
depends = json-c
optdepends = python: for python scripts
- provides = dnsutils=9.13.3
+ provides = dnsutils=9.13.5
conflicts = dnsutils
conflicts = bind-tools
replaces = dnsutils
diff --git a/01-fs60913.patch b/01-fs60913.patch
new file mode 100644
index 000000000000..a88439eaec3d
--- /dev/null
+++ b/01-fs60913.patch
@@ -0,0 +1,45 @@
+From 0e5dd25fc5c70d656666f6d537e93cf346e7f419 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Witold=20Kr=C4=99cicki?= <wpk@isc.org>
+Date: Thu, 3 Jan 2019 13:06:39 +0100
+Subject: [PATCH] When a forwarder fails and we're not in a forward-only mode
+ we go back to regular resolution. When this happens the fetch timer is
+ already running, and we might end up in a situation where we we create a
+ fetch for qname-minimized query and after that the timer is triggered and the
+ query is retried (fctx_try) - which causes relaunching of qname-minimization
+ fetch - and since we already have a qmin fetch for this fctx - assertion
+ failure.
+
+
+diff --git a/lib/dns/resolver.c b/lib/dns/resolver.c
+index 8beecbcb07..ea122bd30c 100644
+--- a/lib/dns/resolver.c
++++ b/lib/dns/resolver.c
+@@ -4012,6 +4012,7 @@ fctx_try(fetchctx_t *fctx, bool retrying, bool badcache) {
+ options &= ~DNS_FETCHOPT_QMINIMIZE;
+ fctx_increference(fctx);
+ task = res->buckets[bucketnum].task;
++ fctx_stoptimer(fctx);
+ result = dns_resolver_createfetch(fctx->res, &fctx->qminname,
+ fctx->qmintype, &fctx->domain,
+ &fctx->nameservers, NULL, NULL, 0,
+@@ -4343,13 +4344,12 @@ fctx_timeout(isc_task_t *task, isc_event_t *event) {
+ * timer.
+ */
+ result = fctx_starttimer(fctx);
+- if (result != ISC_R_SUCCESS)
++ if (result != ISC_R_SUCCESS) {
+ fctx_done(fctx, result, __LINE__);
+- else
+- /*
+- * Keep trying.
+- */
++ } else {
++ /* Keep trying */
+ fctx_try(fctx, true, false);
++ }
+ }
+
+ isc_event_free(&event);
+--
+2.18.1
+
diff --git a/PKGBUILD b/PKGBUILD
index 63ee6ed45d67..7479d706304d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgbase=bind-rl
pkgname=(bind-rl bind-rl-tools)
-_pkgver=9.13.3
+_pkgver=9.13.5
pkgver=${_pkgver//-/.}
pkgrel=1
url='https://www.isc.org/software/bind/'
@@ -27,8 +27,9 @@ source=("https://ftp.isc.org/isc/bind9/${_pkgver}/bind-${_pkgver}.tar.gz"{,.asc}
'localhost.zone'
'localhost.ip6.zone'
'127.0.0.zone'
- 'empty.zone')
-sha1sums=('eed41fd32887bd163935fe14b94afad4a8b287c2'
+ 'empty.zone'
+ '01-fs60913.patch')
+sha1sums=('8c01018e6928e9117cd8e0cdd464efe3b68894c5'
'SKIP'
'c5a2bcd9b0f009ae71f3a03fbdbe012196962a11'
'9537f4835a1f736788d0733c7996a10db2d4eee4'
@@ -37,7 +38,8 @@ sha1sums=('eed41fd32887bd163935fe14b94afad4a8b287c2'
'6704303a6ed431a29b1d8fe7b12decd4d1f2f50f'
'52da8f1c0247a11b16daa4e03d920e8f09315cbe'
'9c33726088342207ad06d33b2c13408290a0c8ad'
- '4f4457b310cbbeadca2272eced062a9c2b2b42fe')
+ '4f4457b310cbbeadca2272eced062a9c2b2b42fe'
+ 'a71c39b6073be96589e3c0a8cc7430f0e22ebe9c')
prepare() {
msg2 'Getting a fresh version of root DNS'