summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZhang Hua2023-06-21 21:26:21 +0800
committerZhang Hua2023-06-21 21:26:21 +0800
commit5421839abe4d5671432a505ce6d2fcd300747113 (patch)
tree279ee66da61e1af6cab8981200a7c49ab682bba3
parentd73b0c31780e1f3dcf0fa78ca3ef855379e3144f (diff)
downloadaur-5421839abe4d5671432a505ce6d2fcd300747113.tar.gz
Update to latest commit and drop uneeded patch
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD25
3 files changed, 14 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f908599946a4..eba80fe77b7a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,14 @@
pkgbase = binder_linux-dkms
pkgdesc = Android kernel driver fork by @choff in DKMS format, binder only.
pkgver = 6.3
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/choff/anbox-modules
arch = x86_64
license = GPL3
makedepends = git
depends = dkms
conflicts = anbox-modules-dkms
- source = git+https://github.com/choff/anbox-modules.git#commit=44dc351409c6e1665c0dd3c7a32c8e79a2950a4e
- source = 10-6.3.diff::https://github.com/choff/anbox-modules/pull/10.diff
+ source = git+https://github.com/choff/anbox-modules.git#commit=abead1debfae56e8d0307c642865ec23aaa854d3
sha256sums = SKIP
- sha256sums = 7bfae09412b8ed3835c2b91a775f5e1dff46ce2e05824cc203a14a52491cecec
pkgname = binder_linux-dkms
diff --git a/.gitignore b/.gitignore
index dc8594e8c84c..2ec01664f369 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,4 +2,5 @@ src
pkg
anbox-modules
*.pkg.tar.*
+*.log
diff --git a/PKGBUILD b/PKGBUILD
index 26afaf6c3c5b..5300c51f6ac5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,11 +2,11 @@
# Maintainer: Christian Hoff <https://github.com/choff>
# Contributor: Tobias Martin <tm-x at gmx dot net>
-_commit=44dc351409c6e1665c0dd3c7a32c8e79a2950a4e
+_commit=abead1debfae56e8d0307c642865ec23aaa854d3
pkgname=binder_linux-dkms
pkgver=6.3
-pkgrel=1
+pkgrel=2
arch=("x86_64")
url='https://github.com/choff/anbox-modules'
pkgdesc='Android kernel driver fork by @choff in DKMS format, binder only.'
@@ -16,18 +16,15 @@ depends=("dkms")
makedepends=("git")
source=(
"git+${url}.git#commit=${_commit}"
- # Fix build on 6.3 kernel
- # See https://github.com/choff/anbox-modules/pull/10
- "10-6.3.diff::https://github.com/choff/anbox-modules/pull/10.diff")
-sha256sums=('SKIP'
- '7bfae09412b8ed3835c2b91a775f5e1dff46ce2e05824cc203a14a52491cecec')
-prepare(){
- cd "${srcdir}/anbox-modules"
- for diff_file in "${srcdir}/"*.diff
- do
- git apply "$diff_file"
- done
-}
+)
+sha256sums=('SKIP')
+# prepare(){
+# cd "${srcdir}/anbox-modules"
+# for diff_file in "${srcdir}/"*.diff
+# do
+# git apply "$diff_file"
+# done
+# }
package(){
install -dm755 "${pkgdir}/usr/src/binder-1"
cp -r "${srcdir}/anbox-modules/binder/"* "${pkgdir}/usr/src/binder-1/"