summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZhang Hua2023-01-30 14:19:36 +0800
committerZhang Hua2023-01-30 14:19:36 +0800
commit99af759737e7077d80c5f1cc11ee51f4e3d5c1f9 (patch)
treea31fd6774ada38cf8f7914eab57d08d87ad1d39b
parenteba497e2f76651000e915d63ff6028a5e2554a8d (diff)
downloadaur-99af759737e7077d80c5f1cc11ee51f4e3d5c1f9.tar.gz
Sync with latest upstream
-rw-r--r--.SRCINFO6
-rw-r--r--6.1-fix.diff24
-rw-r--r--PKGBUILD12
3 files changed, 7 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b16cb9c7c934..b6cca4ac903e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,14 @@
pkgbase = binder_linux-dkms
pkgdesc = Android kernel driver fork by @choff in DKMS format, binder only.
pkgver = 6.1
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/choff/anbox-modules
arch = x86_64
license = GPL3
makedepends = git
depends = dkms
conflicts = anbox-modules-dkms
- source = git+https://github.com/choff/anbox-modules.git#commit=cd66055f6d806d7f1534f38ff7142c75f6735e09
- source = 6.1-fix.diff
+ source = git+https://github.com/choff/anbox-modules.git#commit=ab8278c603ed54152d3a8e23269198d1044b2fa3
sha256sums = SKIP
- sha256sums = 46331ef50b05db9313c826e5f0d3cf7a65a8f1fc5908bb7cae191cd6ef308b70
pkgname = binder_linux-dkms
diff --git a/6.1-fix.diff b/6.1-fix.diff
deleted file mode 100644
index 3b9dda13e2a2..000000000000
--- a/6.1-fix.diff
+++ /dev/null
@@ -1,24 +0,0 @@
-diff --git a/binder/binder.c b/binder/binder.c
-index a7e620b..8b9519a 100644
---- a/binder/binder.c
-+++ b/binder/binder.c
-@@ -4109,7 +4109,9 @@ static int binder_wait_for_work(struct binder_thread *thread,
- struct binder_proc *proc = thread->proc;
- int ret = 0;
-
-+#if LINUX_VERSION_CODE <= KERNEL_VERSION(6,0,0)
- freezer_do_not_count();
-+#endif
- binder_inner_proc_lock(proc);
- for (;;) {
- prepare_to_wait(&thread->wait, &wait, TASK_INTERRUPTIBLE);
-@@ -4129,7 +4131,9 @@ static int binder_wait_for_work(struct binder_thread *thread,
- }
- finish_wait(&thread->wait, &wait);
- binder_inner_proc_unlock(proc);
-+#if LINUX_VERSION_CODE <= KERNEL_VERSION(6,0,0)
- freezer_count();
-+#endif
-
- return ret;
- }
diff --git a/PKGBUILD b/PKGBUILD
index 8d70eefb2f25..b842cf3e0cf9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,11 +2,11 @@
# Maintainer: Christian Hoff <https://github.com/choff>
# Contributor: Tobias Martin <tm-x at gmx dot net>
-_commit=cd66055f6d806d7f1534f38ff7142c75f6735e09
+_commit=ab8278c603ed54152d3a8e23269198d1044b2fa3
pkgname=binder_linux-dkms
pkgver=6.1
-pkgrel=2
+pkgrel=3
arch=("x86_64")
url='https://github.com/choff/anbox-modules'
pkgdesc='Android kernel driver fork by @choff in DKMS format, binder only.'
@@ -15,13 +15,11 @@ conflicts=("anbox-modules-dkms")
depends=("dkms")
makedepends=("git")
source=(
- "git+${url}.git#commit=${_commit}"
- "6.1-fix.diff")
-sha256sums=('SKIP'
- '46331ef50b05db9313c826e5f0d3cf7a65a8f1fc5908bb7cae191cd6ef308b70')
+ "git+${url}.git#commit=${_commit}")
+sha256sums=('SKIP')
prepare(){
cd "${srcdir}/anbox-modules"
- git apply "${srcdir}/6.1-fix.diff"
+
}
package(){
install -dm755 "${pkgdir}/usr/src/binder-1"