summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZhang Hua2023-11-01 15:14:52 +0800
committerZhang Hua2023-11-01 15:14:52 +0800
commitbbc48da65bdd0a35d6d3629aa79d1a6884efbff4 (patch)
tree811b46fdf436a4b4685865cba3cd2c2178156442
parent5421839abe4d5671432a505ce6d2fcd300747113 (diff)
downloadaur-bbc48da65bdd0a35d6d3629aa79d1a6884efbff4.tar.gz
Fix build on 6.6 kernel
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD22
2 files changed, 16 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index eba80fe77b7a..f08654217e70 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = binder_linux-dkms
pkgdesc = Android kernel driver fork by @choff in DKMS format, binder only.
- pkgver = 6.3
- pkgrel = 2
+ pkgver = 6.6
+ pkgrel = 1
url = https://github.com/choff/anbox-modules
arch = x86_64
license = GPL3
@@ -9,6 +9,8 @@ pkgbase = binder_linux-dkms
depends = dkms
conflicts = anbox-modules-dkms
source = git+https://github.com/choff/anbox-modules.git#commit=abead1debfae56e8d0307c642865ec23aaa854d3
+ source = https://github.com/choff/anbox-modules/pull/12.diff
sha256sums = SKIP
+ sha256sums = 6964cc4c070a34bbed1a5e4249c1a2928f05c94716adfd0c79c410266ee4d0fd
pkgname = binder_linux-dkms
diff --git a/PKGBUILD b/PKGBUILD
index 5300c51f6ac5..bbd6f5b0a359 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,8 +5,8 @@
_commit=abead1debfae56e8d0307c642865ec23aaa854d3
pkgname=binder_linux-dkms
-pkgver=6.3
-pkgrel=2
+pkgver=6.6
+pkgrel=1
arch=("x86_64")
url='https://github.com/choff/anbox-modules'
pkgdesc='Android kernel driver fork by @choff in DKMS format, binder only.'
@@ -16,15 +16,17 @@ depends=("dkms")
makedepends=("git")
source=(
"git+${url}.git#commit=${_commit}"
+ "https://github.com/choff/anbox-modules/pull/12.diff"
)
-sha256sums=('SKIP')
-# prepare(){
-# cd "${srcdir}/anbox-modules"
-# for diff_file in "${srcdir}/"*.diff
-# do
-# git apply "$diff_file"
-# done
-# }
+sha256sums=('SKIP'
+ '6964cc4c070a34bbed1a5e4249c1a2928f05c94716adfd0c79c410266ee4d0fd')
+prepare(){
+ cd "${srcdir}/anbox-modules"
+ for diff_file in "${srcdir}/"*.diff
+ do
+ git apply "$diff_file"
+ done
+}
package(){
install -dm755 "${pkgdir}/usr/src/binder-1"
cp -r "${srcdir}/anbox-modules/binder/"* "${pkgdir}/usr/src/binder-1/"