summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZhang Hua2023-05-08 09:28:43 +0800
committerZhang Hua2023-05-08 09:28:43 +0800
commitd73b0c31780e1f3dcf0fa78ca3ef855379e3144f (patch)
treec6328395a6e156a60d73e463229527118542d6b6
parent9bb74e0a1122addb7033a750efeccdc3fa9260fd (diff)
downloadaur-d73b0c31780e1f3dcf0fa78ca3ef855379e3144f.tar.gz
Fix build on 6.3 kernel
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD19
2 files changed, 18 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 90add25248b1..f908599946a4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,16 @@
pkgbase = binder_linux-dkms
pkgdesc = Android kernel driver fork by @choff in DKMS format, binder only.
- pkgver = 6.1
- pkgrel = 4
+ pkgver = 6.3
+ pkgrel = 1
url = https://github.com/choff/anbox-modules
arch = x86_64
license = GPL3
makedepends = git
depends = dkms
conflicts = anbox-modules-dkms
- source = git+https://github.com/choff/anbox-modules.git#commit=a961389cd7246be89fa4ea36a9947eddfe29900e
+ source = git+https://github.com/choff/anbox-modules.git#commit=44dc351409c6e1665c0dd3c7a32c8e79a2950a4e
+ source = 10-6.3.diff::https://github.com/choff/anbox-modules/pull/10.diff
sha256sums = SKIP
+ sha256sums = 7bfae09412b8ed3835c2b91a775f5e1dff46ce2e05824cc203a14a52491cecec
pkgname = binder_linux-dkms
diff --git a/PKGBUILD b/PKGBUILD
index a7cc34c8ef89..26afaf6c3c5b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,11 +2,11 @@
# Maintainer: Christian Hoff <https://github.com/choff>
# Contributor: Tobias Martin <tm-x at gmx dot net>
-_commit=a961389cd7246be89fa4ea36a9947eddfe29900e
+_commit=44dc351409c6e1665c0dd3c7a32c8e79a2950a4e
pkgname=binder_linux-dkms
-pkgver=6.1
-pkgrel=4
+pkgver=6.3
+pkgrel=1
arch=("x86_64")
url='https://github.com/choff/anbox-modules'
pkgdesc='Android kernel driver fork by @choff in DKMS format, binder only.'
@@ -15,11 +15,18 @@ conflicts=("anbox-modules-dkms")
depends=("dkms")
makedepends=("git")
source=(
- "git+${url}.git#commit=${_commit}")
-sha256sums=('SKIP')
+ "git+${url}.git#commit=${_commit}"
+ # Fix build on 6.3 kernel
+ # See https://github.com/choff/anbox-modules/pull/10
+ "10-6.3.diff::https://github.com/choff/anbox-modules/pull/10.diff")
+sha256sums=('SKIP'
+ '7bfae09412b8ed3835c2b91a775f5e1dff46ce2e05824cc203a14a52491cecec')
prepare(){
cd "${srcdir}/anbox-modules"
-
+ for diff_file in "${srcdir}/"*.diff
+ do
+ git apply "$diff_file"
+ done
}
package(){
install -dm755 "${pkgdir}/usr/src/binder-1"