summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoronurmercury2024-01-16 14:54:12 +0300
committeronurmercury2024-01-16 14:57:46 +0300
commit3507da8954808650bdc01c14a1e242c18b4c4282 (patch)
tree8959a79343969f0fa4b65d64f424a504ddfa99be
downloadaur-3507da8954808650bdc01c14a1e242c18b4c4282.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD33
3 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4dce5e98bff0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = binder_linux-dkms-git
+ pkgdesc = Binder kernel module for Waydroid.
+ pkgver = r52.13a93a4
+ pkgrel = 1
+ url = https://github.com/choff/anbox-modules
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ depends = dkms
+ conflicts = binder_linux-dkms
+ conflicts = anbox-modules-dkms
+ source = git+https://github.com/choff/anbox-modules.git
+ sha512sums = SKIP
+
+pkgname = binder_linux-dkms-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..d6a704a58a78
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+#Ignore everything
+*
+
+# Exclude these
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..de9834b554a9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: onurmercury <onurmercury at proton dot me>
+# Contributor: Sick Codes <info at sick dot codes>
+# Contributor: Tobias Martin <tm-x at gmx dot net>
+
+# This package includes the Binder module, sourced from @choff's anbox-modules fork.
+# However, it differs from the repository by excluding
+# the ashmem module, as both the Linux kernel (version 5.18)
+# and Waydroid (version 1.2.1) now utilize memfd instead.
+
+_pkgname=binder_linux-dkms
+
+pkgname="${_pkgname}-git"
+pkgver=r52.13a93a4
+pkgrel=1
+arch=("x86_64")
+url="https://github.com/choff/anbox-modules"
+pkgdesc="Binder kernel module for Waydroid."
+license=("GPL2")
+conflicts=("${_pkgname}" "anbox-modules-dkms")
+depends=("dkms")
+makedepends=("git")
+source=(git+"${url}".git)
+sha512sums=("SKIP")
+
+pkgver() {
+ cd anbox-modules
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short=7 HEAD)"
+}
+
+package() {
+ install -dm755 "${pkgdir}/usr/src/binder-1"
+ cp -r "${srcdir}/anbox-modules/binder/"* "${pkgdir}/usr/src/binder-1/"
+}