summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDario Ostuni2019-09-07 11:54:11 +0200
committerDario Ostuni2019-09-07 11:54:11 +0200
commite5b8fbb79bcbe21e502de7828111ef8c9253b323 (patch)
treec1961e1d8772220928a0dc8874e1077adf80abf0
downloadaur-e5b8fbb79bcbe21e502de7828111ef8c9253b323.tar.gz
Initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD16
-rw-r--r--wasm.conf1
3 files changed, 30 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5ca452d8a016
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = binfmt-wasm
+ pkgdesc = Register wasmtime interpreter for wasm format
+ pkgver = 20190907
+ pkgrel = 1
+ url = http://www.freedesktop.org/software/systemd/man/binfmt.d.html
+ arch = any
+ license = MPL2
+ depends = wasmtime
+ source = wasm.conf
+ sha384sums = a7f7237a20bfd41484e6abfe1d5224cdd6ca1f7e563c04ef8b80c0a7e9893c2a5d6a34876e85ef7275d06ae7c9242c23
+
+pkgname = binfmt-wasm
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8ea04607fce9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,16 @@
+# Maintainer: Dario Ostuni <dario.ostuni@gmail.com>
+
+pkgname=binfmt-wasm
+pkgver=20190907
+pkgrel=1
+pkgdesc="Register wasmtime interpreter for wasm format"
+arch=('any')
+url="http://www.freedesktop.org/software/systemd/man/binfmt.d.html"
+license=('MPL2')
+depends=('wasmtime')
+source=("wasm.conf")
+sha384sums=('a7f7237a20bfd41484e6abfe1d5224cdd6ca1f7e563c04ef8b80c0a7e9893c2a5d6a34876e85ef7275d06ae7c9242c23')
+
+package() {
+ install -Dm 644 "$srcdir/wasm.conf" "$pkgdir/usr/lib/binfmt.d/wasm.conf"
+}
diff --git a/wasm.conf b/wasm.conf
new file mode 100644
index 000000000000..e4326eef7e29
--- /dev/null
+++ b/wasm.conf
@@ -0,0 +1 @@
+:wasm1:M::\x00\x61\x73\x6d\x01\x00\x00\x00::/usr/bin/wasmtime:CF