summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMax Resch2019-12-05 18:02:34 +0100
committerMax Resch2019-12-05 18:02:34 +0100
commitd3001fbc6c4f6ff95bd49edc9024c2beefd50505 (patch)
treebe75e3c687a6a1a2ebea85b997a91dbe2c403ccf
parent4d2de30695b48b20ff961c8fa858a3782e05b6b6 (diff)
downloadaur-d3001fbc6c4f6ff95bd49edc9024c2beefd50505.tar.gz
update to 1.3.5 from website
-rw-r--r--PKGBUILD16
-rw-r--r--makefile.patch9
-rw-r--r--memcpy.patch20
3 files changed, 24 insertions, 21 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e8e0a0563013..377d455b2e68 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,28 +4,26 @@ pkgname=bing
pkgver=1.3.5
pkgrel=1
pkgdesc="Measure the bandwidth between two hosts using the ICMP protocol without the need of a client/server architecture"
-arch=('i686' 'x86_64')
-url="http://fgouget.free.fr/bing/bing_src-readme-1st.shtml"
+arch=('i686' 'x86_64' 'armv6h' 'armv7h' 'aarch64')
+url="http://fgouget.free.fr/bing/index-en.shtml"
license=('BSD')
-optdepends=('libcap: for setting cap_net_raw')
source=(
- "http://http.debian.net/debian/pool/main/b/bing/${pkgname}_${pkgver}.orig.tar.gz"
+ "http://fgouget.free.fr/bing/bing_src-${pkgver}.tar.gz"
"makefile.patch"
"memcpy.patch" )
sha256sums=(
'12bbf7f869474691f8d1f42aaa28547b2eee338576397dccd9d5bf862fc90768'
- 'be1874bb8d39021f072409d4c52291da71e36edca9762b5cbc631b597422e57b'
- '170ce4b0cb4696b719d567721798b388900c2c646fffc15d3b3b1bf19b67554d' )
+ 'e04114e388e51a25c2775fc344e2c98bb106eb7b6198c94a1a59a05017ac1225'
+ 'f18f0c48aa4fda031f119ba095ecb5eb9c1cd9e85c92eef976f4aa485fe82e43' )
install="${pkgname}.install" # setcap cap_net_raw or setuid root
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
- # add #include<string.h> to avoid missing memcpy() warning
- patch -p1 < ${srcdir}/memcpy.patch
# remove debug build flags
patch -p1 < ${srcdir}/makefile.patch
+ patch -p1 < ${srcdir}/memcpy.patch
CFLAGS="$(CFLAGS) -fPIC -D_FORTIFY_SOURCE=2" LDFLAGS="$(LDFLAGS) -Wl,-z,relro,-z,now -pie" make
- gzip -k unix/bing.8
+ gzip -c unix/bing.8 > unix/bing.8.gz
}
package() {
diff --git a/makefile.patch b/makefile.patch
index fd9c2895ab1f..92604c5f794e 100644
--- a/makefile.patch
+++ b/makefile.patch
@@ -1,6 +1,7 @@
-diff -u bing-1.3.5.orig/Makefile bing-1.3.5/Makefile
---- bing-1.3.5.orig/Makefile 1999-10-26 08:42:16.000000000 +0200
-+++ bing-1.3.5/Makefile 2018-08-26 17:22:36.976401721 +0200
+Gemeinsame Unterverzeichnisse: bing-1.3.5/include und bing-1.3.5-makefile/include.
+diff -u bing-1.3.5/Makefile bing-1.3.5-makefile/Makefile
+--- bing-1.3.5/Makefile 1999-10-26 08:42:16.000000000 +0200
++++ bing-1.3.5-makefile/Makefile 2019-12-05 17:54:43.579231998 +0100
@@ -46,9 +46,9 @@
# You may optionally provide some optimisation flags. Optimising bing for
# speed should slightly improve the results.
@@ -13,3 +14,5 @@ diff -u bing-1.3.5.orig/Makefile bing-1.3.5/Makefile
# -> on Solaris you may use
#COPTIM = -O
# on some hosts like AIX, HP-UX the optimisation options are already set
+Gemeinsame Unterverzeichnisse: bing-1.3.5/unix und bing-1.3.5-makefile/unix.
+Gemeinsame Unterverzeichnisse: bing-1.3.5/win32 und bing-1.3.5-makefile/win32.
diff --git a/memcpy.patch b/memcpy.patch
index 8ca7d6b4db46..ddf80dba7d74 100644
--- a/memcpy.patch
+++ b/memcpy.patch
@@ -1,12 +1,14 @@
-diff -u bing-1.3.5/bing_probes.c bing-1.3.5_n/bing_probes.c
---- bing-1.3.5.orig/bing_probes.c 1999-10-26 08:42:16.000000000 +0200
-+++ bing-1.3.5/bing_probes.c 2018-08-26 17:13:15.156726035 +0200
-@@ -7,6 +7,7 @@
- /* $Id: bing_probes.c,v 1.12 1999/10/24 23:28:14 fgouget Exp $ */
-
- #include <stdio.h>
-+#include <string.h>
+diff -u bing-1.3.5/bing_probes.c bing-1.3.5-memcpy/bing_probes.c
+--- bing-1.3.5/bing_probes.c 1999-10-26 08:42:16.000000000 +0200
++++ bing-1.3.5-memcpy/bing_probes.c 2019-12-05 17:48:00.330139430 +0100
+@@ -10,6 +10,7 @@
#include <errno.h>
#include <malloc.h>
#include <stdlib.h>
-
++#include <string.h>
+
+ /* types.h provides u_short on HPUX10 and Solaris */
+ #include <sys/types.h>
+Gemeinsame Unterverzeichnisse: bing-1.3.5/include und bing-1.3.5-memcpy/include.
+Gemeinsame Unterverzeichnisse: bing-1.3.5/unix und bing-1.3.5-memcpy/unix.
+Gemeinsame Unterverzeichnisse: bing-1.3.5/win32 und bing-1.3.5-memcpy/win32.