summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-03-22 15:01:44 +0800
committerzxp198210052024-03-22 15:01:44 +0800
commita18d49ac1a19e3214cb154d2e17ec845a9a13232 (patch)
treecc42248ff1e09cc2a17a3c2987466edbb9f25785
parent59ce1e65df55195e87fbdeb6da2f6cda09ea2e7f (diff)
downloadaur-a18d49ac1a19e3214cb154d2e17ec845a9a13232.tar.gz
fix errors
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD7
-rw-r--r--binggpt-ee.sh5
3 files changed, 10 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b60c5bc29641..3289baf3393d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,18 @@
pkgbase = binggpt-ee-bin
pkgdesc = BingGPT Enhanced Editon - Desktop application of new Bing's AI-powered chat.A rewritten version.
pkgver = 0.4.7
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/fangkehou-team/BingGPT_Enhanced_Editon
arch = aarch64
arch = x86_64
license = Apache-2.0
- depends = electron26
+ depends = electron26-bin
provides = binggpt-desktop
conflicts = binggpt
conflicts = binggpt-desktop
conflicts = binggpt-ee
source = binggpt-ee.sh
- sha256sums = 50b10386d13e5bec806aeb78f819c4edd0208a4d184332e53866c802731217fe
+ sha256sums = dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8
source_aarch64 = binggpt-ee-0.4.7-aarch64.deb::https://github.com/fangkehou-team/BingGPT_Enhanced_Editon/releases/download/v0.4.7/BingGPT-Linux-arm64-0.4.7.deb
sha256sums_aarch64 = c51a2fd6705dc5bfe7b3cdebf6fd6daedade8be00fc5e8cbd0abc3ddbda20b16
source_x86_64 = binggpt-ee-0.4.7-x86_64.deb::https://github.com/fangkehou-team/BingGPT_Enhanced_Editon/releases/download/v0.4.7/BingGPT-Linux-amd64-0.4.7.deb
diff --git a/PKGBUILD b/PKGBUILD
index 6835bf905425..e87e10228ea5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ pkgname="${_pkgname}-ee-bin"
_appname=BingGPT
pkgver=0.4.7
_electronversion=26
-pkgrel=2
+pkgrel=3
pkgdesc="BingGPT Enhanced Editon - Desktop application of new Bing's AI-powered chat.A rewritten version."
arch=(
'aarch64'
@@ -19,20 +19,21 @@ conflicts=(
)
provides=("${_pkgname}-desktop")
depends=(
- "electron${_electronversion}"
+ "electron${_electronversion}-bin"
)
source_aarch64=("${pkgname%-bin}-${pkgver}-aarch64.deb::${url}/releases/download/v${pkgver}/${_appname}-Linux-arm64-${pkgver}.deb")
source_x86_64=("${pkgname%-bin}-${pkgver}-x86_64.deb::${url}/releases/download/v${pkgver}/${_appname}-Linux-amd64-${pkgver}.deb")
source=(
"${pkgname%-bin}.sh"
)
-sha256sums=('50b10386d13e5bec806aeb78f819c4edd0208a4d184332e53866c802731217fe')
+sha256sums=('dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8')
sha256sums_aarch64=('c51a2fd6705dc5bfe7b3cdebf6fd6daedade8be00fc5e8cbd0abc3ddbda20b16')
sha256sums_x86_64=('01dafcd9a29abc8e1960ce0a405bbaa7ca7612f353d9a0bac3ab439eec564839')
build() {
sed -e "s|@electronversion@|${_electronversion}|g" \
-e "s|@appname@|${pkgname%-bin}|g" \
-e "s|@runname@|app.asar|g" \
+ -e "s|@options@||g" \
-i "${srcdir}/${pkgname%-bin}.sh"
bsdtar -xf "${srcdir}/data."*
sed -e "s|\"/opt/${_chsname}/${_appname}\"|${pkgname%-bin}|g" \
diff --git a/binggpt-ee.sh b/binggpt-ee.sh
index 86cb3dc6a9bf..7ddcaab8d734 100644
--- a/binggpt-ee.sh
+++ b/binggpt-ee.sh
@@ -2,6 +2,7 @@
set -e
_APPDIR="/usr/lib/@appname@"
_RUNNAME="${_APPDIR}/@runname@"
+_OPTIONS="@options@"
export PATH="${_APPDIR}:${PATH}"
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
export ELECTRON_IS_DEV=0
@@ -9,7 +10,7 @@ export ELECTRON_FORCE_IS_PACKAGED=true
export NODE_ENV=production
cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- exec electron@electronversion@ "${_RUNNAME}" "$@" || exit $?
+ exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" "$@" || exit $?
else
- exec electron@electronversion@ "${_RUNNAME}" --no-sandbox "$@" || exit $?
+ exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" --no-sandbox "$@" || exit $?
fi \ No newline at end of file