summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShibumi2015-08-19 19:36:32 +0200
committerShibumi2015-08-19 19:36:32 +0200
commit1b6ce7cc007f7a3b38f6aee252fd9268e83cd5bb (patch)
treee340eab3360f1a37ab0d9e07273385ca8d0e8149
downloadaur-1b6ce7cc007f7a3b38f6aee252fd9268e83cd5bb.tar.gz
initial push
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD25
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a784c50dd748
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = binnavi-git
+ pkgdesc = BinNavi is a binary analysis IDE that allows to inspect, navigate, edit and annotate control flow graphs and call graphs of disassembled code
+ pkgver = 0.0.590.8512d7c
+ pkgrel = 1
+ url = https://github.com/google/binnavi
+ arch = any
+ license = Apache
+ makedepends = git
+ provides = binnavi
+ conflicts = binnavi
+ source = binnavi-git::https://github.com/google/binnavi.git
+ sha512sums = SKIP
+
+pkgname = binnavi-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a27ba773afcd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Christian Rebischke <echo Q2hyaXMuUmViaXNjaGtlQGdtYWlsLmNvbQo= | base64 -d>
+pkgname=binnavi-git
+pkgver=0.0.590.8512d7c
+pkgrel=1
+pkgdesc="BinNavi is a binary analysis IDE that allows to inspect, navigate, edit and annotate control flow graphs and call graphs of disassembled code"
+url="https://github.com/google/binnavi"
+arch=('any')
+license=('Apache')
+depends=()
+makedepends=('git')
+provides=('binnavi')
+conflicts=('binnavi')
+source=(${pkgname}::https://github.com/google/binnavi.git)
+sha512sums=('SKIP')
+
+pkgver() {
+ cd ${pkgname}
+ printf "%s.%s.%s" "0.0" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ echo "in work"
+}
+
+# vim:set et sw=2 ts=2 tw=80: