summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorclintval2017-12-19 11:49:15 -0500
committerclintval2017-12-19 11:49:15 -0500
commitb67944f0c285c5a3bfe92f8d1fa97f241d52c1b3 (patch)
treef4a4b1fa53923ffa2605f59d4eb2b7ec56e35691
downloadaur-b67944f0c285c5a3bfe92f8d1fa97f241d52c1b3.tar.gz
First commit with PKGBUILD and .SRCINFO
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD34
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c1f671307196
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = biobambam
+ pkgdesc = Bioinformatics BAM file pre-processing utilities
+ pkgver = 2.0.79
+ pkgrel = 1
+ url = https://github.com/gt1/biobambam2
+ arch = x86_64
+ license = GPL3
+ makedepends = gcc-libs
+ depends = libmaus>=2.0
+ provides = biobambam
+ conflicts = biobambam
+ source = https://github.com/gt1/biobambam2/archive/2.0.79-release-20171006114010.tar.gz
+ md5sums = 534458a7b22e37bfd4b5b6e9c590553f
+
+pkgname = biobambam
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e7e108c292ca
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Clint Valentine <valentine.clint@gmail.com>
+
+pkgname=biobambam
+pkgver=2.0.79
+pkgrel=1
+release=20171006114010
+pkgdesc="Bioinformatics BAM file pre-processing utilities"
+arch=('x86_64')
+url="https://github.com/gt1/biobambam2"
+license=('GPL3')
+depends=('libmaus>=2.0')
+makedepends=('gcc-libs')
+provides=('biobambam')
+conflicts=('biobambam')
+source=("https://github.com/gt1/${pkgname}2/archive/${pkgver}-release-${release}.tar.gz")
+md5sums=('534458a7b22e37bfd4b5b6e9c590553f')
+MAKEFLAGS="-j$(nproc)"
+
+build()
+{
+ cd "${srcdir}/${pkgname}2-${pkgver}-release-${release}"
+ ./configure \
+ --prefix="${pkgdir}/usr"
+}
+
+check() {
+ cd "${srcdir}/${pkgname}2-${pkgver}-release-${release}"
+ make test
+}
+
+package() {
+ cd "${srcdir}/${pkgname}2-${pkgver}-release-${release}"
+ make install
+}