summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormschubert2015-06-12 12:07:46 +0100
committermschubert2015-06-12 12:07:46 +0100
commit9cefe4561dbddb8022362babaeb697c0638ea401 (patch)
treeac27f961f4eead440c6da7ff46131fd08f8d7b8f
downloadaur-9cefe4561dbddb8022362babaeb697c0638ea401.tar.gz
Initial import
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD22
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..de685816366a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = biomart
+ pkgdesc = A query-oriented data management system
+ pkgver = 0.8
+ pkgrel = 1
+ url = http://www.biomart.org/
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ depends = java-runtime
+ source = ftp://ftp.ebi.ac.uk/pub/software/biomart/martj_current/martj-bin.tar.gz
+ md5sums = 9381d0fd3a76652bfbebc60b209d9e0c
+
+pkgname = biomart
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..10bd9c2448bc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Michael Schubert <mschu.dev at google mail>
+
+pkgname=biomart
+pkgver=0.8
+pkgrel=1
+pkgdesc="A query-oriented data management system"
+arch=('i686' 'x86_64')
+url="http://www.biomart.org/"
+license=('LGPL')
+depends=('java-runtime')
+source=('ftp://ftp.ebi.ac.uk/pub/software/biomart/martj_current/martj-bin.tar.gz')
+md5sums=('9381d0fd3a76652bfbebc60b209d9e0c')
+
+package() {
+ mkdir -p $pkgdir/opt/biomart
+ cp -r $srcdir/martj-bin/* $pkgdir/opt/biomart/
+
+ mkdir -p $pkgdir/usr/bin
+ for L in martbuilder marteditor martexplorer martregistrydbtool martrunner martshell; do
+ ln -s /opt/biomart/bin/$L.sh $pkgdir/usr/bin/$L
+ done
+}