summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTeddyHuang-002024-04-23 11:05:35 -0400
committerTeddyHuang-002024-04-23 11:05:35 -0400
commit86e54589197b03c5127d2bf99aadf093237a5a52 (patch)
tree5b32006f268b74672d5a319c214938b1ffdd484d
parent759cff50cd4bf6769b69a34e7759ae44491573a0 (diff)
downloadaur-86e54589197b03c5127d2bf99aadf093237a5a52.tar.gz
Upgrade to v1.7.1
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD6
-rw-r--r--biome-bin.changelog67
3 files changed, 72 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 413f1e729506..5d0f47f29068 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = biome-bin
pkgdesc = A toolchain for web projects, aimed to provide functionalities to maintain them. Biome offers formatter and linter, usable via CLI and LSP.
- pkgver = 1.7.0
+ pkgver = 1.7.1
pkgrel = 1
url = https://github.com/biomejs/biome
changelog = biome-bin.changelog
@@ -14,9 +14,9 @@ pkgbase = biome-bin
source = LICENSE-MIT::https://raw.githubusercontent.com/biomejs/biome/main/LICENSE-MIT
sha256sums = e2746aba8799f7a3378259f36a83a079e811ca7926cbdd248a2eb7ca9cbbac5d
sha256sums = 4f6a0d776a00c0f46e1da1879321896071494229aa3219862a625e4560691a3a
- source_x86_64 = biome-bin-x86_64-1.7.0::https://github.com/biomejs/biome/releases/download/cli/v1.7.0/biome-linux-x64-musl
- sha256sums_x86_64 = 9e8df2e263bd1a3c057a661682b280edf73c40a288f0c3267d11fcde2553cb87
- source_aarch64 = biome-bin-aarch64-1.7.0::https://github.com/biomejs/biome/releases/download/cli/v1.7.0/biome-linux-arm64-musl
- sha256sums_aarch64 = a042bf5ee40e0b84ee7860a58af69d0766db719eec5a103e9f09b2eef08cf663
+ source_x86_64 = biome-bin-x86_64-1.7.1::https://github.com/biomejs/biome/releases/download/cli/v1.7.1/biome-linux-x64-musl
+ sha256sums_x86_64 = 1b2115fdab03dba4c59cb3d512822e11ceb16f294519343b2e373f9b7aa1a074
+ source_aarch64 = biome-bin-aarch64-1.7.1::https://github.com/biomejs/biome/releases/download/cli/v1.7.1/biome-linux-arm64-musl
+ sha256sums_aarch64 = 02e41aa2eb4994db7316913f58a38b5c7c7876f7d8320625d0c12ccdbc62d0fa
pkgname = biome-bin
diff --git a/PKGBUILD b/PKGBUILD
index 001f0a1d0cbf..45a8e6d2be5c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Theodore Huang <teddyhuangnan@gmail.com>
pkgname=biome-bin
-pkgver=1.7.0
+pkgver=1.7.1
pkgrel=1
pkgdesc="A toolchain for web projects, aimed to provide functionalities to maintain them. Biome offers formatter and linter, usable via CLI and LSP."
arch=("x86_64" "aarch64")
@@ -22,8 +22,8 @@ source_aarch64=(
# checksum generate with 'makepkg -g'
sha256sums=('e2746aba8799f7a3378259f36a83a079e811ca7926cbdd248a2eb7ca9cbbac5d'
'4f6a0d776a00c0f46e1da1879321896071494229aa3219862a625e4560691a3a')
-sha256sums_x86_64=('9e8df2e263bd1a3c057a661682b280edf73c40a288f0c3267d11fcde2553cb87')
-sha256sums_aarch64=('a042bf5ee40e0b84ee7860a58af69d0766db719eec5a103e9f09b2eef08cf663')
+sha256sums_x86_64=('1b2115fdab03dba4c59cb3d512822e11ceb16f294519343b2e373f9b7aa1a074')
+sha256sums_aarch64=('02e41aa2eb4994db7316913f58a38b5c7c7876f7d8320625d0c12ccdbc62d0fa')
build() {
mkdir -p "$srcdir/$pkgname-$pkgver"
diff --git a/biome-bin.changelog b/biome-bin.changelog
index 6cb1bd413ee4..eb2e47f397b6 100644
--- a/biome-bin.changelog
+++ b/biome-bin.changelog
@@ -13,6 +13,30 @@ our [guidelines for writing a good changelog entry](https://github.com/biomejs/b
### Analyzer
+#### Bug fixes
+
+- Import sorting now ignores side effect imports ([#817](https://github.com/biomejs/biome/issues/817)).
+
+ A side effect import consists now in its own group.
+ This ensures that side effect imports are not reordered.
+
+ Here is an example of how imports are now sorted:
+
+ ```diff
+ import "z"
+ - import { D } from "d";
+ import { C } from "c";
+ + import { D } from "d";
+ import "y"
+ import "x"
+ - import { B } from "b";
+ import { A } from "a";
+ + import { B } from "b";
+ import "w"
+ ```
+
+ Contributed by @Conaclos
+
### CLI
### Configuration
@@ -23,15 +47,52 @@ our [guidelines for writing a good changelog entry](https://github.com/biomejs/b
#### Bug fixes
+- Correctly handle placement of comments inside named import clauses. [#2566](https://github.com/biomejs/biome/pull/2566). Contributed by @ah-yu
+
### JavaScript APIs
### Linter
-#### New features
+### Parser
+
+## 1.7.1 (2024-04-22)
+
+### Editors
#### Bug fixes
-### Parser
+- Fix [#2403](https://github.com/biomejs/biome/issues/2403) by printing the errors in the client console. Contributed by @ematipico
+
+### Formatter
+
+#### Bug fixes
+
+- Add parentheses for the return expression that has leading multiline comments. [#2504](https://github.com/biomejs/biome/pull/2504). Contributed by @ah-yu
+
+- Correctly format dangling comments of continue statements. [#2555](https://github.com/biomejs/biome/pull/2555). Contributed by @ah-yu
+
+### Linter
+
+#### Bug fixes
+
+- Fix case where `jsxRuntime` wasn't being respected by `useImportType` rule ([#2473](https://github.com/biomejs/biome/issues/2473)).Contributed by @arendjr
+- Fix [#2460](https://github.com/biomejs/biome/issues/2460), where the rule `noUselessFragments` was crashing the linter in some cases. Now cases like these are correctly handled:
+ ```jsx
+ callFunction(<>{bar}</>)
+ ```
+ Contributed by @ematipico
+- Fix [#2366](https://github.com/biomejs/biome/issues/2366), where `noDuplicateJsonKeys` incorrectly computed the kes to highlight. Contributed by @ematipico
+#### Enhancements
+
+- The rule `noMisplacedAssertions` now considers valid calling `expect` inside `waitFor`:
+ ```js
+ import { waitFor } from '@testing-library/react';
+
+ await waitFor(() => {
+ expect(111).toBe(222);
+ });
+ ```
+ Contributed by @ematipico
## 1.7.0 (2024-04-15)
@@ -1138,7 +1199,7 @@ Additionally, the following rules are now recommended:
- Add rule [noExcessiveNestedTestSuites](https://biomejs.dev/linter/rules/no-excessive-nested-test-suites/).
Contributed by @vasucp1207
-- Add rule [useJsxKeyInIterable](https://biomejs.dev/linter/rules/use-jsx-key-in-iterable/).
+- Add rule [useJsxKeyInIterable](https://biomejs.dev/linter/rules/use-jsx-key-in-iterable/).
Contributed by @vohoanglong0107
#### Enhancements