summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorclintval2018-03-16 18:55:37 -0700
committerclintval2018-03-16 18:55:37 -0700
commit414b0c420f4c4c029c6454c880cb835a02d8b194 (patch)
treeb2cf17e1247d33a194003fe84731e2653b27de1c
parenta96e7ed370d8291b89a0da67a482214881203cb5 (diff)
downloadaur-414b0c420f4c4c029c6454c880cb835a02d8b194.tar.gz
biopieces to 2.0
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD119
2 files changed, 51 insertions, 85 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dd88b994c60b..af275310bd4e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,10 @@
pkgbase = biopieces
pkgdesc = Bioinformatic framework of tools easily used and easily created
- pkgver = r2311
+ pkgver = 2.0
pkgrel = 1
- url = http://biopieces.googlecode.com/
+ url = http://maasha.github.io/biopieces/
arch = any
license = GPL2
- makedepends = svn
depends = perl
depends = ruby
depends = perl-svg
@@ -22,16 +21,12 @@ pkgbase = biopieces
depends = perl-parse-recdescent
depends = perl-dbd-mysql
depends = ruby-gnuplot
- depends = ruby-narray
depends = perl-json-xs
depends = python2
- depends = ruby-rubyinline
depends = ruby-terminal-table
- optdepends = rubyinline
optdepends = blast: legacy blast
optdepends = gnuplot
optdepends = blat
- optdepends = ray
optdepends = bwa
optdepends = bowtie
optdepends = bowtie2
@@ -39,12 +34,8 @@ pkgbase = biopieces
optdepends = mummer
optdepends = muscle
optdepends = velvet
- source = biopieces::svn+http://biopieces.googlecode.com/svn/trunk
- source = biopieces/bp_usage::svn+http://biopieces.googlecode.com/svn/wiki
- source = biopieces.sh
- md5sums = SKIP
- md5sums = SKIP
- md5sums = 8ebebd698533ae818c8cfbef4fa8e9ca
+ source = biopieces-2.0.tar.gz::https://github.com/maasha/biopieces/archive/2.0.tar.gz
+ sha256sums = 484877c4a844ed1e6c70594248c44b9f19a6e7a1fd08456e28f2cc83425151e8
pkgname = biopieces
diff --git a/PKGBUILD b/PKGBUILD
index 56bcbec7a45e..33f327417ddb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,79 +1,54 @@
-# Maintainer: Sebastian Wilzbach < sebi at wilzbach dot me >
+# Maintainer: Clint Valentine <valentine.clint@gmail.com>
+# Contributer: Sebastian Wilzbach <sebi at wilzbach dot me>
+
pkgname=biopieces
-pkgver=r2311
+pkgver=2.0
pkgrel=1
-epoch=
-pkgdesc="Bioinformatic framework of tools easily used and easily created"
-arch=("any")
-url="http://biopieces.googlecode.com/"
+pkgdesc='Bioinformatic framework of tools easily used and easily created'
+arch=('any')
+url='http://maasha.github.io/biopieces/'
license=('GPL2')
-groups=()
-depends=('perl' 'ruby' "perl-svg" "perl-bit-vector" "perl-term-readkey" "perl-dbi" "perl-xml-parser" "perl-carp-clan"
- "perl-class-inspector" "perl-html-parser" "perl-soap-lite" "perl-uri" "perl-inline" "perl-parse-recdescent" "perl-dbd-mysql"
- 'ruby-gnuplot' 'ruby-narray' 'perl-json-xs' 'python2' 'ruby-rubyinline' 'ruby-terminal-table')
-makedepends=("svn")
-checkdepends=()
-optdepends=('rubyinline' 'blast: legacy blast' 'gnuplot' 'blat' 'ray' 'bwa' 'bowtie' 'bowtie2' 'hmmer' 'mummer' 'muscle' 'velvet')
-provides=()
-conflicts=()
-replaces=()
-backup=()
-options=()
-install=
-changelog=
-source=("biopieces::svn+http://biopieces.googlecode.com/svn/trunk"
-"biopieces/bp_usage::svn+http://biopieces.googlecode.com/svn/wiki"
-"biopieces.sh")
-noextract=()
-md5sums=('SKIP'
-'SKIP'
-'8ebebd698533ae818c8cfbef4fa8e9ca')
-
-pkgver() {
- cd "$srcdir/$pkgname"
- local ver="$(svnversion)"
- printf "r%s" "${ver//[[:alpha:]]}"
-}
+depends=(
+ 'perl'
+ 'ruby'
+ 'perl-svg'
+ 'perl-bit-vector'
+ 'perl-term-readkey'
+ 'perl-dbi'
+ 'perl-xml-parser'
+ 'perl-carp-clan'
+ 'perl-class-inspector'
+ 'perl-html-parser'
+ 'perl-soap-lite'
+ 'perl-uri'
+ 'perl-inline'
+ 'perl-parse-recdescent'
+ 'perl-dbd-mysql'
+ 'ruby-gnuplot'
+ 'perl-json-xs'
+ 'python2'
+ 'ruby-terminal-table'
+)
+optdepends=(
+ 'blast: legacy blast'
+ 'gnuplot'
+ 'blat'
+ 'bwa'
+ 'bowtie'
+ 'bowtie2'
+ 'hmmer'
+ 'mummer'
+ 'muscle'
+ 'velvet'
+)
+source=("${pkgname}"-"${pkgver}".tar.gz::https://github.com/maasha/"${pkgname}"/archive/"${pkgver}".tar.gz)
+sha256sums=('484877c4a844ed1e6c70594248c44b9f19a6e7a1fd08456e28f2cc83425151e8')
package() {
- cd "$pkgdir"
- mkdir -p "opt/$pkgname"
-
- cp -a "$srcdir/biopieces" "opt/"
-
- # remove svn history
- rm -r -f "opt/$pkgname/.svn"
- rm -r -f "opt/$pkgname/bp_usage/.svn"
- rm -r -f "opt/$pkgname/.makepkg"
-
- # patch python2 scripts
- find "opt/$pkgname/code_python" -type f -exec sed -i 's/#!\/usr\/bin\/python/&2/' {} \;
-
- # install exports
- install -Dm755 "$srcdir/$pkgname.sh" etc/profile.d/$pkgname.sh
- source etc/profile.d/$pkgname.sh
-}
-
-check() {
- cd "$srcdir/biopieces"
-
- # set the constant for the test suite
- export BP_DIR=$(pwd)
- export BP_TMP=$BP_DIR"/tmp"
- export BP_LOG="$BP_TMP/log"
- mkdir -p $BP_LOG
-
- # source the config
- source "bp_conf/bashrc"
-
- # permission to write on bp_test
- chmod a+w "bp_test"
- chmod a+w "bp_test/in"
- chmod a+w "bp_test/out"
-
- # calling test
- /bin/bash "bp_test/test_all"
+ cd "${srcdir}"/"${pkgname}"-"${pkgver}"
- # remove unnecessary test output
- rm -r -f $BP_TMP
+ for script in bin/*; do
+ if [[ "${script}" =~ README ]]; then continue; fi
+ install -Dm755 "${script}" "${pkgdir}"/opt/"${pkgname}"/"${pkgname}"-"$( basename "${script}" )"
+ done
}