summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJiri Pospisil2024-03-29 14:05:21 +0000
committerJiri Pospisil2024-03-29 14:05:21 +0000
commit352aaae0cf7de5811d4c849b2db1734034c6fd31 (patch)
tree9f8373d585b0b60745e8372b8deca9443a106367
downloadaur-352aaae0cf7de5811d4c849b2db1734034c6fd31.tar.gz
Initial upload
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD35
3 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3fa74384c2c5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = bios_renamer_for_asus-git
+ pkgdesc = Cross-platform Rust implementation of Asus' BIOS renamer utility.
+ pkgver = r36.04c12c2
+ pkgrel = 1
+ url = https://github.com/iAmSomeone2/bios_renamer_for_asus
+ arch = x86_64
+ license = MIT
+ makedepends = cargo
+ makedepends = git
+ provides = bios_renamer_for_asus
+ conflicts = bios_renamer_for_asus
+ source = bios_renamer_for_asus-git::git+https://github.com/iAmSomeone2/bios_renamer_for_asus.git#branch=main
+ sha256sums = SKIP
+
+pkgname = bios_renamer_for_asus-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..dec7332cfcc2
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.tar.*
+src/
+pkg/
+*.log
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6dc4fc19f1ac
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Jiri Pospisil <jiri@jpospisil.com>
+
+pkgname='bios_renamer_for_asus-git'
+pkgver=r36.04c12c2
+pkgrel=1
+pkgdesc="Cross-platform Rust implementation of Asus' BIOS renamer utility."
+url='https://github.com/iAmSomeone2/bios_renamer_for_asus'
+arch=('x86_64')
+makedepends=('cargo' 'git')
+provides=('bios_renamer_for_asus')
+conflicts=('bios_renamer_for_asus')
+license=('MIT')
+source=("$pkgname::git+$url.git#branch=main")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short=7 HEAD)"
+}
+
+build() {
+ cd "$pkgname"
+
+ export RUSTUP_TOOLCHAIN=stable
+ export CARGO_TARGET_DIR=target
+
+ cargo build --release # --locked (there's no Cargo.lock in the repo)
+}
+
+package() {
+ cd "$pkgname"
+
+ install -Dm755 "target/release/bios_renamer_for_asus" "$pkgdir/usr/bin/bios_renamer_for_asus"
+}