summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVladislav2023-10-08 16:19:02 +0300
committerVladislav2023-10-08 16:19:02 +0300
commitdbdc81a013d745b8444b6d5109564491e3de9b4a (patch)
treed2c87d409b310288839a7519d3cd1ab39eb942d2
downloadaur-bip39-standalone.tar.gz
Initial release
-rw-r--r--.SRCINFO12
-rwxr-xr-xPKGBUILD16
2 files changed, 28 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6edfb75da639
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = bip39-standalone
+ pkgdesc = A tool for converting BIP39 mnemonic phrases to addresses and private keys.
+ pkgver = 0.5.6
+ pkgrel = 1
+ url = https://github.com/iancoleman/bip39
+ arch = any
+ license = MIT
+ optdepends = nginx: reverse-proxy
+ source = https://github.com/iancoleman/bip39/releases/download/0.5.6/bip39-standalone.html
+ sha256sums = 129b03505824879b8a4429576e3de6951c8599644c1afcaae80840f79237695a
+
+pkgname = bip39-standalone
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..2a57b9194ba1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,16 @@
+# Maintainer: VVL <me@ivvl.ru>
+
+pkgname=bip39-standalone
+pkgver=0.5.6
+pkgrel=1
+pkgdesc="A tool for converting BIP39 mnemonic phrases to addresses and private keys."
+arch=(any)
+url="https://github.com/iancoleman/bip39"
+license=('MIT')
+source=("https://github.com/iancoleman/bip39/releases/download/$pkgver/bip39-standalone.html")
+optdepends=('nginx: reverse-proxy')
+sha256sums=('129b03505824879b8a4429576e3de6951c8599644c1afcaae80840f79237695a')
+package() {
+ cd "$srcdir"
+ install -Dm755 bip39-standalone.html "$pkgdir/usr/share/webapps/bip39-standalone.html"
+}