aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Parrish2017-12-17 12:23:20 -0500
committerDavid Parrish2017-12-17 12:23:58 -0500
commit16c6d869a1a5462bc648a42f2d7da113a7362eb8 (patch)
tree60b88c37b7df42363dcedadd1fc75e71b47bd9bd
parent2bd662bae5ee84b42c5847288275db72d2a705f8 (diff)
downloadaur-bip39tool-git.tar.gz
Adapt coinbin PKGBUILD for bip39tool
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD33
-rw-r--r--README.md6
-rw-r--r--bip39tool.desktop7
-rwxr-xr-xbip39tool.sh3
-rw-r--r--coinbin.desktop7
-rwxr-xr-xcoinbin.sh3
7 files changed, 43 insertions, 39 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 03f6851e02ad..95cffb35ca71 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,20 @@
# Generated by mksrcinfo v8
-# Sun Dec 17 16:32:13 UTC 2017
-pkgbase = coinbin-git
- pkgdesc = A Open Source Browser Based Bitcoin Wallet
- pkgver = 1.3.r7.g64af126
+# Sun Dec 17 17:23:45 UTC 2017
+pkgbase = bip39tool-git
+ pkgdesc = A tool for converting BIP39 mnemonic phrases to addresses and private keys
+ pkgver = 0.3.1.r2.gab1bd64
pkgrel = 1
- url = https://coinb.in/
+ url = https://iancoleman.io/bip39
arch = any
license = MIT
+ makedepends = python
depends = bash
- source = coinbin-git::git+https://github.com/OutCast3k/coinbin.git
- source = coinbin.sh
- source = coinbin.desktop
+ source = bip39tool-git::git+https://github.com/iancoleman/bip39.git
+ source = bip39tool.sh
+ source = bip39tool.desktop
sha256sums = SKIP
- sha256sums = 3f4cdb3fe4226a4bfceaa5924eb267c5fcd02ae5818c2003e00d6883563e2079
- sha256sums = 1b74d74c6b476afe2a012a9a7e02edd0c1e635dc712262a7add22d6befe4a614
+ sha256sums = 0834e705a72c893f7ac77732a6d157fcd0772bb0e7c713df45474112c9156b67
+ sha256sums = a6eb2bdcd62dbcd7e5bd183cbb67d4a18c4add7613f135d03f941250ccfdfd5f
-pkgname = coinbin-git
+pkgname = bip39tool-git
diff --git a/PKGBUILD b/PKGBUILD
index 9c5a9edb79c7..0e71b6855911 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,41 @@
# Maintainer: David Parrish <daveparrish@tutanota.com>
-pkgname=coinbin-git
-pkgver=1.3.r7.g64af126
+pkgname=bip39tool-git
+pkgver=0.3.1.r2.gab1bd64
pkgrel=1
-pkgdesc="A Open Source Browser Based Bitcoin Wallet"
+pkgdesc="A tool for converting BIP39 mnemonic phrases to addresses and private keys"
arch=('any')
-url="https://coinb.in/"
+url="https://iancoleman.io/bip39"
license=('MIT')
depends=('bash')
-source=("${pkgname}::git+https://github.com/OutCast3k/coinbin.git"
- "coinbin.sh"
- "coinbin.desktop")
+makedepends=('python')
+source=("${pkgname}::git+https://github.com/iancoleman/bip39.git"
+ "bip39tool.sh"
+ "bip39tool.desktop")
sha256sums=('SKIP'
- '3f4cdb3fe4226a4bfceaa5924eb267c5fcd02ae5818c2003e00d6883563e2079'
- '1b74d74c6b476afe2a012a9a7e02edd0c1e635dc712262a7add22d6befe4a614')
+ '0834e705a72c893f7ac77732a6d157fcd0772bb0e7c713df45474112c9156b67'
+ 'a6eb2bdcd62dbcd7e5bd183cbb67d4a18c4add7613f135d03f941250ccfdfd5f')
pkgver() {
cd "$pkgname"
git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
+build() {
+ cd "${srcdir}/${pkgname}"
+ python compile.py
+}
+
package() {
# Install License
install -Dm644 $pkgname/LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
- # Install coinbin application files
- mkdir -p "$pkgdir/usr/share/$pkgname"
- cp -r $pkgname/* "$pkgdir/usr/share/$pkgname"
+ # Install html file
+ install -Dm644 $pkgname/bip39-standalone.html "$pkgdir/usr/share/$pkgname/bip39-standalone.html"
# Install binary
- install -Dm755 coinbin.sh "${pkgdir}/usr/bin/coinbin"
+ install -Dm755 bip39tool.sh "${pkgdir}/usr/bin/bip39tool"
# Install desktop launcher
- install -Dm644 coinbin.desktop "${pkgdir}/usr/share/applications/coinbin.desktop"
+ install -Dm644 bip39tool.desktop "${pkgdir}/usr/share/applications/bip39tool.desktop"
}
diff --git a/README.md b/README.md
index 4312e73d6b0e..761ece199937 100644
--- a/README.md
+++ b/README.md
@@ -1,5 +1,3 @@
-# bitaddress for Arch Linux
+# bip39 web tool for Arch Linux
-Install bitaddress client side using the (AUR bitaddress package)[https://aur.archlinux.org/packages/bitaddress-git/]. The AUR package will build the HTML file from source and install a launcher on your desktop.
-
-If you have (yaourt)[https://archlinux.fr/yaourt-en] installed then run `yaourt -S bitaddress-git` to install.
+Install bip39 web tool client side using the (AUR bip39tool package)[https://aur.archlinux.org/packages/bip39tool-git/]. The AUR package will build the HTML file from source and install a launcher on your desktop.
diff --git a/bip39tool.desktop b/bip39tool.desktop
new file mode 100644
index 000000000000..695850b822f3
--- /dev/null
+++ b/bip39tool.desktop
@@ -0,0 +1,7 @@
+[Desktop Entry]
+Name=BIP 39 Tool
+Type=Application
+Comment=A tool for converting BIP39 mnemonic phrases to addresses and private keys
+Exec=bip39tool
+Categories=Utility;Finance;
+GenericName=A tool for converting BIP39 mnemonic phrases to addresses and private keys
diff --git a/bip39tool.sh b/bip39tool.sh
new file mode 100755
index 000000000000..6093f3b14288
--- /dev/null
+++ b/bip39tool.sh
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+xdg-open /usr/share/bip39tool-git/bip39-standalone.html
diff --git a/coinbin.desktop b/coinbin.desktop
deleted file mode 100644
index 5999457b7c12..000000000000
--- a/coinbin.desktop
+++ /dev/null
@@ -1,7 +0,0 @@
-[Desktop Entry]
-Name=Coinbin
-Type=Application
-Comment=A Open Source Browser Based Bitcoin Wallet
-Exec=coinbin
-Categories=Utility;Finance;
-GenericName=A Open Source Browser Based Bitcoin Wallet
diff --git a/coinbin.sh b/coinbin.sh
deleted file mode 100755
index 0d1e285b151f..000000000000
--- a/coinbin.sh
+++ /dev/null
@@ -1,3 +0,0 @@
-#!/bin/sh
-
-xdg-open /usr/share/coinbin-git/index.html