summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjhammen2019-03-15 22:44:54 -0700
committerjhammen2019-03-15 22:44:54 -0700
commitadadc7c26b15539b64e6a2f6af0f9b45d19472ee (patch)
tree5f0fcc4f535355d10513b2c4758db78c0a61344c
parent4d7439e6d6cb78dc45a650e630b2907d351eff32 (diff)
downloadaur-adadc7c26b15539b64e6a2f6af0f9b45d19472ee.tar.gz
help menu, comment action, kill script dialog
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD6
-rw-r--r--bipscript-ide-v0.5.patch28
3 files changed, 36 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3fa5bbd86e3e..a55ea1a08d4e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = bipscript-ide
pkgdesc = IDE for the bipscript language
- pkgver = 0.4
+ pkgver = 0.5
pkgrel = 1
url = http://www.bipscript.org
arch = i686
@@ -12,10 +12,10 @@ pkgbase = bipscript-ide
depends = qt5-base
provides = bipscript-ide
conflicts = bipscript-ide
- source = https://github.com/bipscript/bipscript-ide/archive/v0.4.tar.gz
- source = bipscript-ide-v0.4.patch
- md5sums = bbc9fdbf6fc353bb9184343314085636
- md5sums = 0d66a2efe623b4ef93e1b43f65ad34ae
+ source = https://github.com/bipscript/bipscript-ide/archive/v0.5.tar.gz
+ source = bipscript-ide-v0.5.patch
+ md5sums = 42b50d93e644ecc7d039b54fbebc0ae1
+ md5sums = 846ef29e04748b623443f3264b84ed38
pkgname = bipscript-ide
diff --git a/PKGBUILD b/PKGBUILD
index 842e4c2eef81..1541611961f7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: John Hammen <jhammen@j2page.com>
pkgname=bipscript-ide
-pkgver=0.4
+pkgver=0.5
pkgrel=1
pkgdesc="IDE for the bipscript language"
arch=('i686' 'x86_64')
@@ -13,8 +13,8 @@ provides=("bipscript-ide")
conflicts=("bipscript-ide")
source=("https://github.com/bipscript/$pkgname/archive/v$pkgver.tar.gz"
"$pkgname-v$pkgver.patch")
-md5sums=('bbc9fdbf6fc353bb9184343314085636'
- '0d66a2efe623b4ef93e1b43f65ad34ae')
+md5sums=('42b50d93e644ecc7d039b54fbebc0ae1'
+ '846ef29e04748b623443f3264b84ed38')
prepare() {
cd "$pkgname-$pkgver"
diff --git a/bipscript-ide-v0.5.patch b/bipscript-ide-v0.5.patch
new file mode 100644
index 000000000000..2827a4611a1b
--- /dev/null
+++ b/bipscript-ide-v0.5.patch
@@ -0,0 +1,28 @@
+diff -ur --new-file ./bipscript-ide-0.5/bipscript-ide.pro ./bipscript-ide/bipscript-ide.pro
+--- ./bipscript-ide-0.5/bipscript-ide.pro 2019-03-15 22:05:43.799996951 -0700
++++ ./bipscript-ide/bipscript-ide.pro 2019-03-15 22:21:29.773330279 -0700
+@@ -49,14 +49,6 @@
+ synhighlighter.h \
+ version.h
+
+-# version header
+-version.target = version.h
+-version.commands = '$$PWD/version.sh'
+-version.depends = FORCE
+-
+-PRE_TARGETDEPS += version.h
+-QMAKE_EXTRA_TARGETS += version
+-
+ unix {
+ INCLUDEPATH += $$PWD/jack
+ HEADERS += \
+diff -ur --new-file ./bipscript-ide-0.5/version.h ./bipscript-ide/version.h
+--- ./bipscript-ide-0.5/version.h 1969-12-31 16:00:00.000000000 -0800
++++ ./bipscript-ide/version.h 2019-03-15 22:22:48.196663613 -0700
+@@ -0,0 +1,6 @@
++#ifndef VERSION_H
++#define VERSION_H
++
++#define BIPSCRIPT_IDE_VERSION "v0.5"
++
++#endif