summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorManuel Hüsers2015-09-21 19:50:16 +0200
committerManuel Hüsers2015-09-21 19:50:16 +0200
commit9457da1208613630f43edfe659e3f1ee157772f7 (patch)
treed6bc44f0027a92878a7cb5b17c30c43a04e99ccf
parentce13a234f2010c7c66a9b47fa23323214f52f555 (diff)
downloadaur-9457da1208613630f43edfe659e3f1ee157772f7.tar.gz
Version 2.11.7
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD37
-rw-r--r--birdfont.install16
-rw-r--r--fix_install.patch33
4 files changed, 71 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0dd1417c0851..62b51a473d32 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,28 @@
pkgbase = birdfont
pkgdesc = A free font editor that lets you create vector graphics and export TTF, EOT & SVG fonts
- pkgver = 2.10.5
+ pkgver = 2.11.7
pkgrel = 1
- url = http://birdfont.org/
+ url = https://birdfont.org/
install = birdfont.install
arch = i686
arch = x86_64
license = GPL3
makedepends = vala
makedepends = gettext
- makedepends = python2
+ makedepends = python
depends = libgee
depends = webkitgtk
depends = libnotify
depends = libxmlbird
- source = http://birdfont.org/releases/birdfont-2.10.5.tar.xz
- source = http://birdfont.org/releases/birdfont-2.10.5.tar.xz.sig
+ depends = ttf-roboto
+ source = https://birdfont.org/releases/birdfont-2.11.7.tar.xz
+ source = https://birdfont.org/releases/birdfont-2.11.7.tar.xz.sig
source = http://www.unicode.org/Public/UNIDATA/NamesList.txt
- sha512sums = f72f0a0c6bfcdd14c67b8980770d4c24a89ebcd56a30fd62cecebe8e06e50e19f04326cba03a030897f45645e1a9bc8ff006ce89efb557630c535e08582c79bf
+ source = fix_install.patch
+ sha512sums = d476497ef6fa8f336820f3c35deb53eed4cdd3db58522c707d689195dcd81962db45527f45ab034b2263b220e160ab5924e22bcf8d936da42c5695b28d4c3053
sha512sums = SKIP
sha512sums = 7f9fb0349f64e8c84d1d2fa3416d561b30744d6f1fcb7d01efe1bc93dca2fe7f58148918270bfeb92551a1e08c7fefba3208af259bf35d8653a1c7772b8da259
+ sha512sums = b8d286db7d56e89045b57f93e712487c9422560c744792326799f3c58fcca2b33bb1cf4c2fe95c693ba1a28b8cfb49f12eea5b59e63cb594e4e8a4f7b5a0e13c
pkgname = birdfont
diff --git a/PKGBUILD b/PKGBUILD
index addddfa75eee..22801321c101 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,42 +1,47 @@
+# Maintainer: Manuel Hüsers <manuel.huesers@uni-ol.de>
+# Contributor: Stefan Husmann <stefan-husmann@t-online.de>
# Contributor: Matej Lach <matej.lach@gmail.com>
-# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
pkgname=birdfont
-pkgver=2.10.5
+pkgver=2.11.7
pkgrel=1
pkgdesc='A free font editor that lets you create vector graphics and export TTF, EOT & SVG fonts'
arch=(i686 x86_64)
-url='http://birdfont.org/'
+url='https://birdfont.org/'
license=('GPL3')
-depends=('libgee' 'webkitgtk' 'libnotify' 'libxmlbird')
-makedepends=('vala' 'gettext' 'python2')
+depends=('libgee' 'webkitgtk' 'libnotify' 'libxmlbird' 'ttf-roboto')
+makedepends=('vala' 'gettext' 'python')
source=(
- "http://birdfont.org/releases/${pkgname}-${pkgver}.tar.xz"
- "http://birdfont.org/releases/${pkgname}-${pkgver}.tar.xz.sig"
+ "https://birdfont.org/releases/${pkgname}-${pkgver}.tar.xz"
+ "https://birdfont.org/releases/${pkgname}-${pkgver}.tar.xz.sig"
'http://www.unicode.org/Public/UNIDATA/NamesList.txt'
+ 'fix_install.patch'
)
sha512sums=(
- 'f72f0a0c6bfcdd14c67b8980770d4c24a89ebcd56a30fd62cecebe8e06e50e19f04326cba03a030897f45645e1a9bc8ff006ce89efb557630c535e08582c79bf'
- SKIP
+ 'd476497ef6fa8f336820f3c35deb53eed4cdd3db58522c707d689195dcd81962db45527f45ab034b2263b220e160ab5924e22bcf8d936da42c5695b28d4c3053'
+ 'SKIP'
'7f9fb0349f64e8c84d1d2fa3416d561b30744d6f1fcb7d01efe1bc93dca2fe7f58148918270bfeb92551a1e08c7fefba3208af259bf35d8653a1c7772b8da259'
+ 'b8d286db7d56e89045b57f93e712487c9422560c744792326799f3c58fcca2b33bb1cf4c2fe95c693ba1a28b8cfb49f12eea5b59e63cb594e4e8a4f7b5a0e13c'
)
validpgpkeys=('FB3BEFA59A6FF7F0E0682B68BCD31D4CCCEB9DD4') # Johan Mattsson <gmail: johan dot mattsson dot m>
-install=birdfont.install
+install="${pkgname}.install"
prepare() {
cd "${srcdir}/$pkgname-$pkgver"
- sed -i -e 's/gtk+-2.0/gtk+-3.0/g' ./scripts/build.py
+ patch -p1 -i '../fix_install.patch'
}
build() {
cd "${srcdir}/$pkgname-$pkgver"
- python2 ./configure -p /usr
- python2 ./scripts/linux_build.py -p /usr
+ ./configure -p /usr
+ ./scripts/linux_build.py -p /usr
}
package() {
cd "${srcdir}/$pkgname-$pkgver"
- install -d -m 0755 "${pkgdir}/usr/share/unicode"
- python2 ./install.py -d "${pkgdir}" -n /share/man -l /lib
- install -m 0644 "${srcdir}/NamesList.txt" "${pkgdir}/usr/share/unicode"
+ ./install.py -d "${pkgdir}" -n /share/man -l /lib
+ install -Dm644 '../NamesList.txt' \
+ "${pkgdir}/usr/share/unicode/NamesList.txt"
+ install -Dm644 "resources/linux/256x256/${pkgname}.png" \
+ "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
}
diff --git a/birdfont.install b/birdfont.install
index d6d2f5ffa13e..da52f423e134 100644
--- a/birdfont.install
+++ b/birdfont.install
@@ -1,17 +1,17 @@
-post_install() {
+_update() {
gtk-update-icon-cache
update-desktop-database -q
update-mime-database /usr/share/mime
}
+post_install() {
+ _update
+}
+
post_upgrade() {
- gtk-update-icon-cache
- update-desktop-database -q
- update-mime-database /usr/share/mime
+ _update
}
post_remove() {
- gtk-update-icon-cache
- update-desktop-database -q
- update-mime-database /usr/share/mime
-} \ No newline at end of file
+ _update
+}
diff --git a/fix_install.patch b/fix_install.patch
new file mode 100644
index 000000000000..93e12bf46a81
--- /dev/null
+++ b/fix_install.patch
@@ -0,0 +1,33 @@
+diff --git a/install.py b/install.py
+index 4ecbced..6dbc2a1 100755
+--- a/install.py
++++ b/install.py
+@@ -48,14 +48,14 @@ def install (file, dir, mode):
+ f = getDest (file, dir)
+ print ("install: " + f)
+ run ('install -d ' + dest + prefix + dir)
+- run ('install -m ' + `mode` + ' ' + file + ' ' + dest + prefix + dir + '/')
++ run ('install -m ' + str(mode) + ' ' + file + ' ' + dest + prefix + dir + '/')
+ installed.write (f + "\n")
+
+ def install_root (file, dir, mode):
+- f = getDestRoot (file, dir)
+- print ("install: " + f)
+- run ('install -d ' + dest + dir)
+- run ('install -m ' + `mode` + ' ' + file + ' ' + dest + dir + '/')
++ f = getDestRoot (file, dir)
++ print ("install: " + f)
++ run ('install -d ' + dest + dir)
++ run ('install -m ' + str(mode) + ' ' + file + ' ' + dest + dir + '/')
+
+ def link (dir, file, linkname):
+ f = getDest (linkname, dir)
+@@ -172,7 +172,7 @@ elif os.path.isfile ('build/bin/libbirdgems.' + version.LIBBIRDGEMS_SO_VERSION +
+ link (libdir, 'libbirdgems.' + version.LIBBIRDGEMS_SO_VERSION + '.dylib', ' libbirdgems.dylib.' + version.LIBBIRDGEMS_SO_VERSION_MAJOR)
+ link (libdir, 'libbirdgems.' + version.LIBBIRDGEMS_SO_VERSION + '.dylib', ' libbirdgems.dylib')
+ else:
+- print ("Can't find libbirdgems, version: " + version.LIBBIRDGEMS_SO_VERSION)
++ print ("Can't find libbirdgems, version: " + version.LIBBIRDGEMS_SO_VERSION)
+ exit (1)
+
+