summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBjoern Franke2015-06-08 21:00:26 +0200
committerBjoern Franke2015-06-08 21:00:26 +0200
commitb2da7b379d63904ea3b164031200bd1c934bd229 (patch)
treefe817b0c33cff6d6e21acaf2e307d91b5acf4741
downloadaur-b2da7b379d63904ea3b164031200bd1c934bd229.tar.gz
Initial import
-rw-r--r--.SRCINFO35
-rw-r--r--PKGBUILD35
-rw-r--r--birdie.install16
3 files changed, 86 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..30aadc96bc54
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,35 @@
+pkgbase = birdie-git
+ pkgdesc = Twitter client for Linux
+ pkgver = 497+g345d84b
+ pkgrel = 6
+ url = http://birdieapp.github.io
+ install = birdie.install
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = desktop-file-utils
+ makedepends = hicolor-icon-theme
+ makedepends = intltool
+ makedepends = yelp-tools
+ makedepends = gnome-common
+ makedepends = gobject-introspection
+ depends = glib2
+ depends = gtk3
+ depends = hicolor-icon-theme
+ depends = python2-requests
+ depends = python2-requests-oauthlib
+ depends = pygtksourceview2
+ depends = python2-pillow
+ depends = gtksourceview3
+ depends = webkitgtk
+ depends = python2-socksipy-git
+ provides = birdie
+ conflicts = birdie
+ conflicts = birdie-bzr
+ options = !libtool
+ source = birdie::git+https://github.com/birdieapp/birdie.git
+ md5sums = SKIP
+
+pkgname = birdie-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..87222133dc28
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Ivo Nunes <ivoavnunes at gmail dot com>
+_pkgname="birdie"
+pkgname="${_pkgname}-git"
+pkgver=497+g345d84b
+pkgrel=6
+pkgdesc="Twitter client for Linux"
+arch=('i686' 'x86_64')
+url="http://birdieapp.github.io"
+license=('GPL3')
+depends=('glib2' 'gtk3' 'hicolor-icon-theme' 'python2-requests' 'python2-requests-oauthlib' 'pygtksourceview2' 'python2-pillow' 'gtksourceview3' 'webkitgtk' 'python2-socksipy-git')
+makedepends=('git' 'desktop-file-utils' 'hicolor-icon-theme' 'intltool' 'yelp-tools' 'gnome-common' 'gobject-introspection')
+options=('!libtool')
+conflicts=('birdie' 'birdie-bzr')
+provides=('birdie')
+install="${_pkgname}.install"
+source=("${_pkgname}::git+https://github.com/birdieapp/birdie.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${_pkgname}"
+ echo $(git rev-list --count HEAD)+g$(git rev-parse --short HEAD)
+}
+
+build() {
+ cd "${_pkgname}"
+ export PYTHON=`which python2`
+ ./autogen.sh --prefix=/usr
+ make ${MAKEFLAGS}
+}
+
+package() {
+ cd "${_pkgname}"
+ make DESTDIR="${pkgdir}/" install
+ sed -i 's|/usr/bin/env python|/usr/bin/python2|' ${pkgdir}/usr/bin/birdie
+}
diff --git a/birdie.install b/birdie.install
new file mode 100644
index 000000000000..f878ac0bfdf8
--- /dev/null
+++ b/birdie.install
@@ -0,0 +1,16 @@
+post_install() {
+ xdg-icon-resource forceupdate --theme hicolor
+ glib-compile-schemas usr/share/glib-2.0/schemas
+ update-desktop-database -q
+ gtk-update-icon-cache -f /usr/share/icons/hicolor
+}
+
+post_upgrade()
+{
+ post_install "$1"
+}
+
+post_remove()
+{
+ post_install "$1"
+}