summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrederic Bezies2015-10-31 22:41:06 +0100
committerFrederic Bezies2015-10-31 22:41:06 +0100
commite4031958c5632860b440c560b3514198232198f8 (patch)
treecb88f3b5ab10dfe35cc1dc01e355dc93d2dccaad
parentb2da7b379d63904ea3b164031200bd1c934bd229 (diff)
downloadaur-e4031958c5632860b440c560b3514198232198f8.tar.gz
cleaned PKGBUILD
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD13
2 files changed, 10 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 30aadc96bc54..6a94e38ce72a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = birdie-git
pkgdesc = Twitter client for Linux
- pkgver = 497+g345d84b
- pkgrel = 6
+ pkgver = 1.1+git.21.gf235c55
+ pkgrel = 1
url = http://birdieapp.github.io
install = birdie.install
arch = i686
@@ -23,7 +23,7 @@ pkgbase = birdie-git
depends = python2-pillow
depends = gtksourceview3
depends = webkitgtk
- depends = python2-socksipy-git
+ depends = python2-socksipy-branch
provides = birdie
conflicts = birdie
conflicts = birdie-bzr
diff --git a/PKGBUILD b/PKGBUILD
index 87222133dc28..4f271197b187 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,14 @@
-# Maintainer: Ivo Nunes <ivoavnunes at gmail dot com>
+# Maintainer: Frederic Bezies <fredbezies at gmail dot com>
+# Contributor : Ivo Nunes <ivoavnunes at gmail dot com>
_pkgname="birdie"
pkgname="${_pkgname}-git"
-pkgver=497+g345d84b
-pkgrel=6
+pkgver=1.1+git.21.gf235c55
+pkgrel=1
pkgdesc="Twitter client for Linux"
arch=('i686' 'x86_64')
url="http://birdieapp.github.io"
license=('GPL3')
-depends=('glib2' 'gtk3' 'hicolor-icon-theme' 'python2-requests' 'python2-requests-oauthlib' 'pygtksourceview2' 'python2-pillow' 'gtksourceview3' 'webkitgtk' 'python2-socksipy-git')
+depends=('glib2' 'gtk3' 'hicolor-icon-theme' 'python2-requests' 'python2-requests-oauthlib' 'pygtksourceview2' 'python2-pillow' 'gtksourceview3' 'webkitgtk' 'python2-socksipy-branch')
makedepends=('git' 'desktop-file-utils' 'hicolor-icon-theme' 'intltool' 'yelp-tools' 'gnome-common' 'gobject-introspection')
options=('!libtool')
conflicts=('birdie' 'birdie-bzr')
@@ -18,14 +19,14 @@ md5sums=('SKIP')
pkgver() {
cd "${_pkgname}"
- echo $(git rev-list --count HEAD)+g$(git rev-parse --short HEAD)
+ echo $(git describe --tags | sed s'/v\.//;s/-/./g')
}
build() {
cd "${_pkgname}"
export PYTHON=`which python2`
./autogen.sh --prefix=/usr
- make ${MAKEFLAGS}
+ make
}
package() {