summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathon Fernyhough2018-09-23 12:07:10 +0100
committerJonathon Fernyhough2018-09-23 12:07:10 +0100
commit786af1942cde41c2aa9a3ecef8539cc7e31d8255 (patch)
treeadef276a60a8ec2c954c7a67e175975d2238de20
downloadaur-786af1942cde41c2aa9a3ecef8539cc7e31d8255.tar.gz
Initial commit; 0.2 release.
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD30
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f1e5da3e2e8c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = birdtray
+ pkgdesc = Run Thunderbird with a system tray icon.
+ pkgver = 0.2
+ pkgrel = 1
+ url = https://github.com/gyunaev/birdtray
+ arch = i686
+ arch = x86_64
+ arch = armv7h
+ arch = armv6h
+ arch = aarch64
+ license = GPL
+ depends = qt5-base
+ depends = sqlite3
+ source = birdtray-0.2.tar.gz::https://github.com/gyunaev/birdtray/archive/0.2.tar.gz
+ sha1sums = 8d49f7699eeb58faaede2e351e10a0d07b894a80
+
+pkgname = birdtray
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4c9ae9df5367
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Jonathon Fernyhough <jonathon_at_manjaro dot+org>
+
+pkgname=birdtray
+pkgver=0.2
+pkgrel=1
+pkgdesc="Run Thunderbird with a system tray icon."
+arch=('i686' 'x86_64' 'armv7h' 'armv6h' 'aarch64')
+url="https://github.com/gyunaev/birdtray"
+license=('GPL')
+depends=(qt5-base sqlite3)
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/gyunaev/$pkgname/archive/${pkgver}.tar.gz")
+sha1sums=('8d49f7699eeb58faaede2e351e10a0d07b894a80')
+
+build() {
+ mkdir build && cd build
+ qmake-qt5 ../$pkgname-$pkgver/src
+ make
+}
+
+package() {
+ cd build
+
+ install -d "$pkgdir"/usr/bin
+ install -d "$pkgdir"/usr/lib/birdtray
+ install -d "$pkgdir"/usr/include/birdtray
+
+ install birdtray "$pkgdir"/usr/bin/birdtray
+ install -m644 *.o "$pkgdir"/usr/lib/birdtray/
+ install -m644 *.h "$pkgdir"/usr/include/birdtray/
+}