summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathon Fernyhough2018-10-12 16:26:40 +0100
committerJonathon Fernyhough2018-10-12 16:26:40 +0100
commit3367e45e736e83829cda39090a38a65853d044dd (patch)
tree42f161208420f9a5cdcacd6bbaf7baf5a557cf43
parent774309556a5e11db8fe8e03ee2bdec768cd3c6dc (diff)
downloadaur-3367e45e736e83829cda39090a38a65853d044dd.tar.gz
Add pkgver() function, which is kinda crucial...
-rw-r--r--PKGBUILD4
1 files changed, 4 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cecb4cd0212b..a6bcbcd5e709 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,6 +14,10 @@ provides=(${pkgname/-git/})
source=("git+https://github.com/gyunaev/${pkgname/-git/}.git")
sha1sums=(SKIP)
+pkgver() {
+ git -C ${pkgname/-git/} describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
build() {
mkdir -p build && cd build
qmake-qt5 ../${pkgname/-git/}/src