summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathon Fernyhough2019-12-04 20:22:01 +0000
committerJonathon Fernyhough2019-12-04 20:22:01 +0000
commit3f0b27c4bfa301fede6c4d0438d65bf4601db3f8 (patch)
tree4f5b062b0d053c49cad50b289a1657d144ee728d
parente438fbcdcc28e0b5e8cb01e92244bad3e142db34 (diff)
downloadaur-3f0b27c4bfa301fede6c4d0438d65bf4601db3f8.tar.gz
Switch to cmake. Thanks to Kr1ss!
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD32
2 files changed, 19 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fc184983b03d..bb73be115e99 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,17 @@
pkgbase = birdtray-git
pkgdesc = Run Thunderbird with a system tray icon.
pkgver = latest
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/gyunaev/birdtray
arch = i686
arch = x86_64
arch = armv7h
arch = armv6h
arch = aarch64
- license = GPL
+ license = GPL-3.0
+ makedepends = cmake
makedepends = git
+ makedepends = qt5-tools
depends = qt5-base
depends = sqlite3
provides = birdtray
diff --git a/PKGBUILD b/PKGBUILD
index ce5bce712bb6..6088c7719a97 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,37 +1,35 @@
# Maintainer: Jonathon Fernyhough <jonathon_at_manjaro dot+org>
+# Contributor: Kr1ss <kr1ss.x#yandex#com>
-pkgname=birdtray-git
+_pkgbase=birdtray
+pkgname=$_pkgbase-git
pkgver=latest
-pkgrel=2
+pkgrel=3
pkgdesc="Run Thunderbird with a system tray icon."
arch=('i686' 'x86_64' 'armv7h' 'armv6h' 'aarch64')
url="https://github.com/gyunaev/birdtray"
-license=('GPL')
+license=('GPL-3.0')
depends=(qt5-base sqlite3)
-makedepends=(git)
-conflicts=(${pkgname/-git/})
-provides=(${pkgname/-git/})
-source=("git+https://github.com/gyunaev/${pkgname/-git/}.git")
+makedepends=(cmake git qt5-tools)
+conflicts=($_pkgbase)
+provides=($_pkgbase)
+source=("git+$url.git")
sha1sums=(SKIP)
pkgver() {
- git -C ${pkgname/-git/} describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^RELEASE_//g'
+ git -C $_pkgbase describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^RELEASE_//g'
}
build() {
mkdir -p build && cd build
- qmake-qt5 ../${pkgname/-git/}/src
+ cmake ../$_pkgbase \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release
make
}
package() {
cd build
-
- install -d "$pkgdir"/usr/bin
- install -d "$pkgdir"/usr/lib/birdtray
- install -d "$pkgdir"/usr/include/birdtray
-
- install birdtray "$pkgdir"/usr/bin/birdtray
- install -m644 *.o "$pkgdir"/usr/lib/birdtray/
- install -m644 *.h "$pkgdir"/usr/include/birdtray/
+ make DESTDIR="$pkgdir" install
+ install -Dm644 ../$_pkgbase/README.md -t"$pkgdir/usr/share/doc/$_pkgbase/"
}