summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathon Fernyhough2018-09-23 12:06:17 +0100
committerJonathon Fernyhough2018-09-23 12:06:17 +0100
commit774309556a5e11db8fe8e03ee2bdec768cd3c6dc (patch)
treea409e6169d630b46e435ea655015a763d2958e50
downloadaur-774309556a5e11db8fe8e03ee2bdec768cd3c6dc.tar.gz
Initial commit based on 0.2
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD33
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dca96849b7a5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = birdtray-git
+ pkgdesc = Run Thunderbird with a system tray icon.
+ pkgver = latest
+ pkgrel = 1
+ url = https://github.com/gyunaev/birdtray
+ arch = i686
+ arch = x86_64
+ arch = armv7h
+ arch = armv6h
+ arch = aarch64
+ license = GPL
+ makedepends = git
+ depends = qt5-base
+ depends = sqlite3
+ provides = birdtray
+ conflicts = birdtray
+ source = git+https://github.com/gyunaev/birdtray.git
+ sha1sums = SKIP
+
+pkgname = birdtray-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cecb4cd0212b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Jonathon Fernyhough <jonathon_at_manjaro dot+org>
+
+pkgname=birdtray-git
+pkgver=latest
+pkgrel=1
+pkgdesc="Run Thunderbird with a system tray icon."
+arch=('i686' 'x86_64' 'armv7h' 'armv6h' 'aarch64')
+url="https://github.com/gyunaev/birdtray"
+license=('GPL')
+depends=(qt5-base sqlite3)
+makedepends=(git)
+conflicts=(${pkgname/-git/})
+provides=(${pkgname/-git/})
+source=("git+https://github.com/gyunaev/${pkgname/-git/}.git")
+sha1sums=(SKIP)
+
+build() {
+ mkdir -p build && cd build
+ qmake-qt5 ../${pkgname/-git/}/src
+ make
+}
+
+package() {
+ cd build
+
+ install -d "$pkgdir"/usr/bin
+ install -d "$pkgdir"/usr/lib/birdtray
+ install -d "$pkgdir"/usr/include/birdtray
+
+ install birdtray "$pkgdir"/usr/bin/birdtray
+ install -m644 *.o "$pkgdir"/usr/lib/birdtray/
+ install -m644 *.h "$pkgdir"/usr/include/birdtray/
+}