summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2018-12-29 18:08:13 +0100
committerFabioLolix2018-12-29 18:08:13 +0100
commit3131e601de28bbac2aca0812719bb31de85e2376 (patch)
tree011db02afdf3a5f7abcbada1dd63709abd507fee
parent257413821718e24ed6b3c26b620ca0c0a214df6c (diff)
downloadaur-3131e601de28bbac2aca0812719bb31de85e2376.tar.gz
Revision
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD29
2 files changed, 25 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c9ca963a662e..c7e533b9f1d4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,17 @@
-# Generated by mksrcinfo v8
-# Mon Mar 21 22:30:35 UTC 2016
pkgbase = birtty-git
pkgdesc = Try not to crash that bird
- pkgver = 1235e3b
+ pkgver = 18.06.r0.gb693f8b
pkgrel = 1
- url = https://github.com/vain/birtty
- arch = i686
+ epoch = 1
+ url = https://www.uninformativ.de/git/birtty/file/README.html
arch = x86_64
- license = custom:PIZZA-WARE LICENSE
- makedepends = gcc
- makedepends = make
- source = git+https://github.com/vain/birtty
+ arch = i686
+ arch = arm
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
+ license = MIT
+ source = git+https://www.uninformativ.de/git/birtty.git
sha512sums = SKIP
pkgname = birtty-git
diff --git a/PKGBUILD b/PKGBUILD
index 7cad95be2604..3a46ee38e86a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,29 @@
-# Maintainer: Janne Heß <jannehess@gmail.com>
+# Maintainer: Fabio 'Lolix' Loli <lolix@disroot.org>
+# Contributor: Janne Heß <jannehess@gmail.com>
pkgname=birtty-git
-pkgver=1235e3b
+pkgver=18.06.r0.gb693f8b
pkgrel=1
+epoch=1
pkgdesc="Try not to crash that bird"
-url="https://github.com/vain/birtty"
-license=("custom:PIZZA-WARE LICENSE")
-makedepends=("gcc" "make")
-source=("git+https://github.com/vain/birtty")
+arch=(x86_64 i686 arm armv6h armv7h aarch64)
+url="https://www.uninformativ.de/git/birtty/file/README.html"
+license=(MIT)
+source=("git+https://www.uninformativ.de/git/birtty.git")
sha512sums=('SKIP')
-arch=("i686" "x86_64")
pkgver() {
- cd birtty
- git describe --always
+ cd "${srcdir}/birtty"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd "${srcdir}/birtty"
- make birtty
+ cd "${srcdir}/birtty"
+ make
}
package() {
- cd "${srcdir}/birtty"
- install -Dm755 birtty "${pkgdir}/usr/bin/birtty"
- install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/birtty/LICENSE"
+ cd "${srcdir}/birtty"
+ install -Dm755 birtty "${pkgdir}/usr/bin/birtty"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/$pkgname/LICENSE"
}