summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabian Preiss2019-05-10 06:34:55 +0200
committerFabian Preiss2019-05-16 22:53:18 +0200
commitf9505149fd8b057b322761d13101ce59679f9f10 (patch)
treeb2be4686f37f457a8818a92c3e4c4cc474be9f0d
parent0a76a868e9e1c11134528919544ac353c2beaa32 (diff)
downloadaur-f9505149fd8b057b322761d13101ce59679f9f10.tar.gz
hotfix added
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD18
-rw-r--r--hotfix.patch26
3 files changed, 44 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dcd3a4f824df..b4e1c1586ad2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = bison2
pkgdesc = The GNU general-purpose parser generator, older version
pkgver = 2.7.1
- pkgrel = 1
+ pkgrel = 2
url = http://www.gnu.org/software/bison/bison.html
arch = x86_64
groups = base-devel
@@ -13,9 +13,11 @@ pkgbase = bison2
conflicts = bison
source = http://ftp.gnu.org/gnu/bison/bison-2.7.1.tar.gz
source = http://ftp.gnu.org/gnu/bison/bison-2.7.1.tar.gz.sig
+ source = hotfix.patch
validpgpkeys = 7DF84374B1EE1F9764BBE25D0DDCAA3278D5264E
- md5sums = f00906151ff9d2cb599cdeae36d902ee
- md5sums = SKIP
+ sha256sums = 08e2296b024bab8ea36f3bb3b91d071165b22afda39a17ffc8ff53ade2883431
+ sha256sums = 588bdf15487db4fe46043717abe84dae644a68c43e040812354e7750738f0fe1
+ sha256sums = 0e953a7a29e18cea5b6f3557cef5072a3af4e708e8a896727d33b78868c36bc8
pkgname = bison2
diff --git a/PKGBUILD b/PKGBUILD
index 0db26e0243e1..943fca8f6504 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,11 @@
# $Id$
-# Maintainer: Marco A Rojas <marco.rojas@zentek.com.mx>
+# Maintainer: Fabian Preiss <fpreiss .ATT. uni-wuppertal_dot_de>
+# Contributor: Marco A Rojas <marco.rojas@zentek.com.mx>
pkgname=bison2
PACKAGE=bison
pkgver=2.7.1
-pkgrel=1
+pkgrel=2
pkgdesc="The GNU general-purpose parser generator, older version"
arch=('x86_64')
license=('GPL3')
@@ -12,11 +13,18 @@ url="http://www.gnu.org/software/bison/bison.html"
depends=('glibc' 'm4' 'sh' 'libiconv')
conflicts=('bison')
groups=('base-devel')
-source=(http://ftp.gnu.org/gnu/bison/${PACKAGE}-${pkgver}.tar.gz{,.sig})
-md5sums=('f00906151ff9d2cb599cdeae36d902ee'
- 'SKIP')
+source=("http://ftp.gnu.org/gnu/bison/${PACKAGE}-${pkgver}.tar.gz"{,.sig}
+ "hotfix.patch"
+)
+sha256sums=('08e2296b024bab8ea36f3bb3b91d071165b22afda39a17ffc8ff53ade2883431'
+ '588bdf15487db4fe46043717abe84dae644a68c43e040812354e7750738f0fe1'
+ '0e953a7a29e18cea5b6f3557cef5072a3af4e708e8a896727d33b78868c36bc8')
validpgpkeys=('7DF84374B1EE1F9764BBE25D0DDCAA3278D5264E')
+prepare() {
+ patch -p0 < hotfix.patch
+}
+
build() {
cd ${srcdir}/${PACKAGE}-${pkgver}
./configure --prefix=/usr/local --datadir=/usr/local/share --mandir=/usr/local/man
diff --git a/hotfix.patch b/hotfix.patch
new file mode 100644
index 000000000000..c4e145c15163
--- /dev/null
+++ b/hotfix.patch
@@ -0,0 +1,26 @@
+--- bison-2.7.1/lib/fseterr.c 2013-04-08 11:18:57.000000000 +0200
++++ bison-2.7.1/lib/fseterr.c 2019-05-10 06:29:55.890136219 +0200
+@@ -29,7 +29,7 @@
+ /* Most systems provide FILE as a struct and the necessary bitmask in
+ <stdio.h>, because they need it for implementing getc() and putc() as
+ fast macros. */
+-#if defined _IO_ftrylockfile || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */
++#if defined _IO_EOF_SEEN || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */
+ fp->_flags |= _IO_ERR_SEEN;
+ #elif defined __sferror || defined __DragonFly__ /* FreeBSD, NetBSD, OpenBSD, DragonFly, Mac OS X, Cygwin */
+ fp_->_flags |= __SERR;
+--- bison-2.7.1/lib/stdio-impl.h 2013-04-08 11:18:57.000000000 +0200
++++ bison-2.7.1/lib/stdio-impl.h 2019-05-10 06:28:35.936803554 +0200
+@@ -18,6 +18,12 @@
+ the same implementation of stdio extension API, except that some fields
+ have different naming conventions, or their access requires some casts. */
+
++/* Glibc 2.28 made _IO_IN_BACKUP private. For now, work around this
++ problem by defining it ourselves. FIXME: Do not rely on glibc
++ internals. */
++#if !defined _IO_IN_BACKUP && defined _IO_EOF_SEEN
++# define _IO_IN_BACKUP 0x100
++#endif
+
+ /* BSD stdio derived implementations. */
+