summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlva Swanson2023-10-16 20:31:07 +0200
committerAlva Swanson2023-10-16 20:31:07 +0200
commit6f2f1fe75c5f3d4707bab5f3d6262440f14040db (patch)
treea5a59cf9a8197107855cb0acf65fefb8d996e82d
parent473eef4d9771a74231a8ec32580f83ca264d5fa4 (diff)
downloadaur-bisq.tar.gz
Update to version 1.9.14
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD6
2 files changed, 8 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 091dbd60274a..273e8b7cd79b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = bisq
pkgdesc = Cross-platform desktop application that allows users to trade national currency (dollars, euros, etc) for bitcoin without relying on centralized exchanges
- pkgver = 1.9.12
+ pkgver = 1.9.14
pkgrel = 1
url = https://bisq.network
arch = any
@@ -11,11 +11,11 @@ pkgbase = bisq
provides = bisq
conflicts = bisq-bin
conflicts = bisq-git
- source = bisq-1.9.12.tar.gz::https://github.com/bisq-network/bisq/archive/v1.9.12.tar.gz
- source = https://github.com/bisq-network/bisq/releases/download/v1.9.12/bisq-1.9.12.tar.gz.asc
+ source = bisq-1.9.14.tar.gz::https://github.com/bisq-network/bisq/archive/v1.9.14.tar.gz
+ source = https://github.com/bisq-network/bisq/releases/download/v1.9.14/bisq-1.9.14.tar.gz.asc
source = bisq.desktop
validpgpkeys = B493319106CC3D1F252E19CBF806F422E222AA02
- sha256sums = c802d86665105c6738b5268b30c13b88027ee0d9e8f2f82150a529150b431164
+ sha256sums = e5c1a95a5a67798cbd38460d6fa7e0c753ff3c804091da0bd5917201df52fff8
sha256sums = SKIP
sha256sums = 687d643fbe84660c3ebfe6270de98214f2e3ea791cb1d07d96d7ed889d61d406
diff --git a/PKGBUILD b/PKGBUILD
index 5c32553e6399..d055d38f8cfc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Co-Maintainer: Felix Golatofski <contact@xdfr.de>
pkgname=bisq
-pkgver=1.9.12
+pkgver=1.9.14
pkgrel=1
pkgdesc="Cross-platform desktop application that allows users to trade national currency (dollars, euros, etc) for bitcoin without relying on centralized exchanges"
arch=('any')
@@ -13,7 +13,7 @@ makedepends=('jdk11-openjdk' 'git')
source=("$pkgname-$pkgver.tar.gz::https://github.com/bisq-network/bisq/archive/v${pkgver}.tar.gz"
"https://github.com/bisq-network/bisq/releases/download/v${pkgver}/bisq-${pkgver}.tar.gz.asc"
"bisq.desktop")
-sha256sums=('c802d86665105c6738b5268b30c13b88027ee0d9e8f2f82150a529150b431164'
+sha256sums=('e5c1a95a5a67798cbd38460d6fa7e0c753ff3c804091da0bd5917201df52fff8'
'SKIP'
'687d643fbe84660c3ebfe6270de98214f2e3ea791cb1d07d96d7ed889d61d406')
validpgpkeys=('B493319106CC3D1F252E19CBF806F422E222AA02') # Alejandro GarcĂ­a
@@ -25,6 +25,8 @@ provides=("bisq")
build() {
cd "${srcdir}/${pkgname}-${pkgver}" || exit
msg2 "Building bisq..."
+ sed -i '/vendor = JvmVendorSpec.AZUL/d' build-logic/commons/src/main/groovy/bisq.java-conventions.gradle
+ sed -i '/implementation = JvmImplementation.VENDOR_SPECIFIC/d' build-logic/commons/src/main/groovy/bisq.java-conventions.gradle
./gradlew clean :desktop:build -Dorg.gradle.java.home=/usr/lib/jvm/java-11-openjdk -x test
}