summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Reimair2021-02-02 11:58:20 +0100
committerFlorian Reimair2021-02-02 11:58:20 +0100
commit85cf28db81de86d3896d8976bca61c57a7e1730f (patch)
treee5aa61592e3ce260f4018ab80d8351f4613f3107
parent7efc26c96bd46f6f2457a1d2e1ee6520e2485b35 (diff)
downloadaur-85cf28db81de86d3896d8976bca61c57a7e1730f.tar.gz
v1.5.5 and switched to signed src tarball
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD19
2 files changed, 15 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 973e201325f6..a77f82a22ecc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,22 @@
pkgbase = bisq
pkgdesc = Cross-platform desktop application that allows users to trade national currency (dollars, euros, etc) for bitcoin without relying on centralized exchanges
- pkgver = 1.5.4
+ pkgver = 1.5.5
pkgrel = 1
url = https://bisq.network
arch = any
license = AGPL3
- makedepends = git
- makedepends = git-lfs
makedepends = jdk11-openjdk
depends = jdk11-openjdk
depends = bash
provides = bisq
conflicts = bisq-bin
conflicts = bisq-git
+ source = bisq-1.5.5.tar.gz::https://github.com/bisq-network/bisq/archive/v1.5.5.tar.gz
+ source = https://github.com/bisq-network/bisq/releases/download/v1.5.5/bisq-1.5.5.tar.gz.asc
source = bisq.desktop
+ validpgpkeys = CB36D7D2EBB2E35D9B75500BCD5DC1C529CDFD3B
+ sha256sums = e3c8639fdccf845a463fc9799ecb9b7e16ae6abe49dc322bf12829a5851e70cf
+ sha256sums = 1eec1ef86fdd8c99f849b71bd072e71bddb2e934f6581eebed582336d600db2c
sha256sums = 687d643fbe84660c3ebfe6270de98214f2e3ea791cb1d07d96d7ed889d61d406
pkgname = bisq
diff --git a/PKGBUILD b/PKGBUILD
index 0e064477d862..dd81f801099e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,27 +2,26 @@
# Co-Maintainer: Felix Golatofski <contact@xdfr.de>
pkgname=bisq
-pkgver=1.5.4
+pkgver=1.5.5
pkgrel=1
pkgdesc="Cross-platform desktop application that allows users to trade national currency (dollars, euros, etc) for bitcoin without relying on centralized exchanges"
arch=('any')
url="https://bisq.network"
license=('AGPL3')
depends=('jdk11-openjdk' 'bash')
-makedepends=('git' 'git-lfs' 'jdk11-openjdk')
-source=("bisq.desktop")
-sha256sums=('687d643fbe84660c3ebfe6270de98214f2e3ea791cb1d07d96d7ed889d61d406')
+makedepends=('jdk11-openjdk')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/bisq-network/bisq/archive/v${pkgver}.tar.gz"
+ "https://github.com/bisq-network/bisq/releases/download/v${pkgver}/bisq-${pkgver}.tar.gz.asc"
+ "bisq.desktop")
+sha256sums=('e3c8639fdccf845a463fc9799ecb9b7e16ae6abe49dc322bf12829a5851e70cf'
+ '1eec1ef86fdd8c99f849b71bd072e71bddb2e934f6581eebed582336d600db2c'
+ '687d643fbe84660c3ebfe6270de98214f2e3ea791cb1d07d96d7ed889d61d406')
+validpgpkeys=('CB36D7D2EBB2E35D9B75500BCD5DC1C529CDFD3B') # Christoph Atteneder
_binname=Bisq
conflicts=("bisq-bin" "bisq-git")
provides=("bisq")
-prepare() {
- git lfs install
- rm -rf "${srcdir}/${pkgname}-${pkgver}"
- git clone --depth=1 --branch=v${pkgver} https://github.com/bisq-network/bisq.git ${pkgname}-${pkgver}
-}
-
build() {
cd "${srcdir}/${pkgname}-${pkgver}" || exit
msg2 "Building bisq..."