summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Parrish2016-05-18 17:04:39 -0400
committerDavid Parrish2016-05-18 17:04:39 -0400
commit9fdeb97add5ae908d7ee07f3143424b06049133f (patch)
treeae29b23c2aa78b133306c240d3c1530bdddf0b4d
parent2751c593277b8f83c5aef5e7d0db3bf87584cd08 (diff)
downloadaur-9fdeb97add5ae908d7ee07f3143424b06049133f.tar.gz
Build bitsquare from source and from specific version
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD44
-rw-r--r--bitsquare.desktop9
-rw-r--r--bitsquare.sh2
4 files changed, 53 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3b19b0d2bdb7..8ca3b073acd6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,23 @@
# Generated by mksrcinfo v8
-# Sun Apr 24 01:25:05 UTC 2016
+# Wed May 18 21:03:36 UTC 2016
pkgbase = bitsquare
pkgdesc = Bitsquare is a cross-platform desktop application that allows users to trade national currency (dollars, euros, etc) for bitcoin without relying on centralized exchanges
- pkgver = 0.4.3
+ pkgver = 0.4.6
pkgrel = 1
url = https://bitsquare.io/
arch = x86_64
license = AGPL3
- source_x86_64 = https://github.com/bitsquare/bitsquare/releases/download/v0.4.3/Bitsquare-64bit-0.4.3.deb
- md5sums_x86_64 = a327dd5a9f8d7a3984c5116329b78be3
+ makedepends = maven
+ depends = bash
+ depends = java-openjfx
+ source = bitsquare::git+https://github.com/bitsquare/bitsquare.git#tag=v0.4.6
+ source = git+https://github.com/bitsquare/bitcoinj.git#branch=FixBloomFilters
+ source = bitsquare.sh
+ source = bitsquare.desktop
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = b2e5e85f842f0bc9910087d62f78f5fd9fc1b6232849b59e785acbec5d8955cf
+ sha256sums = 15592a05a2a4d6cb65c757e9eec5e3818bf38e7397a3b98e7651a8a3b51f9ba9
pkgname = bitsquare
diff --git a/PKGBUILD b/PKGBUILD
index 9c181b7f0a58..082e5ee639da 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,42 @@
-# Maintainer: David Parrish <daveparrish@gmail.com>
+# Maintainer: David Parrish <daveparrish@tutanota.com>
pkgname=bitsquare
-pkgver=0.4.3
+pkgver=0.4.6
pkgrel=1
pkgdesc="Bitsquare is a cross-platform desktop application that allows users to trade national currency (dollars, euros, etc) for bitcoin without relying on centralized exchanges"
arch=('x86_64')
url="https://bitsquare.io/"
license=('AGPL3')
-source_x86_64=("https://github.com/bitsquare/bitsquare/releases/download/v${pkgver}/Bitsquare-64bit-${pkgver}.deb")
-md5sums_x86_64=('a327dd5a9f8d7a3984c5116329b78be3')
-_binname=Bitsquare
+depends=('bash' 'java-openjfx')
+makedepends=('maven')
+source=("${pkgname}::git+https://github.com/bitsquare/bitsquare.git#tag=v${pkgver}"
+ "git+https://github.com/bitsquare/bitcoinj.git#branch=FixBloomFilters"
+ "bitsquare.sh"
+ "bitsquare.desktop")
+sha256sums=('SKIP'
+ 'SKIP'
+ 'b2e5e85f842f0bc9910087d62f78f5fd9fc1b6232849b59e785acbec5d8955cf'
+ '15592a05a2a4d6cb65c757e9eec5e3818bf38e7397a3b98e7651a8a3b51f9ba9')
-prepare() {
- tar -Jxvf data.tar.xz
+build() {
+ # Use a temporary local maven repository.
+ local mvn_repo="$srcdir/mvn-repository"
+
+ cd "${srcdir}/bitcoinj"
+ echo "Building bitcoinj ..."
+ mvn clean install -Dmaven.repo.local="$mvn_repo" -DskipTests -Dmaven.javadoc.skip=true
+
+ cd "${srcdir}/${pkgname}"
+ echo "Building bitsquare ..."
+ mvn clean package -Dmaven.repo.local="$mvn_repo" -DskipTests
}
package() {
- install -d "$pkgdir"/{opt/,usr/bin/,usr/share/applications,/usr/share/pixmaps,/usr/share/licenses/$pkgname}
-
- # Install all .deb files into /opt.
- cp -r "$srcdir/opt" "$pkgdir"
+ # Install executable.
+ install -D -m755 "bitsquare.sh" "${pkgdir}/usr/bin/bitsquare"
+ install -D -m644 "${srcdir}/${pkgname}/gui/target/shaded.jar" "${pkgdir}/usr/share/java/bitsquare/shaded.jar"
- # Symlink some files to complete install.
- ln -s "/opt/$_binname/$_binname" "$pkgdir/usr/bin/$pkgname"
- ln -s "/opt/$_binname/${_binname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
- ln -s "/opt/$_binname/${_binname}.png" "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
+ # Install desktop launcher.
+ install -Dm644 bitsquare.desktop "${pkgdir}/usr/share/applications/bitsquare.desktop"
+ install -Dm644 "${srcdir}/${pkgname}/package/linux/icon.png" "${pkgdir}/usr/share/pixmaps/bitsquare.png"
}
diff --git a/bitsquare.desktop b/bitsquare.desktop
new file mode 100644
index 000000000000..d1bfc57c419f
--- /dev/null
+++ b/bitsquare.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=Bitsquare
+GenericName=P2P Bitcoin Exchange
+Comment=Bitsquare is a cross-platform desktop application that allows users to trade national currency (dollars, euros, etc) for bitcoin without relying on centralized exchanges
+Exec=/usr/bin/bitsquare
+Icon=/usr/share/pixmaps/bitsquare.png
+Terminal=false
+Type=Application
+Categories=Utility;Finance;
diff --git a/bitsquare.sh b/bitsquare.sh
new file mode 100644
index 000000000000..268195b8712d
--- /dev/null
+++ b/bitsquare.sh
@@ -0,0 +1,2 @@
+#!/bin/sh
+exec "$JAVA_HOME/bin/java" -jar /usr/share/java/bitsquare/shaded.jar "$@"