summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Parrish2019-01-17 20:20:05 -0500
committerDavid Parrish2019-01-17 20:20:05 -0500
commit57ed38bf4a67c3a7a229a68639d24d83512e048b (patch)
tree882f6caeb551cb48ef63c915778446065643a01f
parent6145281c7cfb6ba9862938737b5833435c11339c (diff)
downloadaur-57ed38bf4a67c3a7a229a68639d24d83512e048b.tar.gz
Update dependencies and apply namcap suggestions
- Replace java-openjfx dependency for java-runtime - Add libnet dependency - Use bisq URL instead of old bitsquare URL - Remove license directory which was empty
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD8
2 files changed, 9 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 28fde0020559..21c5444d346d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,19 @@
pkgbase = bisq-bin
pkgdesc = Cross-platform desktop application that allows users to trade national currency (dollars, euros, etc) for bitcoin without relying on centralized exchanges
pkgver = 0.9.3
- pkgrel = 1
+ pkgrel = 2
url = https://bisq.network
arch = x86_64
license = AGPL3
- depends = java-openjfx
+ depends = java-runtime
depends = gtk2
+ depends = libnet
provides = bisq-bin
conflicts = bisq
conflicts = bisq-git
validpgpkeys = CB36D7D2EBB2E35D9B75500BCD5DC1C529CDFD3B
- source_x86_64 = https://github.com/bitsquare/bitsquare/releases/download/v0.9.3/Bisq-64bit-0.9.3.deb
- source_x86_64 = https://github.com/bitsquare/bitsquare/releases/download/v0.9.3/Bisq-64bit-0.9.3.deb.asc
+ source_x86_64 = https://github.com/bisq-network/bisq/releases/download/v0.9.3/Bisq-64bit-0.9.3.deb
+ source_x86_64 = https://github.com/bisq-network/bisq/releases/download/v0.9.3/Bisq-64bit-0.9.3.deb.asc
sha512sums_x86_64 = 70c668906bb3e39c6bdc6df2a8e06927217f3355f9e90ad9ea02ee9b5ab840410d8f5c6743a30cfeb0d32e03080632f1a6c017a77aebe3aa1eb10f74f6c39a42
sha512sums_x86_64 = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 00a4a36cf88a..aae501c42780 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,14 @@
pkgname=bisq-bin
pkgver=0.9.3
-pkgrel=1
+pkgrel=2
pkgdesc="Cross-platform desktop application that allows users to trade national currency (dollars, euros, etc) for bitcoin without relying on centralized exchanges"
arch=('x86_64')
url="https://bisq.network"
license=('AGPL3')
-depends=('java-openjfx' 'gtk2')
+depends=('java-runtime' 'gtk2' 'libnet')
validpgpkeys=('CB36D7D2EBB2E35D9B75500BCD5DC1C529CDFD3B')
-source_x86_64=("https://github.com/bitsquare/bitsquare/releases/download/v${pkgver}/Bisq-64bit-${pkgver}.deb"{,.asc})
+source_x86_64=("https://github.com/bisq-network/bisq/releases/download/v${pkgver}/Bisq-64bit-${pkgver}.deb"{,.asc})
sha512sums_x86_64=('70c668906bb3e39c6bdc6df2a8e06927217f3355f9e90ad9ea02ee9b5ab840410d8f5c6743a30cfeb0d32e03080632f1a6c017a77aebe3aa1eb10f74f6c39a42'
'SKIP')
_binname=Bisq
@@ -21,7 +21,7 @@ prepare() {
}
package() {
- install -d "$pkgdir"/{opt/,usr/bin/,usr/share/applications,/usr/share/pixmaps,/usr/share/licenses/bisq}
+ install -d "$pkgdir"/{opt/,usr/bin/,usr/share/applications,/usr/share/pixmaps}
# Install all .deb files into /opt.
cp -r "$srcdir/opt" "$pkgdir"