summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarl Smedstad2023-09-11 23:39:15 +0200
committerCarl Smedstad2023-09-12 00:51:15 +0200
commit23ce5d5ec794479419763fb9925da3bf1d5ed7b4 (patch)
treec00a8e6878e3abc50c2fc8a7944332ed88d94e20
downloadaur-23ce5d5ec794479419763fb9925da3bf1d5ed7b4.tar.gz
Publish version 0.11.0-1
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD54
3 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..60489432b276
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = bita
+ pkgdesc = Differential file synchronization over http
+ pkgver = 0.11.0
+ pkgrel = 1
+ url = https://github.com/oll3/bita
+ arch = x86_64
+ license = MIT
+ makedepends = cargo
+ makedepends = protobuf
+ depends = gcc-libs
+ depends = glibc
+ depends = openssl
+ depends = xz
+ options = !lto
+ source = bita-0.11.0.tar.gz::https://github.com/oll3/bita/archive/refs/tags/v0.11.0.tar.gz
+ sha256sums = 579291e0eab5afe46ef360f989996a2e8a96746e09f4958497b71c9be1b4fd33
+
+pkgname = bita
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f71c635dafda
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..32800195bc5e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,54 @@
+# Maintainer: Carl Smedstad <carl.smedstad at protonmail dot com>
+
+pkgname=bita
+pkgver=0.11.0
+pkgrel=1
+pkgdesc="Differential file synchronization over http"
+arch=(x86_64)
+url="https://github.com/oll3/bita"
+license=(MIT)
+depends=(
+ gcc-libs
+ glibc
+ openssl
+ xz
+)
+makedepends=(
+ cargo
+ protobuf
+)
+options=(!lto)
+
+source=("$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/v$pkgver.tar.gz")
+sha256sums=('579291e0eab5afe46ef360f989996a2e8a96746e09f4958497b71c9be1b4fd33')
+
+_archive="$pkgname-$pkgver"
+
+prepare() {
+ cd "$_archive"
+
+ export RUSTUP_TOOLCHAIN=stable
+ cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
+}
+
+build() {
+ cd "$_archive"
+
+ export RUSTUP_TOOLCHAIN=stable
+ export CARGO_TARGET_DIR=target
+ cargo build --frozen --release --all-features
+}
+
+check() {
+ cd "$_archive"
+
+ export RUSTUP_TOOLCHAIN=stable
+ cargo test --frozen --all-features
+}
+
+package() {
+ cd "$_archive"
+
+ install -Dm755 -t "$pkgdir/usr/bin/" "target/release/$pkgname"
+ install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname/" LICENSE
+}