summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWu Zhenyu2023-09-11 04:25:45 +0800
committerWu Zhenyu2023-09-11 04:25:45 +0800
commitf8b8f62da8fbc32dee70670c8a493942d4558a64 (patch)
tree556927cace49adadf55b3013a924aec234bbc6ec
parentebb19c70d62a88171b6f39d52a3a6684d8035ba1 (diff)
downloadaur-f8b8f62da8fbc32dee70670c8a493942d4558a64.tar.gz
:bookmark: Dump version
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d1c4292b1442..08a7cb7bae4e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -9,8 +9,8 @@ pkgbase = bitbake-language-server
depends = python-pygls
depends = python-platformdirs
depends = python-tree-sitter
- optdepends = python-bitbake
- source = https://files.pythonhosted.org/packages/py3/b/bitbake_language_server/bitbake_language_server-0.0.4-py3-none-any.whl
- sha256sums = dabdb67b7e7f2959e68da2fb0c07f229a7b73acb3c6ecbaa66529c51d7a1c69f
+ optdepends = bitbake
+ source = https://files.pythonhosted.org/packages/cp310/b/bitbake_language_server/bitbake_language_server-0.0.4-cp310-cp310-manylinux_2_17_x86_64.manylinux_2_5_x86_64.manylinux1_x86_64.manylinux2014_x86_64.whl
+ sha256sums = SKIP
pkgname = bitbake-language-server
diff --git a/PKGBUILD b/PKGBUILD
index a927d321847d..e75754e4caab 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,12 +8,12 @@ pkgdesc="bitbake language server"
arch=(any)
url=https://github.com/Freed-Wu/bitbake-language-server
depends=(python-pygls python-platformdirs python-tree-sitter)
-optdepends=(python-bitbake)
+optdepends=(bitbake)
makedepends=(python-installer)
license=(GPL3)
-_py=py3
-source=("https://files.pythonhosted.org/packages/$_py/${pkgname::1}/${pkgname//-/_}/${pkgname//-/_}-$pkgver-$_py-none-any.whl")
-sha256sums=('dabdb67b7e7f2959e68da2fb0c07f229a7b73acb3c6ecbaa66529c51d7a1c69f')
+_py=cp310
+source=("https://files.pythonhosted.org/packages/$_py/${pkgname::1}/${pkgname//-/_}/${pkgname//-/_}-$pkgver-$_py-$_py-manylinux_2_17_x86_64.manylinux_2_5_x86_64.manylinux1_x86_64.manylinux2014_x86_64.whl")
+sha256sums=('SKIP')
package() {
python -m installer -d "$pkgdir" ./*.whl