summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoraksr2015-06-28 09:12:20 +0200
committeraksr2015-06-28 09:12:20 +0200
commitaf183023232c4c406c6c3267a92709db499ee438 (patch)
treec1757a2f1cde1d50f44c0550201db5525cf88b2b
downloadaur-af183023232c4c406c6c3267a92709db499ee438.tar.gz
Start.
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD43
2 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..37dd97c88bf2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = bitchx-git
+ pkgdesc = An IRC (Internet Relay Chat) client.
+ pkgver = 0+24_e60bfb7
+ pkgrel = 1
+ url = https://github.com/BitchX/BitchX
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ makedepends = cpio
+ depends = openssl
+ conflicts = ircii-pana
+ conflicts = bitchx-svn
+ conflicts = bitchx11-git
+ conflicts = bitchx12-git
+ conflicts = bitchx13-git
+ source = bitchx-git::git+https://github.com/BitchX/BitchX.git
+ md5sums = SKIP
+
+pkgname = bitchx-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..046ee545ea55
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: aksr <aksr at t-com dot me>
+pkgname=bitchx-git
+pkgver=0+24_e60bfb7
+pkgrel=1
+pkgdesc="An IRC (Internet Relay Chat) client."
+arch=('i686' 'x86_64')
+#url="http://www.bitchx.ca/"
+url="https://github.com/BitchX/BitchX"
+license=('GPL2')
+groups=()
+depends=('openssl')
+makedepends=('git' 'cpio')
+provides=()
+conflicts=('ircii-pana' 'bitchx-svn' 'bitchx11-git' 'bitchx12-git' 'bitchx13-git')
+replaces=()
+backup=()
+options=()
+install=
+source=("$pkgname::git+https://github.com/BitchX/BitchX.git")
+noextract=()
+md5sums=('SKIP')
+
+pkgver () {
+ cd "$srcdir/$pkgname"
+ echo "0+$(git rev-list --count HEAD)_$(git describe --always )"
+}
+
+build() {
+ cd $srcdir/$pkgname
+ ./configure --exec_prefix=/usr \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --enable-ipv6 \
+ --with-plugins \
+ --with-ssl
+ make
+}
+
+package() {
+ cd $srcdir/$pkgname
+ make DESTDIR="$pkgdir/" install
+}
+