summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJosh Ellithorpe2018-04-04 22:28:05 -0700
committerJosh Ellithorpe2018-04-04 22:28:05 -0700
commit6f2cf1fb0d82996a5aa5b77d7fb485e84575f839 (patch)
tree8b30c182b2b6b72c8cc4734106c1a17acae4d099
parentc0e8c7a6a770ca2ee4d39522276cc4eacd6bad37 (diff)
downloadaur-6f2cf1fb0d82996a5aa5b77d7fb485e84575f839.tar.gz
Bump to 0.17.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD13
-rw-r--r--patch.diff70
3 files changed, 7 insertions, 84 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ceb07ce9517a..484de998efad 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = bitcoin-abc
pkgdesc = Bitcoin ABC with bitcoind, bitcoin-tx, and bitcoin-cli
- pkgver = 0.16.2
+ pkgver = 0.17.0
pkgrel = 2
url = https://bitcoinabc.org
install = bitcoin.install
@@ -21,20 +21,18 @@ pkgbase = bitcoin-abc
conflicts = bitcoin-tx
backup = etc/bitcoin/bitcoin.conf
backup = etc/logrotate.d/bitcoin
- source = https://github.com/Bitcoin-ABC/bitcoin-abc/archive/v0.16.2.tar.gz
+ source = https://github.com/Bitcoin-ABC/bitcoin-abc/archive/v0.17.0.tar.gz
source = bitcoin.conf
source = bitcoin.logrotate
source = bitcoin.service
source = bitcoin-reindex.service
source = bitcoin.install
- source = patch.diff
- sha256sums = d63616b5399f7bcff88bf874a1880ba8d55b44b8ff9b07d0d56f5b5dfa64d0d9
+ sha256sums = 3c346df244cd6cc0236a3f8564e9a8c52ee7927540f201863748cd2288550613
sha256sums = b1908344281498d39bfa40c3b9725f9c95bf22602cd46e6120a1f17bad9dae35
sha256sums = 8f05207b586916d489b7d25a68eaacf6e678d7cbb5bfbac551903506b32f904f
sha256sums = 9643eed2c20d78a9c7347df64099765773615f79d3b8a95693d871c933516880
sha256sums = 35ff9331d7df8b90adfc7d82752cca4f8b7ff23a29e5d10b07e4e3fc78050679
sha256sums = c8a667f7138a504f0a3018b48eb687814cfc741f4d38d8699b0b3b5234b25fea
- sha256sums = 6b146dc6158d753440c7bf4ea05fa8c38ae7411d4e0cb74a444fcc797b904b5c
pkgname = bitcoin-abc
diff --git a/PKGBUILD b/PKGBUILD
index 8bb5155e0a67..1a9692d44011 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Josh Ellithorpe <quest@mac.com>
pkgname=bitcoin-abc
-pkgver=0.16.2
+pkgver=0.17.0
pkgrel=2
pkgdesc="Bitcoin ABC with bitcoind, bitcoin-tx, and bitcoin-cli"
arch=('i686' 'x86_64')
@@ -15,15 +15,13 @@ source=(https://github.com/Bitcoin-ABC/bitcoin-abc/archive/v$pkgver.tar.gz
bitcoin.logrotate
bitcoin.service
bitcoin-reindex.service
- bitcoin.install
- patch.diff)
-sha256sums=('d63616b5399f7bcff88bf874a1880ba8d55b44b8ff9b07d0d56f5b5dfa64d0d9'
+ bitcoin.install)
+sha256sums=('3c346df244cd6cc0236a3f8564e9a8c52ee7927540f201863748cd2288550613'
'b1908344281498d39bfa40c3b9725f9c95bf22602cd46e6120a1f17bad9dae35'
'8f05207b586916d489b7d25a68eaacf6e678d7cbb5bfbac551903506b32f904f'
'9643eed2c20d78a9c7347df64099765773615f79d3b8a95693d871c933516880'
'35ff9331d7df8b90adfc7d82752cca4f8b7ff23a29e5d10b07e4e3fc78050679'
- 'c8a667f7138a504f0a3018b48eb687814cfc741f4d38d8699b0b3b5234b25fea'
- '6b146dc6158d753440c7bf4ea05fa8c38ae7411d4e0cb74a444fcc797b904b5c')
+ 'c8a667f7138a504f0a3018b48eb687814cfc741f4d38d8699b0b3b5234b25fea')
backup=('etc/bitcoin/bitcoin.conf'
'etc/logrotate.d/bitcoin')
provides=('bitcoin-cli' 'bitcoin-daemon' 'bitcoin-tx')
@@ -33,9 +31,6 @@ install=bitcoin.install
build() {
cd "$srcdir/${pkgname}-$pkgver"
- msg2 'Patching...'
- patch -p1 < ../patch.diff
-
msg2 'Building...'
./autogen.sh
./configure \
diff --git a/patch.diff b/patch.diff
deleted file mode 100644
index d45b98593b7f..000000000000
--- a/patch.diff
+++ /dev/null
@@ -1,70 +0,0 @@
-diff --git a/src/miner.h b/src/miner.h
-index bf79bdfd6..cc9c62c1f 100644
---- a/src/miner.h
-+++ b/src/miner.h
-@@ -71,7 +71,7 @@ struct modifiedentry_iter {
- // TODO: refactor to avoid duplication of this logic.
- struct CompareModifiedEntry {
- bool operator()(const CTxMemPoolModifiedEntry &a,
-- const CTxMemPoolModifiedEntry &b) {
-+ const CTxMemPoolModifiedEntry &b) const {
- double f1 = double(b.nSizeWithAncestors *
- a.nModFeesWithAncestors.GetSatoshis());
- double f2 = double(a.nSizeWithAncestors *
-@@ -87,7 +87,7 @@ struct CompareModifiedEntry {
- // This is sufficient to sort an ancestor package in an order that is valid
- // to appear in a block.
- struct CompareTxIterByAncestorCount {
-- bool operator()(const CTxMemPool::txiter &a, const CTxMemPool::txiter &b) {
-+ bool operator()(const CTxMemPool::txiter &a, const CTxMemPool::txiter &b) const {
- if (a->GetCountWithAncestors() != b->GetCountWithAncestors())
- return a->GetCountWithAncestors() < b->GetCountWithAncestors();
- return CTxMemPool::CompareIteratorByHash()(a, b);
-diff --git a/src/txmempool.h b/src/txmempool.h
-index c51ca831b..72c066335 100644
---- a/src/txmempool.h
-+++ b/src/txmempool.h
-@@ -245,7 +245,7 @@ struct mempoolentry_txid {
- */
- class CompareTxMemPoolEntryByDescendantScore {
- public:
-- bool operator()(const CTxMemPoolEntry &a, const CTxMemPoolEntry &b) {
-+ bool operator()(const CTxMemPoolEntry &a, const CTxMemPoolEntry &b) const {
- bool fUseADescendants = UseDescendantScore(a);
- bool fUseBDescendants = UseDescendantScore(b);
-
-@@ -272,7 +272,7 @@ class CompareTxMemPoolEntryByDescendantScore {
- }
-
- // Calculate which score to use for an entry (avoiding division).
-- bool UseDescendantScore(const CTxMemPoolEntry &a) {
-+ bool UseDescendantScore(const CTxMemPoolEntry &a) const {
- double f1 = double(a.GetSizeWithDescendants() *
- a.GetModifiedFee().GetSatoshis());
- double f2 =
-@@ -287,7 +287,7 @@ class CompareTxMemPoolEntryByDescendantScore {
- */
- class CompareTxMemPoolEntryByScore {
- public:
-- bool operator()(const CTxMemPoolEntry &a, const CTxMemPoolEntry &b) {
-+ bool operator()(const CTxMemPoolEntry &a, const CTxMemPoolEntry &b) const {
- double f1 = double(b.GetTxSize() * a.GetModifiedFee().GetSatoshis());
- double f2 = double(a.GetTxSize() * b.GetModifiedFee().GetSatoshis());
- if (f1 == f2) {
-@@ -299,14 +299,14 @@ class CompareTxMemPoolEntryByScore {
-
- class CompareTxMemPoolEntryByEntryTime {
- public:
-- bool operator()(const CTxMemPoolEntry &a, const CTxMemPoolEntry &b) {
-+ bool operator()(const CTxMemPoolEntry &a, const CTxMemPoolEntry &b) const {
- return a.GetTime() < b.GetTime();
- }
- };
-
- class CompareTxMemPoolEntryByAncestorFee {
- public:
-- bool operator()(const CTxMemPoolEntry &a, const CTxMemPoolEntry &b) {
-+ bool operator()(const CTxMemPoolEntry &a, const CTxMemPoolEntry &b) const {
- double aFees = double(a.GetModFeesWithAncestors().GetSatoshis());
- double aSize = a.GetSizeWithAncestors();
-