summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJosh Ellithorpe2018-01-06 17:12:15 -0800
committerJosh Ellithorpe2018-01-06 17:12:15 -0800
commitc0e8c7a6a770ca2ee4d39522276cc4eacd6bad37 (patch)
tree4babb843dfca3992c2ae51cf412c5722ae22b74f
parent0b681f2b8698d082a7f19444f3d76a30b428376f (diff)
downloadaur-c0e8c7a6a770ca2ee4d39522276cc4eacd6bad37.tar.gz
Added patch to support latest version of Boost
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD11
-rw-r--r--patch.diff70
3 files changed, 81 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 010cfbbae3c0..ceb07ce9517a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = bitcoin-abc
pkgdesc = Bitcoin ABC with bitcoind, bitcoin-tx, and bitcoin-cli
pkgver = 0.16.2
- pkgrel = 1
+ pkgrel = 2
url = https://bitcoinabc.org
install = bitcoin.install
arch = i686
@@ -27,12 +27,14 @@ pkgbase = bitcoin-abc
source = bitcoin.service
source = bitcoin-reindex.service
source = bitcoin.install
+ source = patch.diff
sha256sums = d63616b5399f7bcff88bf874a1880ba8d55b44b8ff9b07d0d56f5b5dfa64d0d9
sha256sums = b1908344281498d39bfa40c3b9725f9c95bf22602cd46e6120a1f17bad9dae35
sha256sums = 8f05207b586916d489b7d25a68eaacf6e678d7cbb5bfbac551903506b32f904f
sha256sums = 9643eed2c20d78a9c7347df64099765773615f79d3b8a95693d871c933516880
sha256sums = 35ff9331d7df8b90adfc7d82752cca4f8b7ff23a29e5d10b07e4e3fc78050679
sha256sums = c8a667f7138a504f0a3018b48eb687814cfc741f4d38d8699b0b3b5234b25fea
+ sha256sums = 6b146dc6158d753440c7bf4ea05fa8c38ae7411d4e0cb74a444fcc797b904b5c
pkgname = bitcoin-abc
diff --git a/PKGBUILD b/PKGBUILD
index 0391b3479aa2..8bb5155e0a67 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=bitcoin-abc
pkgver=0.16.2
-pkgrel=1
+pkgrel=2
pkgdesc="Bitcoin ABC with bitcoind, bitcoin-tx, and bitcoin-cli"
arch=('i686' 'x86_64')
url="https://bitcoinabc.org"
@@ -15,13 +15,15 @@ source=(https://github.com/Bitcoin-ABC/bitcoin-abc/archive/v$pkgver.tar.gz
bitcoin.logrotate
bitcoin.service
bitcoin-reindex.service
- bitcoin.install)
+ bitcoin.install
+ patch.diff)
sha256sums=('d63616b5399f7bcff88bf874a1880ba8d55b44b8ff9b07d0d56f5b5dfa64d0d9'
'b1908344281498d39bfa40c3b9725f9c95bf22602cd46e6120a1f17bad9dae35'
'8f05207b586916d489b7d25a68eaacf6e678d7cbb5bfbac551903506b32f904f'
'9643eed2c20d78a9c7347df64099765773615f79d3b8a95693d871c933516880'
'35ff9331d7df8b90adfc7d82752cca4f8b7ff23a29e5d10b07e4e3fc78050679'
- 'c8a667f7138a504f0a3018b48eb687814cfc741f4d38d8699b0b3b5234b25fea')
+ 'c8a667f7138a504f0a3018b48eb687814cfc741f4d38d8699b0b3b5234b25fea'
+ '6b146dc6158d753440c7bf4ea05fa8c38ae7411d4e0cb74a444fcc797b904b5c')
backup=('etc/bitcoin/bitcoin.conf'
'etc/logrotate.d/bitcoin')
provides=('bitcoin-cli' 'bitcoin-daemon' 'bitcoin-tx')
@@ -31,6 +33,9 @@ install=bitcoin.install
build() {
cd "$srcdir/${pkgname}-$pkgver"
+ msg2 'Patching...'
+ patch -p1 < ../patch.diff
+
msg2 'Building...'
./autogen.sh
./configure \
diff --git a/patch.diff b/patch.diff
new file mode 100644
index 000000000000..d45b98593b7f
--- /dev/null
+++ b/patch.diff
@@ -0,0 +1,70 @@
+diff --git a/src/miner.h b/src/miner.h
+index bf79bdfd6..cc9c62c1f 100644
+--- a/src/miner.h
++++ b/src/miner.h
+@@ -71,7 +71,7 @@ struct modifiedentry_iter {
+ // TODO: refactor to avoid duplication of this logic.
+ struct CompareModifiedEntry {
+ bool operator()(const CTxMemPoolModifiedEntry &a,
+- const CTxMemPoolModifiedEntry &b) {
++ const CTxMemPoolModifiedEntry &b) const {
+ double f1 = double(b.nSizeWithAncestors *
+ a.nModFeesWithAncestors.GetSatoshis());
+ double f2 = double(a.nSizeWithAncestors *
+@@ -87,7 +87,7 @@ struct CompareModifiedEntry {
+ // This is sufficient to sort an ancestor package in an order that is valid
+ // to appear in a block.
+ struct CompareTxIterByAncestorCount {
+- bool operator()(const CTxMemPool::txiter &a, const CTxMemPool::txiter &b) {
++ bool operator()(const CTxMemPool::txiter &a, const CTxMemPool::txiter &b) const {
+ if (a->GetCountWithAncestors() != b->GetCountWithAncestors())
+ return a->GetCountWithAncestors() < b->GetCountWithAncestors();
+ return CTxMemPool::CompareIteratorByHash()(a, b);
+diff --git a/src/txmempool.h b/src/txmempool.h
+index c51ca831b..72c066335 100644
+--- a/src/txmempool.h
++++ b/src/txmempool.h
+@@ -245,7 +245,7 @@ struct mempoolentry_txid {
+ */
+ class CompareTxMemPoolEntryByDescendantScore {
+ public:
+- bool operator()(const CTxMemPoolEntry &a, const CTxMemPoolEntry &b) {
++ bool operator()(const CTxMemPoolEntry &a, const CTxMemPoolEntry &b) const {
+ bool fUseADescendants = UseDescendantScore(a);
+ bool fUseBDescendants = UseDescendantScore(b);
+
+@@ -272,7 +272,7 @@ class CompareTxMemPoolEntryByDescendantScore {
+ }
+
+ // Calculate which score to use for an entry (avoiding division).
+- bool UseDescendantScore(const CTxMemPoolEntry &a) {
++ bool UseDescendantScore(const CTxMemPoolEntry &a) const {
+ double f1 = double(a.GetSizeWithDescendants() *
+ a.GetModifiedFee().GetSatoshis());
+ double f2 =
+@@ -287,7 +287,7 @@ class CompareTxMemPoolEntryByDescendantScore {
+ */
+ class CompareTxMemPoolEntryByScore {
+ public:
+- bool operator()(const CTxMemPoolEntry &a, const CTxMemPoolEntry &b) {
++ bool operator()(const CTxMemPoolEntry &a, const CTxMemPoolEntry &b) const {
+ double f1 = double(b.GetTxSize() * a.GetModifiedFee().GetSatoshis());
+ double f2 = double(a.GetTxSize() * b.GetModifiedFee().GetSatoshis());
+ if (f1 == f2) {
+@@ -299,14 +299,14 @@ class CompareTxMemPoolEntryByScore {
+
+ class CompareTxMemPoolEntryByEntryTime {
+ public:
+- bool operator()(const CTxMemPoolEntry &a, const CTxMemPoolEntry &b) {
++ bool operator()(const CTxMemPoolEntry &a, const CTxMemPoolEntry &b) const {
+ return a.GetTime() < b.GetTime();
+ }
+ };
+
+ class CompareTxMemPoolEntryByAncestorFee {
+ public:
+- bool operator()(const CTxMemPoolEntry &a, const CTxMemPoolEntry &b) {
++ bool operator()(const CTxMemPoolEntry &a, const CTxMemPoolEntry &b) const {
+ double aFees = double(a.GetModFeesWithAncestors().GetSatoshis());
+ double aSize = a.GetSizeWithAncestors();
+